Results 1 to 3 of 3

Thread: kdeinit starts 200 konquerorprocesses

  1. #1
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default kdeinit starts 200 konquerorprocesses

    This is still a openSUSE 13.1 system (the reason that it is still not newer is in one keyword: KDE).

    Nevertheless there might be people here that can comment on what we experience.

    The system being out of support already for a long time, no patches, updates or even new packages are installed already for a long time. One would say that such a system will be as stable as a rock.

    But since a few weeks, running KDE, programs refuse to start or start with strange results. After trying all sorts of combinations, two are presented below:
    When Firefox runs, Kmail can not be started (bouncing icon and nothing).
    When Kmail runs, Firefox will start but present: this tab crashed.

    Starting kmail after Firefox (first case) from the terminal:
    Code:
    marian@beneden:~> kmail
    Maximum number of clients reachedkbuildsycoca running...
    DCOP Cleaning up dead connections.
    Maximum number of clients reachedkmail: cannot connect to X server :0
    DCOP aborting call from 'anonymous-4515' to 'kmail'
    marian@beneden:~>
    .
    In the second case Firfox has more to tell, but the "Maxiumum number of clients" is prominent.

    Checking the process list it shows about 200 konqueror processes:
    Code:
    marian    3489     1  0 14:34 ?        00:00:00 kdeinit4: kdeinit4 Running...                  
    marian    3490  3489  0 14:34 ?        00:00:00 kdeinit4: klauncher [kdeinit] --fd=9           
    marian    3511  3489  0 14:34 ?        00:00:01 kdeinit4: ksmserver [kdeinit]                  
    marian    3577  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 10c6cadc650001398079695
    marian    3578  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 10c6cadc650001398082314
    marian    3579  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 10c6cadc650001398964423
    marian    3580  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 10c6cadc650001399137513
    marian    3581  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 10c6cadc650001399301354
    marian    3582  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 
    ............
    marian    3866  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 10c6cadc650001558549890
    marian    3867  3489  0 14:34 ?        00:00:00 kdeinit4: konqueror [kdeinit] -session 10c6cadc650001558939845
    These konquror processes aren't there with another user loged in on the same system.
    They return immediatly after logout-login for this user "marian".

    It will be clear that other (combinations of) programs will fail on other points. when they try to open one window more then the maxiumum resulting in a confusing number of errors and failures.

    To me it seems that these konqueror processes are the root problem. They do not result in any visible window on the desktop. But why do they start?
    Henk van Velden

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,882
    Blog Entries
    3

    Default Re: kdeinit starts 200 konquerorprocesses

    Quote Originally Posted by hcvv View Post
    To me it seems that these konqueror processes are the root problem. They do not result in any visible window on the desktop. But why do they start?
    I don't have a 13.1 system around to check. So this is based on 15.1.

    If I go to:
    Settings --> Configure Konqueror

    then I see a "Performance" tab. There's are boxes for:
    • Preload an instance after desktop startup;
    • Always try to have one preloaded instance.


    In experience, these cause problems. So I uncheck both boxes. Then I shutdown konqueror. Then I check if it is still running, and kill (with the "kill" command). Then, when I restart, it behaves better.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: kdeinit starts 200 konquerorprocesses

    YES!

    It looks a bit different. Both were not checked, but there was a "preloaded" number set to 1. I set it to 0.

    Then I had a nice task in killing all the 200 processes. But they do not return on login!

    Must be some old error that adds one at every login instead of just sticking to one.

    My wife is very happy now!.

    Thanks a lot.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •