Results 1 to 4 of 4

Thread: ODROID C2 eMMC Boot

  1. #1

    Default ODROID C2 eMMC Boot

    Hello,

    I hoping someone may be able to help or point me in the right direction.

    First, I would like to thank whomever has been updating the image here:
    http://download.opensuse.org/reposit...roidC2/images/

    Thank You. I stumbled upon that page after noticing the download link on this page is dead: https://en.opensuse.org/HCL:OdroidC2

    I am currently using the openSUSE-Tumbleweed-ARM-JeOS-odroidc2.aarch64-2019.05.17-Build4.11.raw.xz image for my testing.

    I am able to get my C2 to boot from an SD Card.
    A few things I have noticed. The blue alive LED does not flash when powering on the device while using this image. There are also no boot messages when powering on the device.

    I have tried other distros, including the ODROID Mate that came preinstalled on the eMMC chip. Booting with those other distros does activate the 'alive' LED and show boot messages.

    I can boot normally without error using the preinstalled OS on the eMMC chip. The eMMC booting with the openSUSE image is not working for me at all. Is it possible to boot this image from eMMC? Is there something I am missing?
    I have verified the image with the sha256sum. I do not know what the .packages file is. Could anyone point me in the direction of some documentation?

    When I first started down this trail I was using Build 8 of the image. I could not get that image to boot at all from neither the SD card nor the eMMC. I did try the method outlined here with a little luck:
    https://forums.opensuse.org/showthre...ghlight=odroid
    I was able to get the Build 8 image to boot from the SD card, but there quite a few failures listed in the boot messages.
    Since Build 10, I have been able to boot from SD card without using this method. Thanks.

    Does anyone have any insight on the eMMC booting, the lack of boot messages, lack of blue led activity, or the purpose of the .packages file?
    Any help would be greatly appreciated.

    Regards,

    RandomName

  2. #2

    Default Re: ODROID C2 eMMC Boot

    I'm not near my C2 right now so I can't address the lights and boot messages questions, but I can at least confirm that booting from eMMC does work. I've got a 64GB module on mine with the Tumbleweed image and it works as expected, so don't give up hope. I assume you've dd'ed the module more than once?

    As for the flashing blue LED, now that I think about it, I don't think mine does either. It's behavior can be set by setting a trigger value in some /sys file that I can never remember, and I don't think opensuse bothered to set it. So your lack of blinkenlights should not be interpreted as a problem, at least in its own.

    If no one else responds soon, I'll have a look at mine tonight to see if I can come up with any other ideas.

  3. #3

    Default Re: ODROID C2 eMMC Boot

    Okay, I've had a little chance to play with my C2. Definitely no flashing blue LED. I don't have a monitor on mine (running as a headless server), but I don't remember having much luck seeing anything on the console while it was booting. Something about when the video output was active or not (I don't think it is during boot). Anyway, you can try a couple of things to replay various log messages:

    Code:
    dmesg
    journalctl -p 3 -xb
    The latter replays systemd messages since the last boot. By limiting to priority 3, you get errors and warnings. If you do -p 4 instead, you'll get more information (the highest is 7). Unfortunately, that means you have to have at least partially booted, which it sounds like your eMMC hasn't.

    I didn't save my JeOS image, so I can't tell you which version I installed - it was over a year ago - but I did notice that a Build4.17 was uploaded today. Perhaps try again with that? The .packages file just lists all the RPMs that were included in the install file, so it can be safely ignored. All I can really suggest is download the new version, dd it to your eMMC card according to the directions, and make sure the sync at the end of the command completes before you pull the module. (Doing an "eject /dev/sdX" where X is the module device letter wouldn't be a bad idea either.) Good luck!

  4. #4

    Default Re: ODROID C2 eMMC Boot

    Thank You for the help and insight.

    Unfortunately, I am still unable to boot from eMMC.
    I wiped the eMMC using gparted.
    I downloaded build 17 and verified the checksum.
    I elevated to root and ran:
    Code:
    xzcat [image].raw.xz | dd bs=4M of=/dev/sdX iflag=fullblock oflag=direct; sync
    When that completed, I ejected the eMMC.
    Code:
    eject /dev/sdb
    Still no boot at all.

    If I reflash the original image back to the eMMC, the C2 boots into Ubuntu.
    I seem to be at a loss here. I will continue to tinker around. Maybe there is a clue in the boot files for the Ubuntu image.

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •