Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

  1. #1

    Default OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    OpenSuSE Leap 15.1 suffers from a 90 seconds delay during shutdown/reboot.
    Here are the relevant lines of a log file I managed to produce.
    Anyone an idea what is going on here?

    [ 76.984308] systemd[1]: klog.service: Failed to send unit remove signal for klog.service: Transport endpoint is not connected
    [ 76.984320] systemd[1]: winbind.service: Failed to send unit remove signal for winbind.service: Transport endpoint is not connected
    [ 77.002581] systemd[1]: Hardware watchdog 'iTCO_wdt', version 0
    [ 77.002600] systemd[1]: Set hardware watchdog to 10min.
    [ 77.002606] watchdog: watchdog0: watchdog did not stop!
    [ 77.015101] systemd-shutdown[1]: Sending SIGTERM to remaining processes...
    [ 77.019276] systemd-journald[473]: Failed to forward syslog message: Connection refused
    [ 77.019471] systemd-journald[473]: Failed to forward syslog message: Connection refused
    [ 77.019593] systemd-journald[473]: Received SIGTERM from PID 1 (systemd-shutdow).
    [ 77.019608] systemd-journald[473]: systemd-journald stopped as pid 473
    [ 167.020886] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
    [ 167.027376] systemd-shutdown[1]: Sending SIGKILL to PID 484 (lvmetad).

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    Hi, I witnessed something similar during the beta phase but apparently with different logs: see https://bugzilla.opensuse.org/show_bug.cgi?id=1129476
    But I must say that I haven't seen that behaviour after the General Availability release, so I was thinking of closing that bug report.
    Apparently it is something HW related and I was wondering if somebody else witnessed that odd 90 s delay...
    Let me know if I can do some further testing.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    I read your link.
    Every time I followed these these instructions:.

    > boot to multi-user.target (just adding '3' to the boot command line)
    > login as root and issue 'systemctl isolate graphical.target' on VT1
    > login as normal desktop user via GDM (desktop shows on VT2)
    > logout as 'root' from VT1
    > work on the desktop (VT2) as usual, reboot or shutdown from desktop when finished.

    the shutdown time was normal. But as soon as I booted default to the graphical desktop, the 90seconds delay came back when shutting down.

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    Quote Originally Posted by EdVaessen View Post
    I read your link.
    ...the shutdown time was normal. But as soon as I booted default to the graphical desktop, the 90seconds delay came back when shutting down.
    Well, at least the problem seems reproducible on your system, with Leap 15.1 beta I had some 2 "normal" reboots out of 5 and now after the official release every reboot was fine so far.
    I think that joining the bug report with your results is a good idea, apparently there are very few of us witnessing this and the developers may not be able to reproduce and fix this problem without our help.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    Hello,

    Looking at this line, I realized that lvmetad was the service that was delaying things.

    [ 167.027376] systemd-shutdown[1]: Sending SIGKILL to PID 484 (lvmetad).

    As I do not need LVM, I deleted the following packages:

    liblvm2app2_2
    liblvm2cmd2_02
    lvm2

    The service has vanished and shutdown is no longer delayed now.

    I added my comments to the bug report.

  6. #6
    Join Date
    Sep 2012
    Posts
    5,124

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    Quote Originally Posted by EdVaessen View Post
    Anyone an idea what is going on here?
    Code:
    [   77.015101] systemd-shutdown[1]: Sending SIGTERM to remaining processes...
    [ 167.020886] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
    [  167.027376] systemd-shutdown[1]: Sending SIGKILL to PID 484 (lvmetad)
    Process lvmetad ignores SIGTERM. Do you use LVM?

  7. #7
    Join Date
    Nov 2009
    Location
    Somerset, UK
    Posts
    249

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    I also have this problem with two desktop PCs. They have both been upgraded with the Leap 15.1 DVD from 15.0. The systems have different hardware except they both have the same Radeon HD 6450 1GB graphics. I will try deleting liblvm2app2_2, liblvm2cmd2_02, lvm2 as suggested above and see what happens.
    ......but when it comes to computers, I've forgotten more than I ever knew.

  8. #8
    Join Date
    Nov 2009
    Location
    Somerset, UK
    Posts
    249

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    Thank you EdVaessen, removing lvm2 etc has fixed my problem.
    ......but when it comes to computers, I've forgotten more than I ever knew.

  9. #9
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    A possibly related thread is here: https://www.mail-archive.com/dm-deve.../msg02361.html
    Somewhat similar troubles on Arch here: https://bugs.archlinux.org/task/50420

    Apparently lvmetad ignores SIGTERM and a 90s timeout is triggered, but the details are beyond my understanding,
    It seems that this behaviour has been around for some time and the 90s timeout was introduced in systemd 231, so we should see this problem also in Leap 15.0.
    Maybe something has changed in the boot/shutdown timing in Leap 15.1 so that now some systems trigger the undesired timeout.
    Until somebody comes up with a better fix, I'm just running with all lvm services disabled since I don't use lvm at all on the troubled laptop.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,615
    Blog Entries
    3

    Default Re: OpenSuSE Leap 15.1 shutdown/reboot delay of 90 seconds

    I am using LVM. But I am not seeing problems.

    There was one occasion when shutting down seemed to have an unnecessary delay. But it hasn't happened since. And I did not check logs for that one occasion, so I'm not sure what happened. Mostly by 15.1 shutdowns are reasonably fast.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •