Results 1 to 5 of 5

Thread: Folder view applications icons problem

  1. #1

    Default Folder view applications icons problem

    Hi, there!
    I've a leap 15.1 fresh installation with KDE desktop environment.
    I added a "folder view" widget to the desktop. And then, I copied some applications (e.g. Firefox) from "Applications Menu" to that folder.
    When I click on the Firefox icon on the folder on the desktop, it opens KWrite showing the content of "Firefox.desktop" file instead to run Firefox application.

    The content of "Firefox.desktop" file is:
    Code:
    [Desktop Entry]
    Categories=Network;WebBrowser;GTK;
    Encoding=UTF-8
    Name=Firefox
    GenericName=Web Browser
    Comment=Web Browser
    TryExec=firefox
    Exec=firefox %u
    Icon=firefox
    Terminal=false
    StartupNotify=true
    MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;application/x-xpinstall;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;
    Type=Application
    
    
    Actions=PrivateBrowsing;
    
    
    [Desktop Action PrivateBrowsing]
    Name=New Private Browsing Window
    Exec=firefox --private-window %u
    If I link the application, instead of copy, from "Applications Menu" to the folder, I get the same result.

    I think I have to change some setting to get the application running by clicking in its icon on folder view, but I can't find it.

    Can sombody help me?

    Thank you very much.
    [Adrián E. Córdoba]

  2. #2
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    154

    Default Re: Folder view applications icons problem

    If you right-click on firefox.desktop, then select »Properties«, do you get an »Application« tab?



    You then should be able to fine-tune what will happen in »Advanced Options«.

  3. #3

    Default Re: Folder view applications icons problem

    Thank you for reply, unix111!
    I tried with the Advanced Options, like Run in a Terminal, but I get the same result.
    [Adrián E. Córdoba]

  4. #4
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    154

    Default Re: Folder view applications icons problem

    Quote Originally Posted by aecordoba View Post
    I tried with the Advanced Options, like Run in a Terminal, but I get the same result.
    If you create a new user account with YaST for testing and try the same with that new user, can you then launch Firefox from the desktop? If yes, the problem is local to your standard user; if no, the problem is system-wide. Maybe we then can go from there.

  5. #5

    Default Re: Folder view applications icons problem

    Quote Originally Posted by unix111 View Post
    If you create a new user account with YaST for testing and try the same with that new user, can you then launch Firefox from the desktop? If yes, the problem is local to your standard user; if no, the problem is system-wide. Maybe we then can go from there.
    Thank you, unix111!
    But I found the solution to my problem in Internet.

    I change the property "behaviourOnLaunch" to "execute" in "~/.config/kiorc" file. (I don't know, where this property is in System Settings window.)

    Thank you very much.
    [Adrián E. Córdoba]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •