Results 1 to 3 of 3

Thread: after upgrade from Leap 15.0 KMyMoney crashes in XFCE, but works in KDE

  1. #1
    Join Date
    Jul 2008
    Location
    Warrington, England
    Posts
    111

    Default after upgrade from Leap 15.0 KMyMoney crashes in XFCE, but works in KDE

    After upgrade from Leap 15 (where KMyMoney works OK in XFCE) to Leap 15.1, the application KMyMoney crashes, and does not load. After many re-loadings of both KMyMoney and reinstalls of LEAP 15.1 XFCE to computer including a fresh install not an upgrade KMyMoney still crashes.
    When KDE desktop environment added to fresh install, so choice of XFCE or KDE being possible; then:
    a) KDE opens KMyMoney OK.
    b) XFCE still crashes.
    Bug reported to KDE team, but it may be a XFCE package problem.

    When starting in terminal under: gbd output of gdb bt gives

    Thread 1 "kmymoney" received signal SIGSEGV, Segmentation fault.
    0x00007ffff2f2595a in QWidgetPrivate::showChildren(bool) ()
    from /usr/lib64/libQt5Widgets.so.5
    (gdb) bt
    #0 0x00007ffff2f2595a in QWidgetPrivate::showChildren(bool) ()
    from /usr/lib64/libQt5Widgets.so.5
    #1 0x00007ffff2f25a8f in QWidgetPrivate::show_helper() ()
    from /usr/lib64/libQt5Widgets.so.5
    #2 0x00007ffff2f2878b in QWidget::setVisible(bool) ()
    from /usr/lib64/libQt5Widgets.so.5
    #3 0x00007ffff2f259e0 in QWidgetPrivate::showChildren(bool) ()
    from /usr/lib64/libQt5Widgets.so.5
    #4 0x00007ffff2f25a8f in QWidgetPrivate::show_helper() ()
    from /usr/lib64/libQt5Widgets.so.5
    #5 0x00007ffff2f2878b in QWidget::setVisible(bool) ()
    from /usr/lib64/libQt5Widgets.so.5
    #6 0x00005555555f0edc in runKMyMoney (splash=..., file=...,
    noFile=<optimized out>, a=...)
    at /usr/src/debug/kmymoney-5.0.4-lp151.1.1.x86_64/kmymoney/main.cpp:332
    #7 0x00005555555efb93 in main (argc=<optimized out>, argv=<optimized out>)
    at /usr/src/debug/kmymoney-5.0.4-lp151.1.1.x86_64/kmymoney/main.cpp:243
    (gdb)


    Has anyone else this bug?
    How to sort?
    How to report to XFCE?

    regards and thanks in advance.
    Eionmac
    Regards
    Eionmac
    openSUSE LEAP 15.1 , Windows 10 ; Various old computers dual boot and Live Linux distros

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,447
    Blog Entries
    2

    Default Re: after upgrade from Leap 15.0 KMyMoney crashes in XFCE, but works in KDE

    I'd recommend reporting through the openSUSE bugzilla (https://bugzilla.opensuse.org.
    With 15.1, I see significant changes to the core/base components pattern, my guess is that the previous pattern provided some components that aren't in the new pattern, and the application package wasn't built against the new pattern (simply updated from previous package).

    Be sure to create a proper debug log and include with your report.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jul 2008
    Location
    Warrington, England
    Posts
    111

    Default Re: after upgrade from Leap 15.0 KMyMoney crashes in XFCE, but works in KDE

    Quote Originally Posted by tsu2 View Post
    I'd recommend reporting through the openSUSE bugzilla (https://bugzilla.opensuse.org.
    With 15.1, I see significant changes to the core/base components pattern, my guess is that the previous pattern provided some components that aren't in the new pattern, and the application package wasn't built against the new pattern (simply updated from previous package).

    Be sure to create a proper debug log and include with your report.

    TSU
    How to do "Be sure to create a proper debug log and include with your report.". I have no experience of this, but can follow (I hope) instructions. Please advise how to do or provide link to instructions.

    [Meanwhile added KDE to system and it operates KMyMoney no problem. However I prefer XFCE.]
    Thanks in advance
    Regards
    Eionmac
    openSUSE LEAP 15.1 , Windows 10 ; Various old computers dual boot and Live Linux distros

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •