Results 1 to 3 of 3

Thread: How to turn off pulseaudio

  1. #1

    Default How to turn off pulseaudio

    Hi,

    I'm using my Opensuse also for producing music. Ardour is my program of choice at the moment. Since it requires jack I use to turn off pulseaudio before.

    It always worked pretty well that way. I only executed

    sudo setup-pulseaudio --disable

    and pulseaudio went to sleep. Then I started jack via QjackCtl and everything was fine.

    But after the last Online Update with Yast things are not the same. At first pulse didn't start up at all. I tried a little and finally it worked again after changing the version of the pulseaudio package from 11.1.lp150.4.1-x86_64 (from openSUSE-Leap-15.0-Oss with priority 99 and vendor openSUSE) to 12.2-lp150.11.2-x86_64 (from multimedia:libs with priority 99 and vendor obs://build.opensuse.org/multimedia)

    So pulse was working again.

    But now I am no more able to turn it off. The above command still gives the same output (at least i guess so. Maybe there used to be a line containing the terms "disabling" and "autospawn", which are not there anymore). But it doesn't have the same effect. Pulse is still on.

    pulseaudio --kill seems to give pulse a little pause. But after one second it's back again.

    I edited /etc/pulse/client.conf and set "; autospawn = yes" to "autospawn = no" (yes, I also removed the semicolon) but it always spawns back again as soon as I kill it.

    What can I do? Please help me.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,645

    Default Re: How to turn off pulseaudio

    There is a jack PA module (pulseaudio-module-jack)which should allow most jack dependent program to work with PA.

    Also you can turn off PA if you really really don't want it in Yast-Sound

  3. #3

    Default Re: How to turn off pulseaudio

    The solution was:

    Uninstalling that pulseaudio-module-jack.
    And now I am able to start jack and work with it without turning off PA before. Never thought that's possible. It always caused problems in the past.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •