Results 1 to 7 of 7

Thread: D-Feet does not work

  1. #1
    Join Date
    Nov 2016
    Location
    Moscow
    Posts
    31

    Post D-Feet does not work

    I've install D-Feet like this:
    Code:
    sudo zypper in d-feet
    I expect to explore d-bus interfaces of running programs, like here:

    But, actually right column is now shown (seems bug). I can see only available buses, but not the corresponding interface.

    If it is important - my desktop environment is KDE Plasma.
    May I fully use D-Feet?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: D-Feet does not work

    Could it be you have to run the program with root permissions? You might get some info about what's happening by starting d-feet from a terminal window, then look at it's output in that terminal window.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Nov 2016
    Location
    Moscow
    Posts
    31

    Default Re: D-Feet does not work

    Quote Originally Posted by Knurpht View Post
    Could it be you have to run the program with root permissions? You might get some info about what's happening by starting d-feet from a terminal window, then look at it's output in that terminal window.
    If run with root permissions:
    Code:
    kdesu d-feet
    The app still does not work.

    If just from terminal, when i selected a bus - exception is outputted:
    Code:
    $ d-feet
    Traceback (most recent call last):
      File "/usr/lib/python3.6/site-packages/dfeet/bus_watch.py", line 205, in __listbox_row_selected_cb
        connection_is_bus=True)
      File "/usr/lib/python3.6/site-packages/dfeet/introspection.py", line 57, in __init__
        ui.connect_signals(signal_dict)
      File "/usr/lib/python3.6/site-packages/dfeet/uiloader.py", line 49, in connect_signals
        self.ui.connect_signals(obj_or_map)
    ValueError: Pointer arguments are restricted to integers, capsules, and None. See: https://bugzilla.gnome.org/show_bug.cgi?id=683599

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: D-Feet does not work

    Any added repos? Please show
    Code:
    zypper lr -d
    EDIT: FWIW, I've installed d-feet on Tumbleweed, works as expected.
    Last edited by Knurpht; 15-Apr-2019 at 10:16.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Nov 2016
    Location
    Moscow
    Posts
    31

    Default Re: D-Feet does not work

    Quote Originally Posted by Knurpht View Post
    Any added repos? Please show
    Code:
    zypper lr -d
    EDIT: FWIW, I've installed d-feet on Tumbleweed, works as expected.
    Code:
     zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    
    #  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+---------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | NVIDIA                    | NVIDIA                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.0                           |
     2 | code                      | Visual Studio Code                      | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://packages.microsoft.com/yumrepos/vscode                           |
     3 | google-chrome             | google-chrome                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                      |
     4 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/      |
     5 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/  |
     6 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/oss/                 |
     7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/non-oss/             |
     8 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/        |
     9 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/            |
    10 | repo-source               | openSUSE-Leap-15.0-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/     |
    11 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/ |
    12 | repo-update               | openSUSE-Leap-15.0-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                       |
    13 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                   |
    14 | sublime-text              | Sublime Text - x86_64 - Stable          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.sublimetext.com/rpm/stable/x86_64                       |
    15 | teamviewer                | TeamViewer - x86_64                     | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://linux.teamviewer.com/yum/stable/main/binary-x86_64/               |

  6. #6
    Join Date
    Nov 2016
    Location
    Moscow
    Posts
    31

    Default Re: D-Feet does not work

    Screenshot about the problem: https://www.dropbox.com/s/6u3zdmi1fz...blems.png?dl=0 (i've selected a bus, but can not see dbus interface).
    I've installed D-Feet also about 8 months ago - and met the same problem.
    Any ideas?

  7. #7
    Join Date
    Nov 2016
    Location
    Moscow
    Posts
    31

    Default Re: D-Feet does not work

    Quote Originally Posted by Knurpht View Post
    EDIT: FWIW, I've installed d-feet on Tumbleweed, works as expected.
    Tumbleweed has 0.3.14 version of d-feet, when leap 15.0 only 0.3.13.
    Any chance that openSuse could provide 0.3.14? Seems, leap 15.1 also has only 0.3.13 version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •