Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Driver Nvidia and Kernel5.1 dont work

  1. #11

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    Thanks a lot, but this did not work for me.

    Code:
    ...
    -> Kernel module compilation complete.-> Unable to determine if Secure Boot is enabled: No such file or directory
    x120
    [  216.638788]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
    [  216.638789] RIP: 0033:0x7f8a327b2449
    [  216.638790] Code: 00 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 1f 4a 0c 00 f7 d8 64 89 01 48
    [  216.638791] RSP: 002b:00007ffefdad12b8 EFLAGS: 00000ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.
    
    
    Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.
    -> Kernel module load error: No such device
    -> Kernel messages:
    [  216.638774]  ? __vunmap+0x79/0xb0
    [  216.638775]  ? kmem_cache_alloc_trace+0x1bf/0x240
    [  216.638778]  do_init_module+0x5c/0x220
    [  216.638780]  load_module+0x13c4/0x15a0
    [  216.638782]  ? __do_sys_finit_module+0x91/0xe0
    [  216.638783]  __do_sys_finit_module+0x91/0xe0
    [  216.638785]  do_syscall_64+0x60/0246 ORIG_RAX: 0000000000000139
    [  216.638792] RAX: ffffffffffffffda RBX: 0000000002056460 RCX: 00007f8a327b2449
    [  216.638793] RDX: 0000000000000000 RSI: 00000000004252f0 RDI: 0000000000000005
    [  216.638793] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
    [  216.638794] R10: 0000000000000005 R11: 0000000000000246 R12: 00000000004252f0
    [  216.638795] R13: 0000000000000000 R14: 0000000002076110 R15: 0000000000000000
    [  216.638796] ---[ end trace 4b37d0ddefddcc47 ]---
    [  216.638798] NVRM: failed to register procfs!
    [  216.638876] NVRM: request_mem_region failed for 16M @ 0xfd000000. This can
                   NVRM: occur when a driver such as rivatv is loaded and claims
                   NVRM: ownership of the device's registers.
    [  216.638897] nvidia: probe of 0000:01:00.0 failed with error -1
    [  216.639215] NVRM: The NVIDIA probe routine failed for 1 device(s).
    [  216.639216] NVRM: None of the NVIDIA graphics adapters were initialized!
    [  216.639217] [drm] Module unloaded
    ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

    nouveau is blacklisted.
    GeForce 8800 GTX, openSUSE Tumbleweed x86_64

  2. #12
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by gaedcke View Post
    Thanks a lot, but this did not work for me.

    Code:
    ...
    -> Kernel module compilation complete.-> Unable to determine if Secure Boot is enabled: No such file or directory
    x120
    [  216.638788]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
    [  216.638789] RIP: 0033:0x7f8a327b2449
    [  216.638790] Code: 00 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 1f 4a 0c 00 f7 d8 64 89 01 48
    [  216.638791] RSP: 002b:00007ffefdad12b8 EFLAGS: 00000ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.
    
    
    Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.
    -> Kernel module load error: No such device
    -> Kernel messages:
    [  216.638774]  ? __vunmap+0x79/0xb0
    [  216.638775]  ? kmem_cache_alloc_trace+0x1bf/0x240
    [  216.638778]  do_init_module+0x5c/0x220
    [  216.638780]  load_module+0x13c4/0x15a0
    [  216.638782]  ? __do_sys_finit_module+0x91/0xe0
    [  216.638783]  __do_sys_finit_module+0x91/0xe0
    [  216.638785]  do_syscall_64+0x60/0246 ORIG_RAX: 0000000000000139
    [  216.638792] RAX: ffffffffffffffda RBX: 0000000002056460 RCX: 00007f8a327b2449
    [  216.638793] RDX: 0000000000000000 RSI: 00000000004252f0 RDI: 0000000000000005
    [  216.638793] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
    [  216.638794] R10: 0000000000000005 R11: 0000000000000246 R12: 00000000004252f0
    [  216.638795] R13: 0000000000000000 R14: 0000000002076110 R15: 0000000000000000
    [  216.638796] ---[ end trace 4b37d0ddefddcc47 ]---
    [  216.638798] NVRM: failed to register procfs!
    [  216.638876] NVRM: request_mem_region failed for 16M @ 0xfd000000. This can
                   NVRM: occur when a driver such as rivatv is loaded and claims
                   NVRM: ownership of the device's registers.
    [  216.638897] nvidia: probe of 0000:01:00.0 failed with error -1
    [  216.639215] NVRM: The NVIDIA probe routine failed for 1 device(s).
    [  216.639216] NVRM: None of the NVIDIA graphics adapters were initialized!
    [  216.639217] [drm] Module unloaded
    ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

    nouveau is blacklisted.
    Hi
    How was the patch applied?

    I used (as my user) to patch;
    Code:
    ./NVIDIA-Linux-x86_64-340.107.run --apply-patch 340.107_5.1.patch
    Install (as root user at multi-user level) via;
    Code:
    ./NVIDIA-Linux-x86_64-340.107-custom.run -aq
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #13

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    How was the patch applied?

    I used (as my user) to patch;
    Code:
    ./NVIDIA-Linux-x86_64-340.107.run --apply-patch 340.107_5.1.patch
    Install (as root user at multi-user level) via;
    Code:
    ./NVIDIA-Linux-x86_64-340.107-custom.run -aq
    Ok, will try it that way. I did
    Code:
     patch -p0 -l --verbose < patchSUSE
    
    in extracted .run directory without error...
    GeForce 8800 GTX, openSUSE Tumbleweed x86_64

  4. #14

    Red face Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    How was the patch applied?

    I used (as my user) to patch;
    Code:
    ./NVIDIA-Linux-x86_64-340.107.run --apply-patch 340.107_5.1.patch
    Install (as root user at multi-user level) via;
    Code:
    ./NVIDIA-Linux-x86_64-340.107-custom.run -aq
    Bingo, this did it! Thanks a lot, you made my week .
    GeForce 8800 GTX, openSUSE Tumbleweed x86_64

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by gaedcke View Post
    Bingo, this did it! Thanks a lot, you made my week .
    Hi
    Just don't panic if it stops working after an update... just boot to multi-user target and rebuild the driver, reboot and enjoy
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #16

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Just don't panic if it stops working after an update... just boot to multi-user target and rebuild the driver, reboot and enjoy


    New trouble. Rebuilt for Kernel 5.1.15 and 5.1.16, Driver freezes boot at

    Code:
    ... Starting X Display Manager...         Starting Locale Service...
    nvidia-xconfig did not change that.
    GeForce 8800 GTX, openSUSE Tumbleweed x86_64

  7. #17
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by gaedcke View Post
    New trouble. Rebuilt for Kernel 5.1.15 and 5.1.16, Driver freezes boot at

    Code:
    ... Starting X Display Manager...         Starting Locale Service...
    nvidia-xconfig did not change that.
    Hi
    So the driver rebuilt and installed ok? No errors in the /var/log/nvidia-installer.log?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #18

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So the driver rebuilt and installed ok? No errors in the /var/log/nvidia-installer.log?
    All ok, no errors there.
    GeForce 8800 GTX, openSUSE Tumbleweed x86_64

  9. #19
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by gaedcke View Post
    All ok, no errors there.
    Hi
    The nouveau driver is still blacklisted? File should exist in /etc/modprobe.d/ if it exists, can you rebuild initrd as root user with the command mkinitrd.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #20

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    The nouveau driver is still blacklisted? File should exist in /etc/modprobe.d/ if it exists, can you rebuild initrd as root user with the command mkinitrd.
    Yes it is. Plus nomodeset in boot options. No success. Something wrong with default xorg.conf/nvidia-xconfig maybe?
    GeForce 8800 GTX, openSUSE Tumbleweed x86_64

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •