Results 1 to 5 of 5

Thread: zypper update/dup/up doesnt work :(

  1. #1

    Post zypper update/dup/up doesnt work :(

    This is the O/P in bash .... pls help


    Problem retrieving files from 'openSUSE-20190517-0'.
    Empty destination in URI: hd:/?device=/dev/sdb2
    Please see the above error message for a hint.
    Warning: Skipping repository 'openSUSE-20190517-0' because of the above error.
    Some of the repositories have not been refreshed because of an error.
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...


    Nothing to do.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: zypper update/dup/up doesnt work :(

    Quote Originally Posted by horneD_Owl View Post
    This is the O/P in bash .... pls help
    Empty destination in URI: hd:/?device=/dev/sdb2
    You use a USB for installation. And that "empty destination" is the USB. You could just plug it in to avoid that error.

    However, better still would be to disable or remove that USB as a repo.

    Fire up: Yast --> Software Repositories

    That will list your repos. Look for the one that has that "hd:/?device=" string in the URL. And change that to disabled (uncheck the "enable" box). Click on "Okay" or "Finish" (or "Accept" -- I don't remember the exact wording, but it should obvious). After exiting Yast, try your "zypper dup" again. Note, however, that you only just installed so there might not be much to update.

    And please note the message "Please Don't Ask Product Questions Here". You posted in the wrong forum. I will move to a more appropriate place.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: zypper update/dup/up doesnt work :(

    Closing thread for now. Will move to "Install/Boot/Login" and then reopen.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: zypper update/dup/up doesnt work :(

    Thread moved and reopened.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,836
    Blog Entries
    2

    Default Re: zypper update/dup/up doesnt work :(

    Is this still happening in Tumbleweed?
    Has been addressed in 15.1 (auto removal of install source repo).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •