Results 1 to 6 of 6

Thread: Getting rid of packagekit

  1. #1

    Default Getting rid of packagekit

    I'd like to gte rid of packagekit. Leap 15.0 is installed on a very small network that doesn't have any internet access.

    I'd like to deal with the least possible of hassles. zypper remove seems to try to remove other stuff.

    Alternative 1

    remove from packagekit-background.cron from cron.daily

    Alternative 2

    modifiy /etc/sysconfig/packagekit-background with

    Code:
    ENABLED=no ==> yes
    CHECK_ONLY=no ==> yes
    UPDATE_OFFLINE=no ==>yes
    Thanks

  2. #2
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    189

    Default Re: Getting rid of packagekit

    Quote Originally Posted by elfroggio View Post
    I'd like to gte rid of packagekit. Leap 15.0 is installed on a very small network that doesn't have any internet access.

    I'd like to deal with the least possible of hassles. zypper remove seems to try to remove other stuff.
    Although my main rig is connected to a DSL router, I like a lean, minimal and efficient system too. I prefer to use the Software Management module in YaST because there’s something to be said about graphically and interactively experimenting with package dependencies, and about the many ways YaST can display package information. After a fresh install and reboot, I usually first disable and uninstall whatever I won’t need (Plymouth, wicked, Baloo, NetworkManager, ntpd, Samba, smartd, sddm, all *-lang packages and so on, your mileage may vary). Whenever YaST thinks there are unresolved dependencies, I still can choose whether I'd like to keep it, risk dangling dependencies, uninstall those dependent packages as well — and/or set the packages to »taboo«.

    Occasionally I check for any package recommendations via »Extras/Install All Matching Recommended Packages« (see screenshot), and I use the following commands to quickly log or look up what I had locked:
    Code:
    rig:~ ▶ zypper ll | grep -i packagekit
    8   | PackageKit                       | package | (any)     
    9   | PackageKit-gstreamer-plugin      | package | (any)     
    10  | PackageKit-lang                  | package | (any)     
    68  | gnome-packagekit-lang            | package | (any)
    rig:~ ▶ zypper ll | wc -l # how many taboo packages?
    345
    rig:~ ▶ zypper ll > Documents/rig/lp150/zypper-ll-20190517-taboo.text # save taboo package list for future reference
    As you can see, I have uninstalled — and later set to taboo, or »locked« — 4 packageKit packages. Cheers!


  3. #3
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,075

    Default Re: Getting rid of packagekit

    Quote Originally Posted by elfroggio View Post
    I'd like to gte rid of packagekit. Leap 15.0 is installed on a very small network that doesn't have any internet access.

    I'd like to deal with the least possible of hassles. zypper remove seems to try to remove other stuff.

    Alternative 1

    remove from packagekit-background.cron from cron.daily

    Alternative 2

    modifiy /etc/sysconfig/packagekit-background with

    Code:
    ENABLED=no ==> yes
    CHECK_ONLY=no ==> yes
    UPDATE_OFFLINE=no ==>yes
    Thanks
    Packagekit is triggered by timer:

    Code:
    erlangen:~ # systemctl list-unit-files packagekit*
    UNIT FILE                         STATE  
    packagekit-background.service     static 
    packagekit-offline-update.service static 
    packagekit.service                static 
    packagekit-background.timer       enabled
    
    4 unit files listed.
    erlangen:~ #
    Disabling the timer is hasslefree.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  4. #4

    Default Re: Getting rid of packagekit

    Quote Originally Posted by karlmistelberger View Post
    Packagekit is triggered by timer:

    Code:
    erlangen:~ # systemctl list-unit-files packagekit*
    UNIT FILE                         STATE  
    packagekit-background.service     static 
    packagekit-offline-update.service static 
    packagekit.service                static 
    packagekit-background.timer       enabled
    
    4 unit files listed.
    erlangen:~ #
    Disabling the timer is hasslefree.
    ...and what should be the command to disable the timer?
    becouse mine is different
    Code:
    pla@pla4-TW:~> systemctl list-unit-files packagekit*
    UNIT FILE          STATE 
    packagekit.service static
    
    1 unit files listed.

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,075

    Default Re: Getting rid of packagekit

    Quote Originally Posted by pier_andreit View Post
    ...and what should be the command to disable the timer?
    becouse mine is different
    Code:
    pla@pla4-TW:~> systemctl list-unit-files packagekit*
    UNIT FILE          STATE 
    packagekit.service static
    
    1 unit files listed.
    Since several weeks packagekit is additionally started on behalf of logged in users; it went unnoticed by me. The easiest way to disable is masking the service: systemctl mask packagekit.service see also: https://www.thegeekdiary.com/centos-...ia-packagekit/
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  6. #6

    Default Re: Getting rid of packagekit

    Excellent

    Thank you very much

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •