Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

  1. #11
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    46

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Code:
    he following 68 package updates will NOT be installed:
      0ad 0ad-data armagetron circuslinux csmash exo-branding-openSUSE exo-data exo-helpers exo-lang ffmpeg-4
      frozen-bubble frozen-bubble-lang frozen-bubble-server gnuchess gstreamer-plugins-bad gstreamer-plugins-bad-lang
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libavcodec58 libavdevice58 libavfilter7 libavformat58
      libavresample4 libavutil56 libexo-1-0 libexo-2-0 libgloox17 libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0
      libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstisoff-1_0-0 libgstmpegts-1_0-0
      libgstphotography-1_0-0 libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0 libjsoncpp19 libopenal1
      libopusfile0 libpostproc55 libqqwing2 libquicktime0 libSDL-1_2-0 libSDL2-2_0-0 libSDL_gfx15 libSDL_image-1_2-0
      libSDL_mixer-1_2-0 libSDL_Pango1 libSDL_ttf-2_0-0 libsox3 libswresample3 libswscale5 libvlc5 libvlccore9
      libwayland-egl1 openal-soft-data patterns-games-games phalanx solarwolf sox vlc vlc-codec-gstreamer vlc-lang
      vlc-noX vlc-qt vlc-vdpau

  2. #12
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Quote Originally Posted by LMH1 View Post
    Code:
    he following 68 package updates will NOT be installed:
      0ad 0ad-data armagetron circuslinux csmash exo-branding-openSUSE exo-data exo-helpers exo-lang ffmpeg-4
      frozen-bubble frozen-bubble-lang frozen-bubble-server gnuchess gstreamer-plugins-bad gstreamer-plugins-bad-lang
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libavcodec58 libavdevice58 libavfilter7 libavformat58
      libavresample4 libavutil56 libexo-1-0 libexo-2-0 libgloox17 libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0
      libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstisoff-1_0-0 libgstmpegts-1_0-0
      libgstphotography-1_0-0 libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0 libjsoncpp19 libopenal1
      libopusfile0 libpostproc55 libqqwing2 libquicktime0 libSDL-1_2-0 libSDL2-2_0-0 libSDL_gfx15 libSDL_image-1_2-0
      libSDL_mixer-1_2-0 libSDL_Pango1 libSDL_ttf-2_0-0 libsox3 libswresample3 libswscale5 libvlc5 libvlccore9
      libwayland-egl1 openal-soft-data patterns-games-games phalanx solarwolf sox vlc vlc-codec-gstreamer vlc-lang
      vlc-noX vlc-qt vlc-vdpau
    Hi
    Likely due to the repositories, if you use;

    Code:
    zypper -vvv dup
    This will show more info on what it is doing/not doing.

    Anyway, let's not worry about that for the moment, can you edit the grub file I indicated and run the command to rebuild grub, reboot and show the lspci information again.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #13
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    46

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Still got the same result, try to sudo nano /etc/modprobe.d/blacklist.conf add blacklist radeon but it did not help.
    Any idea?

  4. #14
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    46

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Its works now after a upgrade of distribution.

  5. #15
    Join Date
    Jun 2019
    Location
    São Paulo - Brazil
    Posts
    15

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Hello. It is my first time using Opensuse and I feel like I have a problem similar to that reported by the author of the topic. Yesterday I installed the Dolphin emulator and couldn't use Vulkan as a backend, so I tried to follow the same steps, but I'm having problems after editing the grub configuration.

    Here is my lspci output

    Code:
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP] [1002:6819]
            Subsystem: Gigabyte Technology Co., Ltd Device [1458:2553]
            Kernel driver in use: radeon
            Kernel modules: radeon, amdgpu

    xf86-video-amdgpu is already installed

    So I edited "etc/default/grub" and added the line amdgpu.cik_support = 1 amdgpu.si_support = 0 at the end of file and save. When running mkinitrd, i got this error:

    Code:
    Creating initrd: /boot/initrd-5.1.7-1-default
    dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-5.1.7-1-default 5.1.7-1-default
    dracut: dracut module 'lvm' will not be installed, because command 'lvm' could not be found!
    dracut: dracut module 'lvm' will not be installed, because command 'lvm' could not be found!
    dracut: *** Including module: bash ***
    dracut: *** Including module: systemd ***
    dracut: *** Including module: warpclock ***
    dracut: *** Including module: systemd-initrd ***
    dracut: *** Including module: i18n ***
    dracut: *** Including module: drm ***
    dracut: Possible missing firmware "amdgpu/vega20_ta.bin" for kernel module "amdgpu.ko"
    dracut: *** Including module: plymouth ***
    dracut: *** Including module: btrfs ***
    dracut: *** Including module: kernel-modules ***
    dracut: *** Including module: rootfs-block ***
    dracut: *** Including module: suse-btrfs ***
    dracut: *** Including module: suse-xfs ***
    dracut: *** Including module: terminfo ***
    dracut: *** Including module: udev-rules ***
    dracut: Skipping udev rule: 40-redhat.rules
    dracut: Skipping udev rule: 50-firmware.rules
    dracut: Skipping udev rule: 50-udev.rules
    dracut: Skipping udev rule: 91-permissions.rules
    dracut: Skipping udev rule: 80-drivers-modprobe.rules
    dracut: *** Including module: dracut-systemd ***
    dracut: *** Including module: haveged ***
    dracut: *** Including module: ostree ***
    dracut: *** Including module: usrmount ***
    dracut: *** Including module: base ***
    dracut: *** Including module: fs-lib ***
    dracut: *** Including module: shutdown ***
    dracut: *** Including module: suse ***
    dracut: *** Including modules done ***
    dracut: *** Installing kernel module dependencies and firmware ***
    dracut: *** Installing kernel module dependencies and firmware done ***
    dracut: *** Resolving executable dependencies ***
    dracut: *** Resolving executable dependencies done***
    dracut: *** Hardlinking files ***
    dracut: *** Hardlinking files done ***
    dracut: *** Stripping files ***
    dracut: *** Stripping files done ***
    dracut: *** Generating early-microcode cpio image ***
    dracut: *** Constructing AuthenticAMD.bin ****
    dracut: *** Store current command line parameters ***
    dracut: Stored kernel commandline:
    dracut:  root=UUID=73403f98-fca3-43ce-9736-ffde01a6e3a2 rootfstype=btrfs rootflags=rw,relatime,space_cache,subvolid=268,subvol=/@/.snapshots/1/snapshot,subvol=@/.snapshots/1/snapshot
    dracut: *** Creating image file '/boot/initrd-5.1.7-1-default' ***
    dracut: *** Creating initramfs image file '/boot/initrd-5.1.7-1-default' done ***
    update-bootloader: 2019-06-19 22:12:13 <3> update-bootloader-2171 run_command.294: '/usr/lib/bootloader/grub2/config' failed with exit code 127, output:
    <<<<<<<<<<<<<<<<
    + /usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg
    /etc/default/grub: line 45: amdgpu.cik_support: command not found
    >>>>>>>>>>>>>>>>
    Updating bootloader failed

    What am I doing wrong? I'm adding the line in the wrong place; editing the wrong file, the missing firmware on line 11 is the problem or am I missing something? Any help will be aprecciate.

  6. #16
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,654

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    You put terms at the end of the linelinux or linuxefir not the end of the file

  7. #17
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,374
    Blog Entries
    3

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Quote Originally Posted by McCloud View Post
    So I edited "etc/default/grub" and added the line amdgpu.cik_support = 1 amdgpu.si_support = 0 at the end of file and save.
    Remove those added lines.

    The run Yast bootloader. Add your parameters to the kernel command line parameters (use the "Kernel Parameters" tab to find that).
    openSUSE Leap 15.1; KDE Plasma 5;

  8. #18
    Join Date
    Jun 2019
    Location
    São Paulo - Brazil
    Posts
    15

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Quote Originally Posted by nrickert View Post
    Remove those added lines.

    The run Yast bootloader. Add your parameters to the kernel command line parameters (use the "Kernel Parameters" tab to find that).


    Like this?

  9. #19
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,374
    Blog Entries
    3

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    Quote Originally Posted by McCloud View Post
    Like this?
    Yes, like that.
    openSUSE Leap 15.1; KDE Plasma 5;

  10. #20
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    431

    Default Re: Opensuse tumlewee how to play doom vulcan with R9 280\HD7970\HD6870

    I might be wrong, but it seems to me that you shouldn't have spaces before or after the "=" sign. example: "amdgpu.cik_support = 1 amdgpu.si_support = 0" should be "amdgpu.c​ik_support=1 amdgpu.si_support=0". Like I said, I might be wrong about this.
    "Making rich people richer doesn't make the rest of us richer."
    Ha-Joon Chang

    openSUSE 15.0 4.12.14-lp150.12.45-default x64

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •