Results 1 to 7 of 7

Thread: Virtualhost | Localhost

  1. #1

    Default Virtualhost | Localhost

    Hallo,

    ich versuche die Anwendung CRUD Admin Generator ans Laufen zu bekommen, was sich etwas problematisch gestaltet. Vielleicht weiß jemand Rat.

    Also, ich habe sie soweit installiert, aber es hakt, z. B. bei der Definition des virtualhost. Man soll ihn so definieren:
    Code:
    <VirtualHost *:80>
       DocumentRoot /path_to/admingenerator/web 
       DirectoryIndex index.php
       <Directory "/path_to/admingenerator/web">
            Options Indexes FollowSymLinks
            Order Allow,Deny
            Allow from all
            AllowOverride all
            <IfModule mod_php5.c>
               php_admin_flag engine on
               php_admin_flag safe_mode off
               php_admin_value open_basedir none
            </ifModule>
       </Directory>
    </VirtualHost>
    Meine Variante mit Pfad:
    Code:
    <VirtualHost *:80>
       DocumentRoot /srv/www/htdocs/admingenerator/web 
       DirectoryIndex index.php
       <Directory "/srv/www/htdocs/admingenerator/web">
            Options Indexes FollowSymLinks
            Order Allow,Deny
            Allow from all
            AllowOverride all
            <IfModule mod_php5.c>
               php_admin_flag engine on
               php_admin_flag safe_mode off
               php_admin_value open_basedir none
            </ifModule>
       </Directory>
    </VirtualHost>
    Damit kann apache2 nicht mehr gestartet werden: Zeile 6 und 7 ("Order Allow,Deny" und "Allow from all") sollen fehlerhaft sein. Wenn ich die auskommentiere mit "#", startet apache2 wieder, aber aufrufen kann ich "admingenerator" immer noch nicht. Mir scheint zudem der Entrag mod_php5.c nicht in Ordnung zu sein, da ich php7 installiert habe. Vermutlich muss es in mod_php7.c geändert werden.

    Mit "You can customize the url using the .htaccess file, maybe this will help you: http://stackoverflow.com/questions/24952846/how-do-i-remove-the-web-from-my-url/24953439#24953439" kann ich gar nichts anfangen.

    Den Resources-Eintrag habe ich so gelassen.

    Mit der folgenden virtualhost-Variante im File admingenerator.conf im Verzeichnis vhosts.d und einer Änderung in hosts startet apache2 wieder, aber alle anderen Projekte unter localhost laufen nicht mehr.
    Ich habe nun folgendes versucht:
    Code:
    <VirtualHost *:80>
       DocumentRoot /srv/www/htdocs/admingenerator/web 
       ServerAlias www.admingenerator.de
       DirectoryIndex index.php
       <Directory "/srv/www/htdocs/admingenerator/web">
            Options Indexes FollowSymLinks
            #Order Allow,Deny
            #Allow from all
            AllowOverride all
            <IfModule mod_php5.c>
               php_admin_flag engine on
               php_admin_flag safe_mode off
               php_admin_value open_basedir none
            </ifModule>
       </Directory>
    </VirtualHost>
    
    ---------------------------- 
    
    hosts:
    
    127.0.0.1    localhost www.admingenerator.de             #war vorher ohne www.admingenerator.de
    www.admingenerator.de kann nun aufgerufen werden, und es wird ein Bildschirm wie in Screenshot 2 (http://crud-admin-generator.com/ ca. Miitte des Bildschirms) angezeigt, aber wenn man eine Tabelle auswählt, z. B. actor, sind die Anwendungen "List" und "Create" nicht aufrufbar (404, Objekt nicht gefunden!). Im Verzeichnis /views/actor findet man auch keine create.php-File sondern create.html.twig. Vielleicht muss das so sein, ich weiß es nicht.

    Hat jemand eine Idee, was ich tun kann, damit das Ding läuft und auch die anderen Anwendungen unter localhost gleichzeitig laufen?

    Gruß

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: Virtualhost | Localhost

    Und alles in /srv/www/htdocs ist wwwrun:www ?
    Was gibt's in /var/log/apache2/error.log mit '404' ?
    Schau auch mal
    Code:
    sudo a2enmod -l
    an.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default AW: Virtualhost | Localhost

    Und alles in /srv/www/htdocs ist wwwrun:www ?
    Nein, ist alles user4711:users.

    Was gibt's in /var/log/apache2/error.log mit '404' ?
    Nichts.

    Code:
    sudo a2enmod -l
    $ actions alias auth_basic authn_core authn_file authz_host authz_groupfile authz_core authz_user autoindex cgi dir env expires include log_config mime negotiation php7 setenvif ssl socache_shmcb userdir reqtimeout version

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: Virtualhost | Localhost

    EDIT: Verzeihung

    Try / Versuch mal
    Code:
    sudo chown wwwrun:www /srv/www/htdocs/admin* -R
    and try accessing the pages again./ und dann wieder die website laden.
    Last edited by Knurpht; 09-May-2019 at 09:55.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default AW: Virtualhost | Localhost

    No difference / kein Unterschied.

  6. #6

    Default AW: Virtualhost | Localhost

    Quote Originally Posted by Duplexity View Post
    Hallo,


    Damit kann apache2 nicht mehr gestartet werden: Zeile 6 und 7 ("Order Allow,Deny" und "Allow from all") sollen fehlerhaft sein. Wenn ich die auskommentiere mit "#", startet apache2 wieder, aber aufrufen kann ich "admingenerator" immer noch nicht. Mir scheint zudem der Entrag mod_php5.c nicht in Ordnung zu sein, da ich php7 installiert habe. Vermutlich muss es in mod_php7.c geändert werden.
    Apache 2.4 unterstützt die Direktive "Order" nicht mehr. Lösche die beiden Zeilen und ersetze Sie durch

    Code:
    ...
    Require all granted
    ...

  7. #7

    Default AW: Virtualhost | Localhost

    Kein Unterschied.
    Ich muss das mal checken, wenn ich mal viel Zeit habe. Danke an alle einstweilen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •