Results 1 to 4 of 4

Thread: [kubic] installation requires wpa_supplicant, which is not in repo

  1. #1

    Default [kubic] installation requires wpa_supplicant, which is not in repo

    Hi,

    I am trying to install openSUSE Kubic on a machine that has a WiFi card on board.
    During installation from the boot image, I get the error in Installation Settings step

    "These packages need to be selected to install: wpa_supplicant
    Please manually select the needed items to install.

    And installation will not allow me to skip this check.

    However, I cannot figure out how to either
    a) install wpa_supplicant
    As far as I can tell it is not included in the microos repository, and I also don't see an option to add an additional repo
    b) ignore the error -- I don't intend to use the WiFi card

    Any suggestions on how to proceed with the install are appreciated!

    Thanks,
    Ben

  2. #2

    Default Re: [kubic] installation requires wpa_supplicant, which is not in repo

    Hmm, looks like I incidentally found a workaround:

    - go through installation steps, including Network Settings setup once (so I can set the static IP and DNS settings)
    - now, installation cannot be completed due to missing wpa_supplicant
    - abort installation
    - start installation again
    - observe that static IP and DNS settings are remembered
    - do not enter Network Configuration again (the wpa_supplicant will again block installation, if the network config is entered once, even when no changes are done)
    - install works

    Perhaps a bug in yast with kubic?

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,610
    Blog Entries
    1

    Default Re: [kubic] installation requires wpa_supplicant, which is not in repo

    If wpa_suplicant is missing, please submit a bug to https://bugzilla.opensuse.org

    AFAIK practically every openSUSE version should have wpa_supplicant installed, whether it's needed or no. If a decision was made to exclude it by default, the logic obviously wasn't installed to install it as a dependency should it be needed.

    Have you "Enabled Online Repositories" if that option is presented to you?

    TSU
    Last edited by malcolmlewis; 07-May-2019 at 19:51. Reason: Fix URL
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4

    Default Re: [kubic] installation requires wpa_supplicant, which is not in repo


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •