Results 1 to 5 of 5

Thread: Viber10 = New problems

  1. #1

    Default Viber10 = New problems

    Hi , All

    Have a New problem with Viber.
    ( https://download.cdn.viber.com/desktop/Linux/viber.rpm )
    Look:
    Code:
    kkk@kaph:~/Downloads/viber> rpm -Uvh viber.rpm  --test
    error: Failed dependencies:
        gstreamer1(x86-64) is needed by viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-bad-free(x86-64) is needed by viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-base(x86-64) is needed by viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-good(x86-64) is needed by viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-ugly-free(x86-64) is needed by viber-10.3.0.37-2.x86_64
        libcrypto.so.10()(64bit) is needed by viber-10.3.0.37-2.x86_64
        libssl.so.10()(64bit) is needed by viber-10.3.0.37-2.x86_64
    kkk@kaph:~/Downloads/viber> uname -a
    Linux kaph 4.12.14-lp150.12.58-default #1 SMP Mon Apr 1 15:20:46 UTC 2019 (58fcc15) x86_64 x86_64 x86_64 GNU/Linux
    kkk@kaph:~/Downloads/viber>
    Where i can found
    gstreamer1(x86_64) and
    gstreamer1-plugins-bad-free(x86-64)
    gstreamer1-plugins-base(x86-64)
    gstreamer1-plugins-good(x86-64)
    gstreamer1-plugins-ugly-free(x86-64)
    by my Leap15 ?

    Serg

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,976

    Default Re: Viber10 = New problems

    I do not say it will help in your case, but
    • Why do you not intsall with zypper instead of rpm? zypper will at least try to satisfy depedencies from the repos it knows about.
    • Do you have the Packman repo enables in your repo list? Because I assume this is about multi-media and that is were functioning multi-media livraries come from.
    Henk van Velden

  3. #3

    Default Re: Viber10 = New problems

    Hi, Thank you for answer

    Zypper didn`t resolver this problem



    About packman - yes.
    Code:
    > sudo zypper lr
    Repository priorities in effect:                                                     (See 'zypper lr -P' for details)
          90 (raised priority)  :  1 repository  
          99 (default priority) : 11 repositories
    
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh
    ---+-------------------------------------+-----------------------------------------+---------+-----------+--------
     1 | azure-cli                           | Azure CLI                               | Yes     | (r ) Yes  | No     
     2 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes    
     3 | download.opensuse.org-non-oss_1     | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes    
     4 | download.opensuse.org-oss           | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes    
     5 | download.opensuse.org-oss_1         | Main Update Repository                  | Yes     | (r ) Yes  | Yes    
     6 | http-download.opensuse.org-53d154d2 | home:so_it_team                         | Yes     | (r ) Yes  | Yes    
     7 | http-download.opensuse.org-7bf35913 | multimedia:libs                         | Yes     | (r ) Yes  | Yes    
     8 | http-download.opensuse.org-ec64b533 | openSUSE:Leap:15.1:Update               | Yes     | (r ) Yes  | Yes    
     9 | openSUSE-Leap-15.0-1                | openSUSE-Leap-15.0-1                    | Yes     | (r ) Yes  | Yes    
    10 | packages-microsoft-com-prod         | packages-microsoft-com-prod             | Yes     | (r ) Yes  | Yes    
    11 | packman.inode.at-suse               | Packman Repository                      | Yes     | (r ) Yes  | Yes    
    12 | repo-debug                          | openSUSE-Leap-15.0-Debug                | No      | ----      | ----   
    13 | repo-debug-non-oss                  | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----   
    14 | repo-debug-update                   | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----   
    15 | repo-debug-update-non-oss           | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----   
    16 | repo-source                         | openSUSE-Leap-15.0-Source               | No      | ----      | ----   
    17 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----   
    18 | skype-stable                        | skype (stable)                          | Yes     | (

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,976

    Default Re: Viber10 = New problems

    Thanks. So far for my very general suggestions. Let us wait if somebody with Viber experience tunes in.

    BTW, next time beter copy/paste that zypper trial complete, better then just telling things is showing, then others can see what you did and what you got. May be that leads to suggestions.

    And zypper lr does not tell the crucial thing: which repos. Because the URL is what defines a repo and not the name and alias (they are local to the sytem and may be good suggestions at the most). You get the URL included with e.g.
    Code:
    zypper lr -d
    Henk van Velden

  5. #5

    Default Re: Viber10 = New problems

    Hello there.

    Now I have the same issue with Leap 15.1. Some time ago I have already had this issue with Leap 15.0 like topic starter described it but somehow I got my Viber to work well on it but I can't remember what were exactly those steps which led me to the goal. So I perform a search and found this thread.

    Actually I've checked those libraries that Viber wants to depend on and saw that all of them are already present in the system but they have not exact the same name that Viber wants to see.



    The issue lays in that the Viber starts well but it can't see an Internet connection and therefore can't proceed next to messaging.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •