Results 1 to 6 of 6

Thread: yast2 problem

  1. #1

    Default yast2 problem

    These days it happened to me that using Yast to update, it didn't update, since I always try twice I saw that the update hadn't happened, I proceeded to do it again staying in front of the computer, in the end for security I used also zypper dup. Now going to see in yast> history this message comes out, after which the history comes out normally, I went to see the error line to delete it, but it is a simple line as you can see from the image posted, there is something it escapes me ?


    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,399

    Default Re: yast2 problem

    You should update Tumbleweed only with
    Code:
    zypper dup
    I am not sure what you did with YaST, but it is not obvious to to the equivalent of zypper dup with YaST, thus I doubt you did that.

    So please, first do that zypper dup and check if your problem persists.

    Edit: Hm, I see that you already tried a zypper dup and that it did not help.

    Maybe then do a
    Code:
    zypper clean
    zypper ref
    Last edited by hcvv; 28-Apr-2019 at 06:11.
    Henk van Velden

  3. #3

    Default Re: yast2 problem

    Already done everything you propose to me, it is only a chronological problem that displays an error that in reality is not there, everything works we say that it is a false problem ..... but it must not be
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  4. #4

    Default Re: yast2 problem

    When I open the file with kate this message comes out
    Code:
    The / var / log / zypp / history file was opened with UTF-8 encoding, but contained invalid characters.
    It is set to read-only mode, because saving it could destroy its contents.
    Reopen the file choosing the right encoding, or re-enable the reading and writing mode in the tools menu to be able to modify it.
    It is not by chance that I cannot see what is written in line # 55855 so that I can delete it
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,332

    Default Re: yast2 problem

    Quote Originally Posted by enziosavio View Post
    ... It is not by chance that I cannot see what is written in line # 55855 so that I can delete it
    Try using okteta https://software.opensuse.org/package/okteta

    ... or you could just rename the history file and allow the history to start afresh with a new file.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191211) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  6. #6

    Default Re: yast2 problem

    Quote Originally Posted by tannington View Post
    Try using okteta https://software.opensuse.org/package/okteta

    ... or you could just rename the history file and allow the history to start afresh with a new file.
    Thanks, I had already renamed to see if I had problems, I definitely deleted the file
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •