Results 1 to 5 of 5

Thread: Leap 15.0 wants to update to Tumbleweed?

  1. #1

    Default Leap 15.0 wants to update to Tumbleweed?

    Hey, I'm relatively new to OpenSuse and a ran into the same Problem already twice, and I didn't find any solution for it so far online.
    .
    I tried to install KBibTex through https://software.opensuse.org/ (and I did not check for which distro is was supposed) and while installing there was a conflict, which I tried to avoid by choosing "Ignore Dependencies". After the installation was finished, it did not work (kind of what I expected) I uninstalled it and I thought I was done.

    But now to my Problem. When I'm trying to run zypper update, it seems like it wants to upgrade my distro to Tumbleweed. I get this output:
    Code:
    mraeth@linux-s2d3:~> sudo zypper up
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    
    The following 1158 package updates will NOT be installed:
     ...
    
    The following 121 NEW packages are going to be installed:
    ve-translator texlive-translator-doc tree vlan xml-commons-apis yast2-qt-branding-openSUSE
    
    The following NEW pattern is going to be installed:
      kde_pim
    
    The following 7 packages are going to be REMOVED:
      gtk3-schema mkfontdir openal-soft pciutils-ids translation-update-en translation-update-en_US xerces-j2-xml-apis
    
    The following 3350 packages are going to be upgraded:
     ...
    
    The following 29 patterns are going to be upgraded:
      apparmor apparmor_opt base enhanced_base enhanced_base_opt fonts fonts_opt games imaging imaging_opt kde kde_games kde_imaging
      kde_internet kde_multimedia kde_office kde_plasma kde_utilities kde_utilities_opt laptop minimal_base multimedia multimedia_opt
      office sw_management x11 x11_enhanced x11_opt x11_yast
    
    The following product is going to be upgraded:
      openSUSE Leap 15.0  15.0-1 -> 20190423-0
        Product 'openSUSE Tumbleweed' requires to be updated by calling 'zypper dup'!
    
    The following 5 packages are going to change architecture:
      grub2-x86_64-efi        x86_64 -> noarch
      nodejs-common           noarch -> x86_64
      openSUSE-build-key      noarch -> x86_64
      oxygen5-sounds          x86_64 -> noarch
      xorg-x11-libX11-ccache  noarch -> x86_64
    
    3350 packages to upgrade, 121 new, 7 to remove, 5 to change arch.
    Overall download size: 1.45 GiB. Already cached: 0 B. After the operation, additional 572.2 MiB will be used.
    
        Consider to cancel:
        Product 'openSUSE Tumbleweed' requires to be updated by calling 'zypper dup'!
    Continue? [y/n/...? shows all options] (y): n
    I'm currently running Leap 15
    Code:
    Linux linux-s2d3 4.12.14-lp150.12.58-default #1 SMP Mon Apr 1 15:20:46 UTC 2019 (58fcc15) x86_64 x86_64 x86_64 GNU/Linux
    mraeth@linux-s2d3:~> cat /etc/
    Display all 298 possibilities? (y or n)
    mraeth@linux-s2d3:~> cat /etc/*release
    NAME="openSUSE Leap"
    VERSION="15.0"
    ID="opensuse-leap"
    ID_LIKE="suse opensuse"
    VERSION_ID="15.0"
    PRETTY_NAME="openSUSE Leap 15.0"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:leap:15.0"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://www.opensuse.org/"
    The first time, this occurred I just installed the factory image over it, but I'm not very keen on doing this every time. Thanks for the help!

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,265

    Default Re: Leap 15.0 wants to update to Tumbleweed?

    What repositories have you enabled

    Code:
    sudo zypper lr -d
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3

    Default Re: Leap 15.0 wants to update to Tumbleweed?

    This is the outpu:
    Code:
    Repository priorities in effect:                                                                                                                                                                                                               (See 'zypper lr -P' for details)
          90 (raised priority)  :  1 repository  
          99 (default priority) :  5 repositories
    
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/        |        
     2 | download.opensuse.org-non-oss_1     | Update Repository (Non-Oss)             | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                   |        
     3 | download.opensuse.org-oss           | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/            |        
     4 | download.opensuse.org-oss_1         | Main Update Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss                        |        
     5 | http-download.opensuse.org-8aafefad | openSUSE:Factory                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                        |        
     6 | openSUSE-Leap-15.0-1                | openSUSE-Leap-15.0-1                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/            |        
     7 | packman                             | packman                                 | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/       |        
     8 | repo-debug                          | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/      |        
     9 | repo-debug-non-oss                  | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/  |        
    10 | repo-debug-update                   | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.0/oss/                 |        
    11 | repo-debug-update-non-oss           | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.0/non-oss/             |        
    12 | repo-source                         | openSUSE-Leap-15.0-Source               | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/     |        
    13 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/ |

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,265

    Default Re: Leap 15.0 wants to update to Tumbleweed?

    Remove #5 (openSUSE:Factory)
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5

    Default Re: Leap 15.0 wants to update to Tumbleweed?

    Perfect, thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •