Results 1 to 5 of 5

Thread: leap 15.0 : Susefirewalld - how to import a running config of susefirewall2 ( leap 42.3 )

  1. #1
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,024

    Default leap 15.0 : Susefirewalld - how to import a running config of susefirewall2 ( leap 42.3 )

    Hello.
    I have a firewall config running on a Leap 42.3 laptop.
    I have installed leap 15.0 on a new laptop.
    How can I import the susefirewall2 config to the leap 15.0 machine?

    I have installed the package susefirewall2-to-firewalld, put the file susefirewall2 from the 42.3 machine to the leap 15 machine.
    The script susefirewall2-to-firewalld failed due to an error relative to ip6tables >= 1.4.20, but my current version leap 15 is 1.6.21
    Any help is welcome.
    Thanks for helping. JCD
    __________

    server leap 15-- ASUS g75vw KDE leap 42.3 -- ASUS g750JZ KDE leap 42.3 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,923
    Blog Entries
    2

    Default Re: leap 15.0 : Susefirewalld - how to import a running config of susefirewall2 ( leap 42.3 )

    Quote Originally Posted by jcdole View Post
    Hello.
    I have a firewall config running on a Leap 42.3 laptop.
    I have installed leap 15.0 on a new laptop.
    How can I import the susefirewall2 config to the leap 15.0 machine?

    I have installed the package susefirewall2-to-firewalld, put the file susefirewall2 from the 42.3 machine to the leap 15 machine.
    The script susefirewall2-to-firewalld failed due to an error relative to ip6tables >= 1.4.20, but my current version leap 15 is 1.6.21
    Any help is welcome.
    You'll have to be specific what the error says.
    And, that'll be required whether your problem is solved in this Forum or reported to Bugzilla.

    BTW -
    The script used for the migration can be found here
    https://github.com/openSUSE/susefire...2-to-firewalld

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,024

    Default Re: leap 15.0 : Susefirewalld - how to import a running config of susefirewall2 ( leap 42.3 )

    Quote Originally Posted by tsu2 View Post
    You'll have to be specific what the error says.
    And, that'll be required whether your problem is solved in this Forum or reported to Bugzilla.

    BTW -
    The script used for the migration can be found here
    https://github.com/openSUSE/susefire...2-to-firewalld

    TSU
    I have given all what I got :
    ip6tables >= 1.4.20, but my current version leap 15 is 1.6.21
    If you read carefully my post i have already installed susefirewall2-to-firewalld. And this tools give me the described error 'ip6tables >= 1.4.20, is needed'.

    And my question is rather how to install a running config from 42.3 to leap 15.
    Thanks for helping. JCD
    __________

    server leap 15-- ASUS g75vw KDE leap 42.3 -- ASUS g750JZ KDE leap 42.3 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  4. #4
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,024

    Default Re: leap 15.0 : Susefirewalld - how to import a running config of susefirewall2 ( leap 42.3 )

    I must add that ipv6 is disabled in kernel and in network setting.
    Thanks for helping. JCD
    __________

    server leap 15-- ASUS g75vw KDE leap 42.3 -- ASUS g750JZ KDE leap 42.3 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,923
    Blog Entries
    2

    Default Re: leap 15.0 : Susefirewalld - how to import a running config of susefirewall2 ( leap 42.3 )

    Quote Originally Posted by jcdole View Post
    I have given all what I got :


    If you read carefully my post i have already installed susefirewall2-to-firewalld. And this tools give me the described error 'ip6tables >= 1.4.20, is needed'.

    And my question is rather how to install a running config from 42.3 to leap 15.
    Your error is obviously does not include the words "relative to" and "but my current version leap 15 is"
    If you provide analysis, it should be provided separated from the error.
    When you describe an error, it should be verbatim and not include your analysis.
    In any case, I found the error checking in the script

    Lines 271-274
    Code:
    # Check we can actually use iptables -wif [[ ${tool} == ip*tables ]] && ! ${tool} -w -L > /dev/null 2>&1; then
        error "${tool} -w is not usable. ${tool} >= 1.4.20 is needed"
    fi
    If you're confident the error checking is faulty, then you can try removing those lines (or commenting them out).

    Of course, back up your IP tables before experimenting.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •