Results 1 to 9 of 9

Thread: New splash screen appeared on Tumbleweed

  1. #1
    Join Date
    Jan 2016
    Location
    UK
    Posts
    566

    Default New splash screen appeared on Tumbleweed

    Just done my usual zypper dup on Tumbleweed and now when I boot my ASUS Laptop I see an ASUS logo with the Tumbleweed logo beneath it. Really neat, wonder if it recognises other makes as well?

    Stuart
    Last edited by broadstairs; 14-Apr-2019 at 01:01. Reason: spelling

  2. #2
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    120

    Default Re: New splash screen appeared on Tumbleweed

    Does with Gigabyte. I suspect that it is not "recognizing" but has something to do with the new graphical logon process that SUSE has been working on as reported recently.

  3. #3
    Join Date
    Jan 2016
    Location
    UK
    Posts
    566

    Default Re: New splash screen appeared on Tumbleweed

    Just rebooted my desktop which is a home built but there is no logo. Obviously does not know either motherboard of processor! Perhaps there is an image somewhere which could be edited?

    Stuart

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,141

    Default Re: New splash screen appeared on Tumbleweed

    This perhaps ?

    https://build.opensuse.org/package/r...v=base&rev=285

    What snapshot are you using? I didn't think it had made it into TW yet, but I seem to be getting a lot wrong lately ...
    Regards, Paul

    Tumbleweed (Snapshot: 20190716) KDE Plasma 5
    Leap 15.0 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected]

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,185
    Blog Entries
    3

    Default Re: New splash screen appeared on Tumbleweed

    Quote Originally Posted by broadstairs View Post
    Just done my usual zypper dup on Tumbleweed and now when I boot my ASUS Laptop I see an ASUS logo with the Tumbleweed logo beneath it. Really neat, wonder if it recognises other makes as well?

    Stuart
    Yes, I rather like it. I normally don't use the splash screen, but I turned it on to test.

    I don't think it is recognizing your computer as an ASUS. Rather, it is using the screen from the BIOS. In my case, I was using a virtual machine (KVM), and it says "TianoCore" which comes from the OVMF firmware. I didn't try flash on the real physical computer that I updated yesterday.
    openSUSE Leap 15.1; KDE Plasma 5;

  6. #6
    Join Date
    Jan 2016
    Location
    UK
    Posts
    566

    Default Re: New splash screen appeared on Tumbleweed

    Quote Originally Posted by tannington View Post
    This perhaps ?

    https://build.opensuse.org/package/r...v=base&rev=285

    What snapshot are you using? I didn't think it had made it into TW yet, but I seem to be getting a lot wrong lately ...
    My branding-opensuse is 84.87.20180403-1.1 and grub2-branding-opensuse is the same version, are these the files in question?

    How does it get the logo to display?

    Stuart

  7. #7
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,141

    Default Re: New splash screen appeared on Tumbleweed

    Those are the same versions I have, I don't use plymouth so am not seeing the effect.

    OK, I've investigated a little further...

    If you look at the change log for grub2-branding-openSUSE:

    Wed 03 Apr 2019 13:00:00 BST
    Stasiek Michalski <***@***>
    - Rewrite the spec and makefile to make it easier to contibute
    - Change the default plymouth theme to bgrt
    The change to bgrt enables plymouth to use the UEFI boot/logo screen during the boot process.

    See:
    https://github.com/darac/plymouth-bgrt
    https://www.phoronix.com/forums/foru...oot-experience
    Regards, Paul

    Tumbleweed (Snapshot: 20190716) KDE Plasma 5
    Leap 15.0 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected]

  8. #8

    Default Re: New splash screen appeared on Tumbleweed

    I saw a hp logo here on a low res. but when I increase the resolution to 1920x1050 the logo disappeared.
    I haven't check if it will comeback if I switch to a low resolution in the boot loader.
    People who do not break things first will never learn to create anything

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,185
    Blog Entries
    3

    Default Re: New splash screen appeared on Tumbleweed

    Quote Originally Posted by tannington View Post
    The change to bgrt enables plymouth to use the UEFI boot/logo screen during the boot process.
    Yes, I see the boot logo screen on UEFI boxes. But on an older system with legacy BIOS, I only see a black screen with the Tumbleweed logo at the bottom.

    And for those who do not use encrypted disk:

    On booting with Plymouth, I first see a black screen with the Tumbleweed logo near the bottom. And there is a box for entering the encryption passphrase. That box is near the middle of the screen. The computer manufacturer's boot logo only shows up after entering the passphrase.

    Overall, I like the new plymouth screen. However, I will revert to my normal practice of not showing it, because I really prefer to see all of those boot messages.
    openSUSE Leap 15.1; KDE Plasma 5;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •