Results 1 to 3 of 3

Thread: Did someone forget the libcrypto43-devel files?

  1. #1

    Default Did someone forget the libcrypto43-devel files?

    I have been struggling to install the lightworks-14.5.0-amd64.rpm package, because it insisted upon finding some missing dependencies. I was able to solve the libcG dependency by adding non-oss repository and then installing cG. However lightworks keeps insisting upon finding libcrypto.so.10. Finally I realized that it needs the header files to be able to resolve the dependencies, so I went to install libcrypto43 from yast2.

    Guess what?

    Libcrypto43-devel is MISSING and there was a recent Bugzilla filing libreSSL bug # 1097779 dated late March this year where I verified that this file (or these files) are missing.

    Can some person at package development level add the missing libcrypto43-devel files to the build? This I would consider to be a major oversight.

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Did someone forget the libcrypto43-devel files?

    Without much knowledge or exposure to developing apps calling libcrypto, I wonder if it makes sense that there might be development headers?
    A quick Internet search turned up nothing.
    Also, libcrypto itself is a library, presumably ready to be used "as is" by an app, it's higher level apps like lib64openssl that would have a need to itself have development headers, but presumably not the lower level component packages like libcrypto..

    I could be completely wrong about my speculation on libcrypto headers...

    So, maybe it comes down to what purpose or scenario might be asking for libcrypto headers.

    As far as your libcrypto.so.10 dependency, that's been discussed numerous times in numerous Forum posts, the issue is a naming convention, IIRC you should symlink the lowest version libcrypto on your system which on my LEAP 15.0 are currently /usr/lib64/libcrypto.so.1.0.0 and /usr/lib64/libcrypto.so.1.1. If your app only requires a libcrypto version at least the minimum, then you might be able to symlink libcryto.so.43 or libcryptio.so.43.1

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Sep 2012
    Posts
    7,868

    Default Re: Did someone forget the libcrypto43-devel files?

    Quote Originally Posted by randallrathbun View Post
    Can some person at package development level add the missing libcrypto43-devel files to the build?
    You do realize that this is user to user forum, do not you? And if you want to reach somebody at package development, you need to open bug report?

    ... actually I suspect you need libressl-devel if you want development headers for libressl libraries.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •