Results 1 to 9 of 9

Thread: firefox: how to get rid of black popups

  1. #1

    Default firefox: how to get rid of black popups

    Hi, how to get rid of this black popups when I hoover the mouse on??
    https://susepaste.org/view//40146566

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,352
    Blog Entries
    3

    Default Re: firefox: how to get rid of black popups

    Technically, I don't think that's considered a popup. It is usually called a "mouse-over" or a "tool-tip".

    I don't know if there is a firefox setting to disable them. Just be careful where you move your mouse.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: firefox: how to get rid of black popups

    Looks like you use some color scheme that doesn't work OK with GTK apps. In the past I've seen the same in GIMP.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,162

    Default Re: firefox: how to get rid of black popups

    If that's what you really want ...

    Go to about:config and toggle "browser.chrome.toolbar_tips" to false.

    Additional info here: http://kb.mozillazine.org/Browser.chrome.toolbar_tips
    Last edited by tannington; 08-Apr-2019 at 09:06. Reason: added info link.
    Regards, Paul

    Tumbleweed (Snapshot: 20190814) KDE Plasma 5 ~~~
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    Leap 15.0 KDE Plasma 5 ~~~ Leap 15.1 KDE Plasma 5 (Work in progress...)

  5. #5

    Default Re: firefox: how to get rid of black popups

    Quote Originally Posted by tannington View Post
    If that's what you really want ...

    Go to about:config and toggle "browser.chrome.toolbar_tips" to false.

    Additional info here: http://kb.mozillazine.org/Browser.chrome.toolbar_tips
    manythanks tanningto but it doesn't works, or better, it works only for toolbar tool tips, for tool tips in the web page it doesnt works, so it works exactly in the contrary I would like, maintain the tool tips in the tool bar and hide in the web page

    Quote Originally Posted by Knurpht
    Looks like you use some color scheme that doesn't work OK with GTK apps. In the past I've seen the same in GIMP.

    my color scheme is OPENsuse, my GTK2 theme should be oxygen-gtk and gtk3 adwaita, I don't know what gtk is firefox
    but the annoying is the tool tip non only the color

    Quote Originally Posted by nrickert

    Technically, I don't think that's considered a popup. It is usually called a "mouse-over" or a "tool-tip".

    I don't know if there is a firefox setting to disable them. Just be careful where you move your mouse.
    the last you said is what I want to do, be careful where I move the mouse is very annoying


  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,162

    Default Re: firefox: how to get rid of black popups

    Quote Originally Posted by pier_andreit View Post
    manythanks tanningto but it doesn't works, ...
    OK - I guess you're on the latest, or a later version. I'm still on 52.9.0 ESR on which it does disable tool-tips, albeit all tool-tips not just on web pages. Hence my "If that's what you really want ..." - Although it's rather a moot point if it no longer works.

    There is another preference that you could try, "ui.tooltipDelay", which as it's name implies is the delay between hovering over an item and the display of the tool-tip. Although perhaps that may no longer work either, (I've tried it on 52.9.0 and it works as intended).

    This preference doesn't exist by default, so you will have to create a new one, of type "integer", named "ui.tooltipDelay", set the value to the delay time you desire. The time is in mS, so for example, if you wanted a 2 sec delay you would use 2000. (The default is 500ms).
    Regards, Paul

    Tumbleweed (Snapshot: 20190814) KDE Plasma 5 ~~~
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    Leap 15.0 KDE Plasma 5 ~~~ Leap 15.1 KDE Plasma 5 (Work in progress...)

  7. #7
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    151

    Default Re: firefox: how to get rid of black popups

    Quote Originally Posted by pier_andreit View Post
    Hi, how to get rid of this black popups when I hoover the mouse on??
    Looking into the HTML source, I am sure that the »title« tag of the »a href« element is responsible for these popups:
    Code:
    <a class="title threadtitle_unread" href="showthread.php/535525-MATE-Desktop-Indicators?highlight=mate+desktop+indicators" id="thread_title_535525" title="I have installed openSUSE Tumbleweed with MATE DE and I want to add the advanced indicators like in Ubuntu-MATE? I have installed Ayatana AFAIK is...">MATE Desktop Indicators.</a>
    If you are good at GreaseMonkey or the ad blocker of your choice, you can try modifying or altogether removing these »title« tags before the browser renders the HTML. You could even make it site-specific (or else you would lose those hidden mouse-over jokes in https://xkcd.com/ and other webcomics). However, sometimes these title tags are really informative (on the Linux Kernel Mailing List https://lkml.org/ for example) and can save you the additional mouse click.

    Any GreaseMonkey wizards around?

  8. #8

    Default Re: firefox: how to get rid of black popups

    Quote Originally Posted by tannington View Post
    OK - I guess you're on the latest, or a later version. I'm still on 52.9.0 ESR on which it does disable tool-tips, albeit all tool-tips not just on web pages. Hence my "If that's what you really want ..." - Although it's rather a moot point if it no longer works.

    There is another preference that you could try, "ui.tooltipDelay", which as it's name implies is the delay between hovering over an item and the display of the tool-tip. Although perhaps that may no longer work either, (I've tried it on 52.9.0 and it works as intended).

    This preference doesn't exist by default, so you will have to create a new one, of type "integer", named "ui.tooltipDelay", set the value to the delay time you desire. The time is in mS, so for example, if you wanted a 2 sec delay you would use 2000. (The default is 500ms).
    manythanks tannington, it works, giving 10000ms it seems less annoying

  9. #9

    Default Re: firefox: how to get rid of black popups

    Quote Originally Posted by unix111 View Post
    Looking into the HTML source, I am sure that the »title« tag of the »a href« element is responsible for these popups:
    Code:
    <a class="title threadtitle_unread" href="showthread.php/535525-MATE-Desktop-Indicators?highlight=mate+desktop+indicators" id="thread_title_535525" title="I have installed openSUSE Tumbleweed with MATE DE and I want to add the advanced indicators like in Ubuntu-MATE? I have installed Ayatana AFAIK is...">MATE Desktop Indicators.</a>
    If you are good at GreaseMonkey or the ad blocker of your choice, you can try modifying or altogether removing these »title« tags before the browser renders the HTML. You could even make it site-specific (or else you would lose those hidden mouse-over jokes in https://xkcd.com/ and other webcomics). However, sometimes these title tags are really informative (on the Linux Kernel Mailing List https://lkml.org/ for example) and can save you the additional mouse click.

    Any GreaseMonkey wizards around?
    ...manythanks unix111 but I'm a newby at all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •