Results 1 to 7 of 7

Thread: Missing lib needed to complete install of Qt Creator

  1. #1
    Join Date
    Apr 2019
    Location
    The California Republic
    Posts
    6

    Question Missing lib needed to complete install of Qt Creator

    My first post here. I have downloaded using YaST all of the needed files to support Qt 5. Last step is to install Qt Creator. I got the following error message:

    #### YaST2 conflicts list - generated 2019-04-05 19:09:32 ####

    nothing provides libQt5Core.so.5(Qt_5.12.0_PRIVATE_API) needed by libqt5-creator-4.8.0-1.1.i586

    [ ] break libqt5-creator-4.8.0-1.1.i586 by ignoring some of its dependencies

    [ ] do not install libqt5-creator-4.8.0-1.1.i586




    #### YaST2 conflicts list END ###


    What can I do? I also got a very similar error trying to install R-Studio. Any help will be gratefully accepted.

    lee

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,608
    Blog Entries
    3

    Default Re: Missing lib needed to complete install of Qt Creator

    I checked on my own Tumbleweed system, which is 64-bit. It looks as if you have 32-bit, so the results might not compare.

    I don't have "libqt5-creator" installed, but it looks as if I could install it without any problems.

    The file that you are missing looks as if it should be in "libQt5Core5" or "libQt5Core-devel".

    You could try installing those in Yast. That will probably give a conflict. But it might give you a better idea of where the conflict is.

    And remember that you can cancel out of your Yast session without actually installing anything. The idea is just to get information about your problem at this stage.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Apr 2019
    Location
    The California Republic
    Posts
    6

    Default Re: Missing lib needed to complete install of Qt Creator

    Quote Originally Posted by nrickert View Post
    I checked on my own Tumbleweed system, which is 64-bit. It looks as if you have 32-bit, so the results might not compare.

    I don't have "libqt5-creator" installed, but it looks as if I could install it without any problems.

    The file that you are missing looks as if it should be in "libQt5Core5" or "libQt5Core-devel".

    You could try installing those in Yast. That will probably give a conflict. But it might give you a better idea of where the conflict is.

    And remember that you can cancel out of your Yast session without actually installing anything. The idea is just to get information about your problem at this stage.
    Thanks for the info. I downloaded the pattern for Qt 5 Development and the pattern for C/C++ Development. Both files show that they are apart of the Qt 5 Core library. Both show that have been down loaded.

    So I am going to just going to run the down load and see what happens. I have been work with Qt since late in version 2.0.

    Sorry, I should have told you that this install is on a 586. Once this and R-Studio get installed, then I will do the install on my laptop with an AMD 64 chip.

    lee

  4. #4
    Join Date
    Apr 2019
    Location
    The California Republic
    Posts
    6

    Default Re: Missing lib needed to complete install of Qt Creator

    Quote Originally Posted by gooddog View Post
    Thanks for the info. I downloaded the pattern for Qt 5 Development and the pattern for C/C++ Development. Both files show that they are apart of the Qt 5 Core library. Both show that have been down loaded.

    So I am going to just going to run the down load and see what happens. I have been work with Qt since late in version 2.0.

    Sorry, I should have told you that this install is on a 586. Once this and R-Studio get installed, then I will do the install on my laptop with an AMD 64 chip.

    lee
    I am using the 1-click Install. It gave me the following error message:

    Internal error. Please report a bug report with logs.
    Run save_y2logs to get complete logs.

    Caller: /usr/share/YaST2/modules/PackageSlideShow.rb:128:in `ListSum'

    Details: undefined method `reduce' for nil:NilClass
    Did you mean? rescue
    lee

  5. #5
    Join Date
    Apr 2019
    Location
    The California Republic
    Posts
    6

    Default Re: Missing lib needed to complete install of Qt Creator

    I just tried to install the IDE for Python - Eric and got the same error about "List Sum".

  6. #6
    Join Date
    Apr 2019
    Location
    The California Republic
    Posts
    6

    Default Re: Missing lib needed to complete install of Qt Creator

    Quote Originally Posted by gooddog View Post
    I just tried to install the IDE for Python - Eric and got the same error about "List Sum".
    I went with the second choice in the first message, installl it any way. It appears to have installed Qt Creator but with the following error:

    /usr/lib/qtcreator/plugins/libDesigner.so: Cannot load library /usr/lib/qtcreator/plugins/libDesigner.so: (/usr/lib/libQt5DesignerComponents.so.5: version `Qt_5.12.0_PRIVATE_API' not found (required by /usr/lib/qtcreator/plugins/libDesigner.so))
    I tried to run Qt Creator and it works sort of.

    1. It did not install the Examples
    2. It will not run the Designer. I tried to create a standard widget program.

    Tomorrow will come soon enough, good night to all...

    lee


  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,264
    Blog Entries
    2

    Default Re: Missing lib needed to complete install of Qt Creator

    IIRC this problem was asked before and answered,
    Recommend you search this Forum for Qt Creator topic.

    Unless the problem is something new... but be sure you have at least tried all known fixes and then reference them in your post so that they can be eliminated as possible solutions.

    You can also search the Development Forum for Qt Creator topics...
    I can't be certain but IIRC solution involved adding all the Qt related Development repos to provide all necessary packages. Which is generally my own SOP, Development is different than simply running an app, when developing I add <all> related language repos.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •