Results 1 to 6 of 6

Thread: Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1.2.x

  1. #1

    Default Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1.2.x

    I have vagrant installed from https://download.opensuse.org/reposi...USE_Leap_15.0/

    The currently installed version is 2.2.2, which I'm trying to upgrade, but I get:

    Code:
    sudo zypper up vagrant
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1.2.x86_64
     Solution 1: do not install vagrant-2.2.4-lp150.1.2.x86_64
     Solution 2: break vagrant-2.2.4-lp150.1.2.x86_64 by ignoring some of its dependencies
    rubygem-net-ssh is only available up to 5.0 in the repository.

    To whom should I report this?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,889
    Blog Entries
    3

    Default Re: Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1

    I am not seeing "vagrant" in the standard repos.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1

    He tries to install from the Virtualisation repo.

    I assume that trying to contact the maintainers there is the way to go.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,483
    Blog Entries
    2

    Default Re: Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1

    The following should work for you

    https://software.opensuse.org/packag...em-net-ssh-5.1

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1

    Quote Originally Posted by hcvv View Post
    He tries to install from the Virtualisation repo.

    I assume that trying to contact the maintainers there is the way to go.
    Indeed. But who are they? My googling skills were failing me...

  6. #6

    Default Re: Problem: nothing provides rubygem(ruby:2.5.0:net-ssh:5.1) >= 5.1 needed by vagrant-2.2.4-lp150.1

    Quote Originally Posted by tsu2 View Post
    The following should work for you

    https://software.opensuse.org/packag...em-net-ssh-5.1

    TSU
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •