Ich versuche zurzeit an meinem PC (OpenSuse Leap 15) Riot (ein Messenger https://about.riot.im/) zu installieren, da leider noch keine offizielle Version vorhanden ist stellt sich das etwas problematisch dar. Ich habe nicht die Kenntnisse das selber zu machen, darum versuche ich es mit Flathub/Flatpak (Version 0.10.4). Das ist ja unter OpenSuse Standardmäßig vorinstalliert, dementsprechend verlief die Installation von Riot auch ohne Fehler. Allerdings starte das Programm danach nicht , ich habe es versucht über die Konsole zu starten und habe diese Fehlermeldung erhalten
Code:
Gtk-Message: 16:50:34.222: Failed to load module "canberra-gtk-module"
Invalid MIT-MAGIC-COOKIE-1 key
(riot-web:2): Gtk-WARNING **: 16:50:34.222: cannot open display: :99.0
Ich habe in Yast nachgeschaut und diese sind installiert:
Code:
S  | Name                          | Zusammenfassung                                               | Typ  
---+-------------------------------+---------------------------------------------------------------+------
   | canberra-gtk-play             | Portable sound event library -- Utility                       | Paket
   | canberra-gtk-play-gnome       | Portable sound event library -- Utility                       | Paket
   | libcanberra-gtk-devel         | Portable sound event library -- Development files             | Paket
i+ | libcanberra-gtk-module-common | Portable sound event library -- Common Files for GTK+ Modules | Paket
i+ | libcanberra-gtk0              | Portable sound event library -- GTK+ 2 Library                | Paket
   | libcanberra-gtk0-32bit        | Portable sound event library -- GTK+ 2 Library                | Paket
i+ | libcanberra-gtk2-module       | Portable sound event library -- GTK+ 2 Module                 | Paket
   | libcanberra-gtk2-module-32bit | Portable sound event library -- GTK+ 2 Module                 | Paket
i+ | libcanberra-gtk3-0            | Portable sound event library -- GTK+ 3 Library                | Paket
   | libcanberra-gtk3-0-32bit      | Portable sound event library -- GTK+ 3 Library                | Paket
   | libcanberra-gtk3-devel        | Portable sound event library -- Development files             | Paket
i+ | libcanberra-gtk3-module       | Portable sound event library -- GTK+ 3 Module                 | Paket
   | libcanberra-gtk3-module-32bit | Portable sound event library -- GTK+ 3 Module                 | Paket
Muss ich noch irgendwas nachinstallieren? Oder wo liegt das Problem?