Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Can't open YasST anymore...

Hybrid View

  1. #1

    Default Can't open YasST anymore...

    Hello SUSE users / Hallo liebe OpenSUSE-Nutzer

    (I will write the post in German as my error messages are in German. The main Problem is that YaST installer does not work anymore, because the R-base package URL cannot be found.
    I deinstalled and installed it many times, because I wasn't happy with my R version and then the problem occured. Now I cannot install anything with YaST anymore.),

    Ich hab leider irgendwas bei YaST gecrasht. Wenn ich YaST über GUI öffne, kein Problem. Wenn ich dann auf "Software installieren oder löschen" klicke kommt nach kurzem laden folgender Fehler:

    Warnung:
    Während der Repository-Initialisierung ist ein Fehler aufgetreten. [R-base|http://download.opensuse.org/reposit.../R:/patched//] Keine gültigen Metadaten bei dem festgelegten URL gefunden Verlauf: - [R-base|http://download.opensuse.org/reposit.../R:/patched//] Repository type can't be determined.

    und dann kommt:

    UI Syntax Error:
    Couldn't load plug-in qt-pkg
    Check the log file!

    und dann kommt:

    Fehler:
    Internal error. Please report a bug report with logs.
    Run save_y2logs to get complete logs.
    Details: Das Öffnen der Paketauswahl ist fehlgeschlagen.
    Caller: /usr/share/YaST2/modules/PackagesUI.rb:316:in `RunPackageSelector'

    Das Problem ist aufgetreten, nachdem ich mehrmals Rstudio installiert und deinstalliert habe. Seitdem habe ich auch folgende Fehlermeldung bei updates übers Terminal (gleich in der ersten Zeile):

    Metadaten von Repository 'R-base' abrufen ..............................[Fehler]
    Repository 'R-base' ist ungültig.
    [R-base|http://download.opensuse.org/reposit.../R:/patched//] Keine gültigen Metadaten bei dem festgelegten URL gefunden
    Überprüfen Sie, ob die für dieses Repository bestimmten URIs auf ein gültiges Repository verweisen.
    Warnung: Repository 'R-base' wird aufgrund des obigen Fehlers übersprungen.
    Einige der Repositorys konnten aufgrund eines Fehlers nicht aktualisiert werden.

    Jetzt funktioniert keine Installation mehr über YaST...

    Vielen Dank und Grüße

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,979

    Default AW: Can't open YasST anymore...

    Als erstes würde ich mal in einem Browser überprüfen, ob die URL überhaupt was ausgibt.

    Diese hier gibt etwas aus, allerdings muss man sich dann auch noch seine openSUSE Version aussuchen:
    http://download.opensuse.org/reposit...s:/R:/patched/

  3. #3
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    379

    Default AW: Can't open YasST anymore...

    Führe auch mal die Ausgabe von
    Code:
    zypper lr -d
    vor, aber bitte in Code-Tags, dann ist auch besser zu helfen.

    Beispiel:
    [code]zypper lr -d
    Repository-Prioritäten treten in Kraft: (Siehe 'zypper lr -P' für Details)
    10 (erhöhte Priorität) : 1 Repository
    15 (erhöhte Priorität) : 1 Repository
    65 (erhöhte Priorität) : 1 Repository
    70 (erhöhte Priorität) : 1 Repository
    80 (erhöhte Priorität) : 1 Repository
    90 (erhöhte Priorität) : 3 Repositorys
    95 (erhöhte Priorität) : 1 Repository
    99 (Standard-Priorität) : 9 Repositorys
    100 (gesenkte Priorität) : 1 Repository

    # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    ---+-------------------------+-----------------------------------+-----------+-----------------+----------------+-----------+--------+-----------------------------------------------------------------------------------+-------
    1 | Dienstprogramme | Dienstprogramme Repositorium | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/utilities/openSUSE_Leap_15.0/ |
    2 | chipcard | Sicherheit:Chipkarte(n) | Ja | (r ) Ja | Ja | 90 | rpm-md | http://download.opensuse.org/repositories/security:/chipcard/openSUSE_Leap_15.0/ |
    3 | darktable | Darktable Repositorium | Ja | (r ) Ja | Ja | 80 | rpm-md | http://download.opensuse.org/repositories/graphics:/darktable/openSUSE_Leap_15.0/ |

    [/code]

    Ergebnis:
    Code:
    zypper lr -d
    Repository-Prioritäten treten in Kraft:                                                    (Siehe 'zypper lr -P' für Details)
          10 (erhöhte Priorität)  :  1 Repository 
          15 (erhöhte Priorität)  :  1 Repository 
          65 (erhöhte Priorität)  :  1 Repository 
          70 (erhöhte Priorität)  :  1 Repository 
          80 (erhöhte Priorität)  :  1 Repository 
          90 (erhöhte Priorität)  :  3 Repositorys
          95 (erhöhte Priorität)  :  1 Repository 
          99 (Standard-Priorität) :  9 Repositorys
         100 (gesenkte Priorität) :  1 Repository 
    
    #   | Alias                   | Name                              |  Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    |  URI                                                                                | Dienst
    ---+-------------------------+-----------------------------------+-----------+-----------------+----------------+-----------+--------+-----------------------------------------------------------------------------------+-------
     1  | Dienstprogramme         | Dienstprogramme Repositorium      |  Ja        | (r ) Ja         | Ja             |   99      | rpm-md |  http://download.opensuse.org/repositories/utilities/openSUSE_Leap_15.0/            |       
     2 | chipcard                |  Sicherheit:Chipkarte(n)           | Ja        | (r ) Ja         |  Ja             |   90      | rpm-md |  http://download.opensuse.org/repositories/security:/chipcard/openSUSE_Leap_15.0/   |       
     3 | darktable               | Darktable  Repositorium            | Ja        | (r ) Ja         | Ja              |   80      | rpm-md |  http://download.opensuse.org/repositories/graphics:/darktable/openSUSE_Leap_15.0/  | 
    …

  4. #4

    Default Re: Can't open YasST anymore...

    Hi,
    Schonmal Danke für die schnelle Antwort.
    Ich habe auch schon bemerkt, dass die URL nicht existiert.
    Was kann ich also tun, um sie zu überschreiben, ohne die Möglichkeit über YaST in die Packages hineinzukommen?
    Version wäre Tumbleweed...

  5. #5

    Default Re: Can't open YasST anymore...

    Hi,
    Hier der nachgefragte Output:

    Code:
    zypper lr -d
    Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.
    
    #  | Alias                               | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                                                                          | Dienst
    ---+-------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+------------------------------------------------------------------------------------------------------------------------------+-------
     1 | R-base                              | R-base                                                  | Ja        | ( p) Ja         | Ja             |   99      | NONE   | http://download.opensuse.org/repositories/devel:/languages:/R:/patched//                                                     |       
     2 | adobe                               | adobe                                                   | Ja        | ( p) Ja         | Ja             |   99      | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/                                                                                 |       
     3 | http-download.opensuse.org-08ac4f1a | devel:languages:R:patched                               | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/R:/patched/openSUSE_Tumbleweed/                                  |       
    ...

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,852
    Blog Entries
    14

    Default Re: Can't open YasST anymore...

    Bitte zeig erst mal
    Code:
    zypper lr -d
    Hast du immer
    Code:
    zypper dup
    benützt ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Can't open YasST anymore...

    Mein Post um 16:23 war der "zypper lr -d" output.
    Ich habe immer
    Code:
    zypper update
    benutzt bis auf einmal.
    Da habe ich "zypper dup" benutzt. Da sind extrem viele Konflikte aufgetreten, die ich erstmal ignoriert bzw. überschrieben habe und da das keine Ende genommen hat, habe ich den Vorgang abgebrochen. Ich habe es so verstanden, dass zypper dup immer mal ausgeführt werden muss, um grundlegende Updates zu bekommen.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,156

    Default Re: Can't open YasST anymore...

    zypper dup heißt "distribution update" und dient in Prinzip dazu aufe ein neue Version um zu steigen. Da Tumbleweed snapshot aber immer wieder als Neuversionen ausgegeben werden, ist die einzige unterstẗzte Methode um ein feissches Tumbleweed zu bekommen
    Code:
    zypper dup
    when du zypper up machst kriegst du nur eventuelle ptaches von Update repos (die es aber in Tumbleweed eigentlich kaum gibt) und Updates von andere Repos als die offizielle openSUSE Tumbleweed repos.

    Sehr warscheinlich bist du also weit hinten.

    Soweit der Thorie.

    Jetz wie sieht es bei dir aus in deine repos Liste.
    Die ist wunderbar. Ich weis nicht was du da gemacht hast. Es ist überhaupt kein einzige Tumbleweed repo da. Es gibt ganze drei (3) repos, die alle LEAP 15.0 sagen und nicht die standard repos sind.

    Wie kann sowas passieren? Es ist kein Wunder das nochmals nachgefragt wurde nach die Liste, Wie du die hier zeigst is die unglaublich.
    Last edited by hcvv; 30-Mar-2019 at 11:57.
    Henk van Velden

  9. #9
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    379

    Default AW: Can't open YasST anymore...

    Quote Originally Posted by LiBurner1 View Post
    Hi,
    Ich habe auch schon bemerkt, dass die URL nicht existiert.
    Was kann ich also tun, um sie zu überschreiben, ohne die Möglichkeit über YaST in die Packages hineinzukommen?
    Führe als Root/su ein
    Code:
    zypper rr R-base
    aus, damit wird das fehlerhafte Repo entfernt. Das korrekte Repositorium ist ja auch schon vorhanden, daher muss nichts mehr hinzugefügt werden.


    Quote Originally Posted by LiBurner1 View Post
    Mein Post um 16:23 war der "zypper lr -d" output.
    Ich habe immer
    Code:
    zypper update
    benutzt bis auf einmal.
    Da habe ich "zypper dup" benutzt. Da sind extrem viele Konflikte aufgetreten, die ich erstmal ignoriert bzw. überschrieben habe und da das keine Ende genommen hat, habe ich den Vorgang abgebrochen. Ich habe es so verstanden, dass zypper dup immer mal ausgeführt werden muss, um grundlegende Updates zu bekommen.
    Bei openSUSE Tumbleweed wird immer ein
    Code:
    zypper dup
    und kein
    Code:
    zypper up
    ausgeführt.


    Quote Originally Posted by hcvv View Post
    Jetz wie sieht es bei dir aus in deine repos Liste.
    Die ist wunderbar. Ich weis nicht was du da gemacht hast. Es ist überhaupt kein einzige Tumbleweed repo da. Es gibt ganze drei (3) repos, die alle LEAP 15.0 sagen und nicht die standard repos sind.

    Wie kann sowas passieren? Es ist kein Wunder das nochmals nachgefragt wurde nach die Liste, Wie du die hier zeigst is die unglaublich.
    Wenn du nur Repos zu openSUSE Leap 15.0 siehst, dann hast dir meine (gekürzte) Liste angeschaut und nicht die von LiBurner1. Die Ausgaben der Listen sind hier fürs Forum von uns gekürzt worden. Meine, weil diese nur als Beispiel diente, die Ausgabe von LiBurner1 sollte aber eigentlich nicht gekürzt werden.

  10. #10

    Default Re: Can't open YasST anymore...

    Hi,
    Hier in dem Forum sieht man ja gar nicht, ob ich eine Antwort bekommen habe? Ich würde eigentlich sowas erwarten, wie in Notifications, dass ich eine Antwort auf meine Frage erhalten habe...

    @hcvv ich muss zugeben, dass ich nicht mal weiß, warum ich eigentlich Tumbleweed habe. Ursprünglich habe ich mir Leap 15 draufgeladen. Dann ist mir das aber wahrscheinlich aufgrund von Nvidia komplett gecrasht und ich habe mich nur noch über "nomodeset" reinbooten können. Dann habe ich nochmal ein Update draufgeladen und bin auf einmal bei Tumbleweed gelandet.

    @tomm_fa danke für den removerepo-Befehl. Das Problem mit R-base ist dann wohl gelöst. ABER das Problem sitzt wohl tiefer, da ich YaST immer noch nicht öffnen kann.

    Ich gebe ich euch jetzt eine Auflistung aller meiner Repositories:

    Code:
    sudo zypper lr -d
    Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.
    
    #  | Alias                               | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                                                                          | Dienst
    ---+-------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+------------------------------------------------------------------------------------------------------------------------------+-------
     1 | adobe                               | adobe                                                   | Ja        | ( p) Ja         | Ja             |   99      | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/                                                                                 |       
     2 | http-download.opensuse.org-08ac4f1a | devel:languages:R:patched                               | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/R:/patched/openSUSE_Tumbleweed/                                  |       
     3 | http-download.opensuse.org-3b45f3df | openSUSE:Factory                                        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                                                            |       
     4 | http-download.opensuse.org-5cc1c599 | Publishing:TeXLive                                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/Publishing:/TeXLive/openSUSE_Factory/                                              |       
     5 | http-download.opensuse.org-9c76c007 | openSUSE:Factory                                        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                                                            |       
     6 | http-download.opensuse.org-c1ae8852 | devel:languages:R:released                              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/R:/released/openSUSE_Leap_15.0/                                  |       
     7 | http-download.opensuse.org-c76318d7 | openSUSE:Tumbleweed                                     | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/                                                     |       
     8 | http-download.opensuse.org-f76918f0 | home:edmundhighcock:branches:devel:languages:R:released | Nein      | ----            | ----           |   99      | rpm-md | http://download.opensuse.org/repositories/home:/edmundhighcock:/branches:/devel:/languages:/R:/released/openSUSE_Tumbleweed/ |       
     9 | http-download.opensuse.org-ff84e766 | openSUSE:Factory                                        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                                                            |       
    10 | http-opensuse-guide.org-323280cd    | libdvdcss repository                                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/                                                                           |       
    11 | http-packman.inode.at-cc999ed9      | Packman Repository                                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.0/                                                                             |       
    12 | isv_TUXEDO                          | isv:TUXEDO (openSUSE_Leap_15.0)                         | Ja        | (r ) Ja         | Nein           |   99      | rpm-md | http://download.opensuse.org/repositories/isv:/TUXEDO/openSUSE_Leap_15.0/                                                    |       
    13 | openSUSE-Leap-15.0-1                | openSUSE-Leap-15.0-1                                    | Nein      | ----            | ----           |   99      | rpm-md | cd:///?devices=/dev/disk/by-id/ata-VBOX_CD-ROM_VB2-01700376                                                                  |       
    14 | repo-non-oss                        | openSUSE-Leap-15.0-Non-Oss                              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                                                            |       
    15 | repo-oss                            | openSUSE-Leap-15.0-Oss                                  | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                                                                |       
    16 | repo-source                         | openSUSE-Leap-15.0-Source                               | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/                                                         |       
    17 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss                       | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/                                                     |       
    18 | repo-update                         | openSUSE-Leap-15.0-Update                               | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                                                                           |       
    19 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss                       | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                                                                       |       
    20 | skypeforlinux                       | skypeforlinux                                           | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://repo.skype.com/rpm/stable                                                                                            |

    Durch eure Antworten ist mir klar geworden, dass "zypper up" wohl nur für Leap 15 gilt.
    Verwende ich jedoch "zypper dup" treten ca. 1 Millionen Konflikte auf.
    So würde schon mal der erste aussehen:
    Code:
    sudo zypper dup
    Warnung: Sie sind im Begriff, eine Distributionsaktualisierung mit allen aktivierten Repositorys durchzuführen. Vergewissern Sie sich, dass diese Repositorys kompatibel sind, bevor Sie fortfahren. Weitere Informationen zu diesem Kommando finden Sie unter 'man zypper'.
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Distributions-Aktualisierungen werden verarbeitet...
    21 Probleme:
    Problem: Problem mit installiertem Paket libavutil54-2.8.15-2.1.x86_64
    Problem: Problem mit installiertem Paket libavformat56-2.8.15-2.1.x86_64
    Problem: Problem mit installiertem Paket libpostproc53-2.8.15-2.1.x86_64
    Problem: Problem mit installiertem Paket libavcodec56-2.8.15-2.1.x86_64
    Problem: Problem mit installiertem Paket libswresample1-2.8.15-2.1.x86_64
    Problem: libIlmImf-2_3-24-2.3.0-1.2.x86_64 benötigt libm.so.6(GLIBC_2.27)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libLLVM6-6.0.1-5.4.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libLLVM7-7.0.1-5.1.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libbd_part2-2.20-2.1.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libgweather-3-15-3.28.3-1.1.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libmozjs-60-60.4.0-2.1.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libmutter-3-0-3.30.2-2.1.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libpipewire-0_2-1-0.2.5-1.1.x86_64 benötigt libc.so.6(GLIBC_2.28)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libpoppler83-0.72.0-1.3.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libtexlua53-5-5.3.4-55.5.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libumfpack5-5.7.6-31.1.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libyui-qt-graph9-2.44.9-2.3.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libyui-qt-pkg9-2.45.27-1.1.x86_64 benötigt libzypp.so.1709()(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libyui-ncurses-pkg9-2.48.9-1.5.x86_64 benötigt libzypp.so.1709()(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: perl-Term-ReadLine-Gnu-1.36-1.1.x86_64 benötigt perl(:MODULE_COMPAT_5.28.1), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libyui-qt9-2.49.16-1.1.x86_64 benötigt libm.so.6(GLIBC_2.29)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    
    Problem: Problem mit installiertem Paket libavutil54-2.8.15-2.1.x86_64
     Lösung 1: libavutil54-2.8.15-lp150.6.4.x86_64 installieren (mit Anbieterwechsel)
      openSUSE --> http://packman.links2linux.de
     Lösung 2: veraltetes libavutil54-2.8.15-2.1.x86_64 beibehalten
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/u/w/a] (a):
    Würde ich jetzt zu Lösung 2 optieren, kommt der nächste Konflikt usw.

    Grüße

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •