Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: freerdp and libfreerdp2 updates for Leap 15.0 are broken

  1. #1

    Default freerdp and libfreerdp2 updates for Leap 15.0 are broken

    The freerdp-2.0.0-rc4-lp150.2.3.1 and libfreerdp2-2.0.0-rc4-lp150.2.3.1 packages updates for Leap 15.0 are broken. Cannot connect to RDP services:
    08:34:09:873] [8209:8210] [INFO][com.freerdp.core] - ERRINFO_SERVER_INSUFFICIENT_PRIVILEGES (0x00000009):The user cannot connect to the server due to insufficient access privileges.
    [08:34:09:873] [8209:8210] [ERROR][com.freerdp.core.transport] - transport_check_fds: transport->ReceiveCallback() - -1
    Revert to freerdp-2.0.0-rc2-lp150.1.1 and libfreerdp2-2.0.0-rc2-lp150.1.1 fixes the issue.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,403
    Blog Entries
    2

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    You can submit a bug to https://bugzilla.opensuse.org,
    But you should include details...

    Where your updated packages are coming from (what repos are configured on your machine?)
    What apps are using those libraries

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    Hi.
    I tried to register the problem in BugZilla, but I do not understand the structure of the platform, and I could not create the ticket.
    The repositories that I have enabled are the basics of openSuSE Leap 15 (OSS, Update-OSS and Non-OSS), and the Pacman repository for Leap 15.
    The packages "freerdp-2.0.0-rc4-lp150.2.3.1" and "libfreerdp2-2.0.0-rc4-lp150.2.3.1" were updated from the "Update-OSS" repository.
    I use Free RDP both from Remmina and from the bash console.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,403
    Blog Entries
    2

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    On the bugzilla page,

    You can first search for any existing bugs by entering keywords in the search field on the top line.
    If you don't find anything that describes your problem on the same top line, click the "new" link (Never touch anything below the top line)
    After you click "New" the next page will list different parts of the bugzilla, in your case you want to click on the "Stable Distribution" link because LEAP is the stable release

    You will then see the page where you enter your bug info.
    I don't see a component that fits your situation so select "Other"
    Everything should be somewhat self-explanatory, be detailed about the libfreerdp file, possibly versions if you have it. Or, be very specific about the date you did your upgrade, perhaps from that someone can identify current and past versions.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Dec 2014
    Location
    Cartagena, Spain
    Posts
    17

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    I do not know if it is related to the reported same problem.
    In my case xfreerdp works well after the last update from official repositories
    (only oss, non-oss and oss-update)

    zypper update

    however, remmina cannot connect to the machines, giving the message:

    Reconnection in progress attempt 1 of 20 ...

    and nothing more happens.
    Before the last update of xfreerdp remmina was working well.

    This happens after upgrading from "2.0.0~rc2-lp150.1.1" to "2.0.0~rc4-lp150.2.3.1"

    Thanks

  6. #6

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    Quote Originally Posted by amelcon View Post
    I do not know if it is related to the reported same problem.
    In my case xfreerdp works well after the last update from official repositories
    (only oss, non-oss and oss-update)

    zypper update

    however, remmina cannot connect to the machines, giving the message:

    Reconnection in progress attempt 1 of 20 ...

    and nothing more happens.
    Before the last update of xfreerdp remmina was working well.

    This happens after upgrading from "2.0.0~rc2-lp150.1.1" to "2.0.0~rc4-lp150.2.3.1"

    Thanks
    Effectively. The problem you describe also happens to me when trying to connect from Remmina by RDP.

  7. #7

  8. #8

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    SOLVED!!!

    Sorry. I was in a mistake. I just checked that "freerdp" and "libfreerdp2" updates was NOT broken, as amelcon wrote. Freerdp works perfectly for me.

    Te problem is only with Remmina. Updating Remmina to 1.3.4-99.1 from X11:RemoteDesktop (https://software.opensuse.org/downlo...ackage=remmina) repository fixes the issue.

  9. #9
    Join Date
    Dec 2014
    Location
    Cartagena, Spain
    Posts
    17

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    Thanks a lot; your proposed solution indeed fixes the problem. The new version of remmina now works again. Thanks.

    If you do not use yast, there is a way to upgrade remmina with zypper from the command line.

    First you need to add the repository where the new version is located:

    zypper addrepo -f -p 90 -n "RemoteDesktop" \
    https://download.opensuse.org/reposi...teDesktop.repo

    You can check that you now have the new repository in your list:

    zypper lr -P

    To be sure refresh the repositories:

    zypper refresh

    You can check which versions of remmina are available in your system:

    zypper search -s remmina

    you will find one version from Oss repository (which is installed) and another version from RemoteDesktop repository (not installed).

    You can now install from the new repository:

    zypper install --from RemoteDesktop remmina

    When prompted, select the option to install with vendor change.

    You can check again the situation with remmina:

    zypper search -s remmina

    now you find one version from RemoteDesktop (which is installed) and another version from Oss repository (not installed).

    The new installed version works again.
    Thanks.

  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,403
    Blog Entries
    2

    Default Re: freerdp and libfreerdp2 updates for Leap 15.0 are broken

    Quote Originally Posted by amelcon View Post
    Thanks a lot; your proposed solution indeed fixes the problem. The new version of remmina now works again. Thanks.

    If you do not use yast, there is a way to upgrade remmina with zypper from the command line.

    First you need to add the repository where the new version is located:

    zypper addrepo -f -p 90 -n "RemoteDesktop" \
    https://download.opensuse.org/reposi...teDesktop.repo

    You can check that you now have the new repository in your list:

    zypper lr -P

    To be sure refresh the repositories:

    zypper refresh

    You can check which versions of remmina are available in your system:

    zypper search -s remmina

    you will find one version from Oss repository (which is installed) and another version from RemoteDesktop repository (not installed).

    You can now install from the new repository:

    zypper install --from RemoteDesktop remmina

    When prompted, select the option to install with vendor change.

    You can check again the situation with remmina:

    zypper search -s remmina

    now you find one version from RemoteDesktop (which is installed) and another version from Oss repository (not installed).

    The new installed version works again.
    Thanks.
    You can go through all those steps if you're curious and careful,
    otherwise you can simply add the new repository and then do a "zypper up," the new version should be found and if it's a later version number than others (including installed), it will automatically propose the update.

    Also,
    recommend next time you post, enclose all your commands within [CODE] tags which can easy be done by clicking the "hash" button (#) in then the Editor's toolbar (typically second row, third from right)

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •