Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Qgis Leap 15.0

Hybrid View

  1. #1

    Default Qgis Leap 15.0

    Bij het opnieuw installeren van Leap15.0 installeer Qgis , Postgis en Postgresql.
    Qgis lukt niet meer. Op de website van Opensuse.org download vind ik geen Qgis meer.
    Ondersteund Opensuse geen GIS applicaties meer? via internet kwam ik bij GEO.
    Ik kan daar Qgis installeren/ Ik krijg bij de installatie de melding niets lib.proj.so13().
    Wanneer ik lib.pro.s013() via internet installeer kan ik na installatie de Qgis 3.4 (LTR) opstarten.
    Ik krijg de melding Qgis gereed, waarna Qgis van het beeldscherm verdwijnt, dus crasht.

    Ik heb nu een probleem daar ik Qgis gebruik voor MBO studenten.

    Ik hoop dat iemand mij kan helpen.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,983
    Blog Entries
    14

    Default Re: Qgis Leap 15.0

    Hallo, welkom !!!

    Op https://software.opensuse.org/package/qgis zie ik wel experimentele pakketten, in de Application:Geo repo. Heb je die geprobeerd?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Qgis Leap 15.0

    Ik heb 2.18. van Beyerle:IAC geprobeerd en 3.4 3.6 van :Geo.
    Leap 15.0 kent lib.proj.so12() en lib.proj.so15() maar geen lib.proj.so13().
    Verder is her vreemd dat een aantal maanden geleden Beyerle:IAC en : Geo te benaderen waren via https://software.opensuse.org/explore.
    Qgis is andere geografische pakketten zoals Qmapshack Qlandkarte zijn van deze website verwijderd.
    Dit betekent dat ook bij Tumbleweed en leap15.1 de pakketten niet via https://software.opensuse.org/explore te benaderen zijn.

  4. #4
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    150

    Default Re: Qgis Leap 15.0

    Ik had, denk ik, een soortgelijk probleem met QMapShack, zie QMapShack not longer working, Proj4 library incompatible after 20190314 update.

    Voor mij (Tumbleweed, met de Application:Geo repository) is qgis wel beschikbaar:
    Code:
    > sudo zypper se qgis
    Loading repository data...
    Reading installed packages...
    
    S | Name                               | Summary                                                 | Type      
    --+------------------------------------+---------------------------------------------------------+-----------
      | qgis                               | QGIS is a Geographic Information System (GIS)           | package   
      | qgis                               | QGIS is a Geographic Information System (GIS)           | srcpackage
      | qgis-debuginfo                     | Debug information for package qgis                      | package   
      | qgis-debugsource                   | Debug sources for package qgis                          | package   
      | qgis-devel                         | Development Libraries for the QGIS                      | package   
      | qgis-master                        | QGIS is a Geographic Information System (GIS)           | srcpackage
      | qgis-master                        | QGIS is a Geographic Information System (GIS)           | package   
      | qgis-master-debuginfo              | Debug information for package qgis-master               | package   
      | qgis-master-debugsource            | Debug sources for package qgis-master                   | package   
      | qgis-master-devel                  | Development Libraries for the QGIS Development branch   | package   
      | qgis-master-plugin-grass           | GRASS Support Libraries for the QGIS Development branch | package   
      | qgis-master-plugin-grass-debuginfo | Debug information for package qgis-master-plugin-grass  | package   
      | qgis-master-sample-data            | QGIS sample data                                        | package   
      | qgis-otb-plugin                    | OTB plugin for QGIS                                     | package   
      | qgis-otb-plugin                    | OTB plugin for QGIS                                     | srcpackage
      | qgis-plugin-grass                  | GRASS Support Libraries for QGIS                        | package   
      | qgis-plugin-grass-debuginfo        | Debug information for package qgis-plugin-grass         | package   
      | qgis-sample-data                   | QGIS sample data                                        | package

  5. #5

    Default Re: Qgis Leap 15.0

    Qgis is wel beschikbaar.

    versie. 2.18 crasht bj het maken van een niewe laag.
    De LTR versie Qgis3.4 wordt in Opensuse niet geleverd.

    De versie Qgis 3.6 start op maar crasht na de melding gereed.

    Ik heb nu echt een probleem met het ondersteunen van studenten.

  6. #6
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    150

    Default Re: Qgis Leap 15.0

    Sinds wanneer heb je het probleem met qgis? Kan je terug gaan met behulp van een snapshot?

    Ik heb geprobeerd qgis te installeren op Tumbleweed maar dat lukt niet zomaar:

    Code:
    > sudo zypper in qgis
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libQt5Core.so.5(Qt_5.12.0_PRIVATE_API)(64bit) needed by qgis-3.6.0-1.7.x86_64
     Solution 1: do not install qgis-3.6.0-1.7.x86_64
     Solution 2: break qgis-3.6.0-1.7.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    Wat je zou kunnen doen is een bug aanmaken via https://build.opensuse.org/package/s...ation:Geo/qgis

  7. #7

    Default Re: Qgis Leap 15.0

    Het begon met leap 15.0. In de vorige versies van Opensuse kon je kiezen uit de LTR versie of de laatste ontwikkelversie.
    Qgis2.18 draaide goed. Nadat ik door een stommiteit Leap 15.0 opnieuw moest installeren ontstonden de problemen met Qgis.
    Nu is Qgis 3.4 de LTR versie. Opensuse heeft die niet meer opgenomen en de laatste versie Qgis3.6
    Verder merk ik dat Postgis in Leap 15.0 niet meer standaard met Postgresql is opgenomen.
    Ik zal je advies opvolgen en een bug rapporteren.

  8. #8
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    150

    Default Re: Qgis Leap 15.0

    Ik zag dat je een commentaar had toegevoegd aan Application:Geo > qgis, goed.

    Zoals Stephan66 schrijft is er vooruitgang, zowel Leap15 en Tumbleweed bouwen weer, maar inderdaad het draait nog niet.
    qgis geïnstalleerd op Tumbleweed, Qgis 3.6 Noosa en die crasht:



    Dus Report Bug aangeklikt en onder Developer Information zie ik:

    Code:
     Application: qgis (qgis), signal: Segmentation fault
    ...
    
    Thread 1 (Thread 0x7f7c6c42d0c0 (LWP 31328)):
     [KCrash Handler]
     #6  0x00007f7c6d42175d in pj_free () at /usr/lib64/libproj.so.15
     #7  0x00007f7c757dbe5c in  () at /usr/lib64/libgdal.so.20
     #8  0x00007f7c757dce54 in OCTProj4Normalize () at /usr/lib64/libgdal.so.20
     #9  0x00007f7c757cc70f in OGRSpatialReference::importFromProj4(char const*) () at /usr/lib64/libgdal.so.20
     #10 0x00007f7c782fed22 in QgsCoordinateReferenceSystem::setProj4String(QString const&) () at /usr/lib64/libqgis_core.so.3.6.0
     #11 0x00007f7c78301fd5 in QgsCoordinateReferenceSystem::createFromProj4(QString const&) () at /usr/lib64/libqgis_core.so.3.6.0
     #12 0x00007f7c78302a6c in QgsCoordinateReferenceSystem::fromProj4(QString const&) () at /usr/lib64/libqgis_core.so.3.6.0
     #13 0x00007f7c783567fe in QgsEllipsoidUtils::ellipsoidParameters(QString const&) () at /usr/lib64/libqgis_core.so.3.6.0
     #14 0x00007f7c7842891b in QgsMapSettings::setEllipsoid(QString const&) () at /usr/lib64/libqgis_core.so.3.6.0
    Ik kan er een bug report van aanmaken, moet alleen even denken waar, niet erg duidelijk waar het probleem zit, libproj, libgdal of qgis.

    Zou goed zijn als je op qgis bijwerkt op Leap 15, hem start en onder de Developer Information laat zien wat er in "Thread 1" gebeurd.

  9. #9
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    150

    Default Re: Qgis Leap 15.0

    Even verder gekeken en qgis opgestart vanaf de commandoregel m.b.v. /usr/bin/qgis

    Dat geeft interessante output en een ding dat me op viel is:
    Code:
    src/core/qgsmessagelog.cpp:29 : (logMessage) [566ms] 2019-04-06T13:37:59 Processing[2] Problem with SAGA installation: SAGA was not found or is not correctly installed
    Dus maar even "sudo zypper search saga" gedaan en inderdaad geen saga geïnstalleerd:
    Code:
    > sudo zypper se saga
    
    S | Name                          | Summary                                                | Type      
    --+-------------------------------+--------------------------------------------------------+-----------
      | python-saga-gis               | Python bindings for SAGA                               | package   
      | python-saga-gis-debuginfo     | Debug information for package python-saga-gis          | package   
      | python-saga-gis-ltr           | Python bindings for SAGA                               | package   
      | python-saga-gis-ltr-debuginfo | Debug information for package python-saga-gis-ltr      | package   
      | saga-gis                      | SAGA GIS - System for Automated Geoscientific Analyses | package   
      | saga-gis                      | SAGA GIS - System for Automated Geoscientific Analyses | srcpackage
      | saga-gis-debuginfo            | Debug information for package saga-gis                 | package   
      | saga-gis-debugsource          | Debug sources for package saga-gis                     | package   
      | saga-gis-devel                | Development files for SAGA                             | package   
      | saga-gis-ltr                  | SAGA GIS - System for Automated Geoscientific Analyses | package   
      | saga-gis-ltr                  | SAGA GIS - System for Automated Geoscientific Analyses | srcpackage
      | saga-gis-ltr-debuginfo        | Debug information for package saga-gis-ltr             | package   
      | saga-gis-ltr-debugsource      | Debug sources for package saga-gis-ltr                 | package   
      | saga-gis-ltr-devel            | Development files for SAGA                             | package
    Ik zag in de debug output ook python voorbij komen dus toen maar python-saga-gis en saga-gis geïnstalleerd en daarmee kwamen gelijk wat meer pakketten, in totaal 11.

    Opnieuw gestart en toen zag ik:
    Code:
    src/core/qgsmessagelog.cpp:29 : (logMessage) [642ms] 2019-04-06T13:48:12 Processing[2] Problem with SAGA installation: unsupported SAGA version (found: 6.3.0, required: 2.3.).
    en nog steeds dezelfde crash.

    Toen python-saga-gis en saga-gis verwijderd en python-saga-gis-ltr en saga-gis-ltr geïnstalleerd, melding weg maar nog steeds zelfde crash.

    @cultuur: Ik ben niet bekend met qgis maar is SAGA een optioneel onderdeel of een integraal onderdeel? Als dat laatste het geval is dan zou de afhankelijkheden van qgis moeten bijgewerkt worden.

    Volgende stap, draaien onder gdb.

    Eerst vier keer gestopt op een signal SIG33, Real-time event 33 maar dat lijkt me geen probleem dus continue gedaan en toen viel gdb ook in de segmentation fault.
    Nu ik er nog eens naar kijk gaat wordt de fout getriggerd in libproj en daar had ik al eerder problemen mee, ik vermoed dat dat geen toeval is.

    @cultuur: Hier verschilt Leap15 van Tumbleweed, dus het zou goed zijn om jou output van /usr/bin/qgis te zien en de stack trace (zie de post hiervoor)

  10. #10
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    150

    Default Re: Qgis Leap 15.0

    Even verder gekeken, en het Tumbleweed probleem is al gerapporteerd: https://issues.qgis.org/issues/21781 - QGis 3.6.0 crash when start on Linux OpenSuse Tumbleweed

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •