Results 1 to 3 of 3

Thread: Sehr langsames WLAN und iwlwifi Fehler

  1. #1

    Default Sehr langsames WLAN und iwlwifi Fehler

    Guten Tag,
    Ich habe ein Problem mit meinem WLAN. Das Wlan ist extrem langsam (teilweise nur einige Bytes/s bis kb/s). Nun habe ich bemerkt, dass dmesg voll ist mit dem Fehler:
    Code:
    iwlwifi 0000:03:00.0: Unhandled alg: 0x707
    ist
    Nach einer kurzen Google Suche habe ich die Vermutung, dass die iwlwifi Treiber nicht vernünftig funktionieren. Dies soll wohl auch ab Kernel Version 4.16.4-1 unter Arch Linux laufen (https://bbs.archlinux.org/viewtopic.php?id=236093 Englischer Thread im Arch Linux Forum). OpenSuse 15.0 hat jedoch zurzeit Kernel Version 4.12.14

    Kann ich irgendwie neuere iwlwifi Treiber installieren? Hat vielleicht jemand eine andere Idee, die funktionieren könnte?

    Vielen Dank im Voraus und viele Grüße,

    - ChrizZly

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,798

    Default AW: Sehr langsames WLAN und iwlwifi Fehler

    Dies mal probieren:
    iwlwifi

    iwlwifi is the wireless driver for Intel's current wireless chips, such as 5100AGN, 5300AGN, and 5350AGN. See the full list of supported devices. The firmware is included in the linux-firmware package. The linux-firmware-iwlwifi-gitAUR may contain some updates sooner.

    If you have problems connecting to networks in general or your link quality is very poor, try to disable 802.11n, and perhaps also enable software encryption:

    /etc/modprobe.d/iwlwifi.conf

    options iwlwifi 11n_disable=1 swcrypto=1

    If you have a problem with slow uplink speed in 802.11n mode, for example 20Mbps, try to enable antenna aggregation:

    /etc/modprobe.d/iwlwifi.conf

    options iwlwifi 11n_disable=8

    Do not be confused with the option name, when the value is set to 8 it does not disable anything but re-enables transmission antenna aggregation.[10] [11]

    In case this does not work for you, you may try disabling power saving for your wireless adapter.

    Some have never gotten this to work. Others found salvation by disabling N in their router settings after trying everything. This is known to have be the only solution on more than one occasion. The second link there mentions a 5ghz option that might be worth exploring.
    Quelle: https://wiki.archlinux.org/index.php...ration#iwlwifi

  3. #3

    Default Re: Sehr langsames WLAN und iwlwifi Fehler

    Danke für die Antwort. Die Internetgeschwindigkeit ist auf jeden Fall mit dem zweiten Befehl besser. dmesg ist jedoch immernoch voller iwlwifi errors (Ich weiß nicht wie schlimm das ist).
    Was hat der zweite Befehl genau gemacht? Ich weiß nicht genau was die antenna aggregation genau sein soll.
    Ich bin gerade so überrascht. Ich wusste gar nicht, dass hier ne Leitung über 100MBits verbaut ist. Aber ich lade gerade mit 20.5MB/s runter.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •