Results 1 to 9 of 9

Thread: Latest Tumbleweed. SSH doesn't start after update

  1. #1

    Default Latest Tumbleweed. SSH doesn't start after update

    hello, Yesterday server was updated to latest version of Tumbleweed. 20190312. and sshd service didn't start. SSH config is default.

    Code:
    sshd /lib64/libcrypt.so.1: version XCRYPT_2.0 not found (required by sshd)
    Please, could somebody help how to resolve this issue.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,396

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    Quote Originally Posted by ipvinner View Post
    hello, Yesterday server was updated to latest version of Tumbleweed.
    How? With zypper dup?
    Quote Originally Posted by ipvinner View Post
    20190312. and sshd service didn't start. SSH config is default.

    Code:
    sshd /lib64/libcrypt.so.1: version XCRYPT_2.0 not found (required by sshd)
    And where/when did you get/see that?
    Henk van Velden

  3. #3

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    Quote Originally Posted by hcvv View Post
    How? With zypper dup?

    And where/when did you get/see that?
    Code:
    zypper update && reboot

    I can see error when try to start sshd
    Code:
    systectl start sshd
    Code:
    journald -xe
    or
    Code:
    sshd --version
    sshd start failed

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,396

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    As the only supported way of updating Tumbleweed is
    Code:
    zypper dup
    you better dio that first and then try again if it still does not work.
    Henk van Velden

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,890
    Blog Entries
    3

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    I'm not having a problem with "ssh" here.

    As Henk suggested, your problem is an incomplete update, due to using "zypper update" when you should use "zypper dup". The result is that you have a library incompatibility. So fix that (by running "zypper dup"), then reboot and see if "sshd" starts up.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    Quote Originally Posted by hcvv View Post
    As the only supported way of updating Tumbleweed is
    Code:
    zypper dup
    you better dio that first and then try again if it still does not work.
    Thank you. zypper dup && reboot helped

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,396

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    That is fine. Thanks for reporting back.
    Henk van Velden

  8. #8

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    hi,
    getting
    sshd /lib64/libcrypt.so.1: version XCRYPT_2.0 not found (required by sshd)did the zypper dup and reboot, same error

    zypper in -f openssh and reboot same error

    any other suggestions?

    Mark

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,890
    Blog Entries
    3

    Default Re: Latest Tumbleweed. SSH doesn't start after update

    Quote Originally Posted by mlmmilkyway View Post
    hi,
    getting
    sshd /lib64/libcrypt.so.1: version XCRYPT_2.0 not found (required by sshd)did the zypper dup and reboot, same error

    zypper in -f openssh and reboot same error

    any other suggestions?

    Mark
    Again, I'm not having problems here. That message suggests an incompatible library.

    What's the output from
    Code:
    zypper lr -d
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •