Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 57

Thread: zypper segfaulting

  1. #11

    Default Re: zypper segfaulting

    On 3/8/19 12:16 PM, poorboywilly wrote:
    > Starting yesterday and continuing today "zypper dup" is crashing with a
    > simple message of "Segmentation fault" during the process of downloading
    > packages. Restarting the "zypper dup" process continues the downloads.
    > Th installation after all the packages are successfully downloaded has
    > not crashed. Yesterday it crashed three times, while today only once
    > (though there were more packages to download yesterday).
    > Is anyone else seeing this?

    I'm seeing this also. I only have non-oss - oss - update and packman

    unix since 1986
    S.u.S.E.-openSUSE since 1998

  2. #12

    Default Re: zypper segfaulting

    On 3/8/19 2:56 PM, xmetal wrote:
    > tsu2;2896474 Wrote:
    >> Are you sure it's during a download?
    >> I've noticed that sometimes packages install immediately after a
    >> download, other times install happens only after all downloading has
    >> completed.
    >> It's more likely that a segmentation fault would happen during an
    >> install than a download... Or, at least I can't think of a reason why it
    >> can happen during a download.
    >> Inspecting your system log can provide a more informative error,
    >> Assuming the segmentation fault isn't so serious it causes your system
    >> to crash, you can view your system log in real time while you're doing
    >> any suspect activity

    > Code:
    > --------------------
    > > > journalctl -f

    > --------------------

    >> TSU

    > I will be completely honest, I am not sure when it's happening (I did
    > edit the log file down by slimming down my "PC name" in the log ... it's
    > now 2.7MB
    > It usually happens after you go through the full install and setup and
    > it is downloading/installing stuff
    > I am having another issue with lagginess on Gnome when no other Gnome on
    > this same machine does this ... SO I MAY redo this as Plasma 5 ... IF
    > the same issue happens (the ORIGINAL ISSUE) then I will be able to save
    > more logs of what happened this time ... if not i still have the log
    > from the Gnome install so maybe (hypothetically thinking...) it's
    > something with one of the Gnome packages
    > I am off to read through the log (again of the original issue) again
    > right now

    I always use

    zypper -v dup -d
    before running dup and I am getting the segfault, So it is happening
    during the download phase.

    unix since 1986
    S.u.S.E.-openSUSE since 1998

  3. #13
    Join Date
    Jan 2010
    Rochester, NY

    Default Re: zypper segfaulting

    I am seeing this as well.

    2 different boxes.

    Box 1: Ryzen 1700X machine, 16 GB ram

    Box 2: AMD APU, 8G ram

  4. #14

  5. #15

    Default Re: zypper segfaulting

    not related to my other post but I found an ISO that was newer than the one i had been having issues with (march 2019) and used the November 2018 ISO for TW I found and while this time the install works just fine

    I NOW am seeing a segment fault when using zypper

    using the following command did not help
    sudo rpm --rebuilddb && sudo zypper clean -a && sudo zypper ref

    right now i cant update or install anything without getting right back to that segment fault when downloading

  6. #16
    Join Date
    Jun 2008

    Default Re: zypper segfaulting

    I have gotten the segfault on two different machines while packages are installing. Never appears to be the same package in 4 attempts (twice on each machine). Come to think of it: I also got the exit during a download but restarting zypper dup finished the download and gave the segfault during installation.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  7. #17

    Default Re: zypper segfaulting

    I hate to cross post but i wonder if THIS is the same thing happening in my other thread where the installer for the new snapshots fail exit for no reason ... it could be the same issue I guess .... zypper dup on an installed rig = exits ... the other issue i had = installer exits during the install

    anyway rerunning sudo zypper dup EVERY TIME it segment faults, gets more and more package downloaded

  8. #18

    Default Re: zypper segfaulting

    dmesg | grep segfault
    got me this

    [ 538.121244] zypper[3594]: segfault at 100000228 ip 00007fb985d01237 sp 00007fff45beded0 error 4 in[7fb985cbb000+63000]
    [ 890.537248] zypper[4124]: segfault at 7f83000001f9 ip 00007f83507b15e1 sp 00007ffd6ae09ac8 error 6 in[7f8350785000+63000]
    [ 2950.791449] zypper[8081]: segfault at 0 ip 00007fe7f6f3450e sp 00007ffcfe64f0e0 error 4 in[7fe7f6ee4000+14c000]

  9. #19

    Default Re: zypper segfaulting

    On Sat, 09 Mar 2019 14:18:45 +0000, Ken Schneider wrote:

    > I'm seeing this also. I only have non-oss - oss - update and packman
    > enabled.

    Another "me 2" - segfaults at random points in reasonably lagre downloads
    and then it will successfully restart. confirm what had been successful,
    and complete the job w/o further problem. Running multiple machines via
    ssh at the same time I've even seen one machine abend while everyone else
    pressed on. Asked for an opinion on the cause, I would lean towards a
    race or improper response to a data sream error. Glad I'm not chasing
    this one- 'random' events are a nightmare!

    At the moment I would rate this as a nuisance not a pending catastrophy...

  10. #20

    Default Re: zypper segfaulting

    It looks like a me2 so hope the detail below might help.

    The biggest issue at this point is not being able to install additional software via zypper or YaST
    - Segmentation fault (core dumped) with zypper install and also YaST install

    The previous issue though related is "YaST is missing after update"

    Where this is now, the latest steps in this issue:

    - Saved the downloaded rpms from /var/cache/zypper to a backup directory
    - Reinstalled and have a clean installation (openSuSE TW - gecko-rolling - Cinnamon)
    - It looks and runs amazingly smooth, love it.
    - Yast Control Center and all functionality is where it should be
    - Mapped the backup rpms as a local repository and gave it priorety
    - Ran zypper dup to update the system - it updated 1523 files
    - Disabled the local zypper backup repository
    - Ran zypper dup to update the system - it updated 18 files
    - I saved both zypper dups as a text file if anyone needs it

    So far so good. Everything is working. The only thing that changed is it lost the openSuse Oxygen icons in the process

    - Using the YaST Control Center tried to install wine.
    - There were no exceptions or conflicts but the installation crashed before it was finished
    - Using the YaST Control Center tried to install gimp.
    - There were no exceptions or conflicts but the installation crashed before it was finished
    - In Terminal ran zypper install q4wine, it failed.
    Retrieving: libvorbisenc2-32bit-1.3.6-3.4.x86_64.rpm ------------------------------------[| (921 B/s)]Segmentation fault (core dumped)
    dad # zypper install q4wine
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    The following 127 NEW packages are going to be installed:
      fuseiso gstreamer-32bit icoutils krb5-32bit libacl1-32bit libasound2-32bit libavahi-client3-32bit
      libavahi-common3-32bit libblkid1-32bit libbz2-1-32bit libcap2-32bit libcapi20-3 libcapi20-3-32bit
      libcom_err2-32bit libcrypt1-32bit libcups2-32bit libdb-4_8-32bit libdbus-1-3-32bit libdw1-32bit
      libebl-plugins-32bit libelf1-32bit libexif12-32bit libexpat1-32bit libffi7-32bit libFLAC8-32bit
      libfontconfig1-32bit libfreetype6-32bit libgcrypt20-32bit libgd3-32bit libgdbm6-32bit
      libgdbm_compat4-32bit libgio-2_0-0-32bit libglib-2_0-0-32bit libGLU1-32bit libglvnd-32bit
      libgmodule-2_0-0-32bit libgmp10-32bit libgnutls30-32bit libgobject-2_0-0-32bit libgpg-error0-32bit
      libgphoto2-6-32bit libgsm1-32bit libgstaudio-1_0-0-32bit libgstreamer-1_0-0-32bit
      libgsttag-1_0-0-32bit libgstvideo-1_0-0-32bit libhogweed4-32bit libidn2-0-32bit libjbig2-32bit
      libjpeg8-32bit libkeyutils1-32bit liblcms2-2-32bit libldap-2_4-2-32bit liblockdev1-32bit
      libltdl7-32bit liblua5_3-5-32bit liblz4-1-32bit liblzma5-32bit libmagic1-32bit libmount1-32bit
      libmpg123-0-32bit libncurses6-32bit libnettle6-32bit libnl3-200-32bit libogg0-32bit libopenal1-32bit
      libopenssl1_1-32bit liborc-0_4-0-32bit libOSMesa8 libOSMesa8-32bit libp11-kit0-32bit libpcap1-32bit
      libpcre1-32bit libpng16-16-32bit libpopt0-32bit libpulse0-32bit libsasl2-3-32bit libSDL2-2_0-0-32bit
      libselinux1-32bit libsensors4-32bit libsndfile1-32bit libsnmp30-32bit libspeex1-32bit
      libsystemd0-32bit libtasn1-6-32bit libtiff5-32bit libudev1-32bit libunistring2-32bit libunwind-32bit
      libusb-1_0-0-32bit libuuid1-32bit libv4l1-0-32bit libv4l2-0-32bit libv4lconvert0-32bit
      libverto1-32bit libvkd3d1 libvkd3d1-32bit libvorbis0-32bit libvorbisenc2-32bit libvulkan1
      libvulkan1-32bit libwebp7-32bit libwrap0-32bit libX11-6-32bit libXau6-32bit libxcb1-32bit
      libXcomposite1-32bit libXcursor1-32bit libXext6-32bit libXfixes3-32bit libXi6-32bit
      libXinerama1-32bit libxml2-2-32bit libXpm4-32bit libXrandr2-32bit libXrender1-32bit libxslt1-32bit
      libXxf86vm1-32bit libz1-32bit Mesa-libglapi0-32bit p11-kit-32bit perl-32bit q4wine rpm-32bit
      sane-backends-32bit wine wine-32bit
    continued below:
    openSUSE Tumbleweed 64-bit / Cimmamon

Page 2 of 6 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts