Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Packman Fahlermeldung

  1. #1

    Default Packman Fahlermeldung

    Hallo zusammen,

    Ich bin kürzlich von Kubuntu auf OpenSuse/KDE umgestiegen. Alles läuft einwandfrei, nur beim Start erscheint immer folgende Fehlermeldung:

    Fehler beim Aktualisieren:
    Download (curl) error for 'http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Could not resolve host: ftp.gwdg.de

    Die Nachricht erscheint sofort nach dem Systemstart zusammen mit einer Fehlermeldung, dass keine Internetverbindung vorliegt. Erst danach wird die WLAN-Verbindung über KWallet freigegeben.

    Ein manuelles Update über Yast oder Konsole ergibt stets, dass die Packman-Bibliothek auf dem neusten Stand ist. MP4-Dateien lassen sich weder in Gwenview noch in Dragon abspielen, werden vom VLC-Player aber einwandfrei wiedergegeben.

    Vielen Dank im Voraus für jede Hilfe!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,694

    Default AW: Packman Fahlermeldung

    Die Nachricht erscheint sofort nach dem Systemstart zusammen mit einer Fehlermeldung, dass keine Internetverbindung vorliegt. Erst danach wird die WLAN-Verbindung über KWallet freigegeben.
    Das ist das Update-Aplett in der Taskleiste, wenn du in Kwallet ein leeres Master-Passwort verwendest, sollte das auch verschwinden.

    Oder aber in den Einstellungen zu dem speziellen Wlan: diese Verbindung für alle User freigeben (oder so ähnlich)
    Dann wird aber das Wlan-Passwort im Klartext gespeichert. Und nur root kann dann ändern.

    Oder aber das Update-Aplett deaktivieren.......

    Zum Thema Packman:
    https://forums.opensuse.org/showthre...SUSE-Leap-42-3
    Einfach die 42.3 in der URL mit 15.0 ersetzen.
    Ausserdem sollte man für Packman eine höhere Priorität einsetzen:
    Code:
    zypper mr -p 20 packman
    Und dann mit einer Zeile installieren (ich habs ein wenig angepasst, installiere immer ein wenig mehr):
    Code:
    zypper install -f libxine2-codecs ffmpeg-3 lame dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs vlc-codec-gstreamer ogmtools libavcodec58 flash-player flash-player-ppapi
    danach statt:
    When done. Close the terminal. And open Yast > Software Management and Apply the Package Switcher on Packman Repo
    In der Konsole:
    Code:
    zypper dup --from packman
    Alle Abhängigkeiten auflösen, nichts ignorieren.
    Last edited by Sauerland; 07-Mar-2019 at 14:46.

  3. #3

    Default Re: Packman Fehlermeldung

    Hallo Sauerland,

    Vielen Dank für die schnelle Hilfestellung!

    Kwallet mit leerem Master-Passwort hatte ich bereits eingerichtet. Aber die Verbindung für alle Benutzer freigeben und Passwort für alle Benutzer speichern, das hat's gebracht. Jetzt läuft der Startvorgang völlig fehlerfrei ab. Besten Dank für den Tip!

    Das Packman-Problem bleibt aber weiter bestehen, und ich kann immer noch keine Videoclips in Gwenview öffnen. Kannst Du mir hierbei nochmal helfen? Hier sind Rückmeldungen auf die vorgeschlagenen Eingaben:

    Zunächst ein Update gibt bereits eine Fehlermeldung.

    Code:
    tom@linux-h38h:~> sudo zypper update 
    [sudo] Passwort für root:  
    Metadaten von Repository 'libdvdcss' abrufen ...
    [Fehler] 
    Repository 'libdvdcss' ist ungültig.
    [libdvdcss|http://opensuse-guide.org/repo/openSUSE_Leap_15-0/] Keine gültigen Metadaten bei dem festgelegten URL gefunden
    Überprüfen Sie, ob die für dieses Repository bestimmten URIs auf ein gültiges Repository verweisen. 
    Warnung: Repository 'libdvdcss' wird aufgrund des obigen Fehlers übersprungen. 
    Einige der Repositorys konnten aufgrund eines Fehlers nicht aktualisiert werden.
    Repository-Daten werden geladen... 
    Installierte Pakete werden gelesen... 
    
    Die folgenden 19 Paketaktualisierungen werden NICHT installiert:
    ffmpeg-3 gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libgstgl-1_0-0 libgstphotography-1_0-0 
     libpostproc54 libquicktime0 libsox3 libswresample2 libswscale4 libxine2-pulse sox vlc-codec-gstreamer 
    
    Keine auszuführenden Aktionen.
    zypper ar -f http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman
    Code:
     tom@linux-h38h:~> su - 
    Passwort:  
    linux-h38h:~ # zypper ar -f http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman 
    Adding repository 'packman' ...[error] 
    Repository named 'packman' already exists. Please use another alias.
    zypper ar -f http://opensuse-guide.org/repo/openSUSE_Leap_15.0/ libdvdcss
    Code:
     linux-h38h:~ # zypper ar -f http://opensuse-guide.org/repo/openSUSE_Leap_15.0/ libdvdcss 
    Adding repository 'libdvdcss' ...[error] 
    Repository named 'libdvdcss' already exists. Please use another alias.
    zypper ref
    Code:
     linux-h38h:~ # zypper ref 
    Retrieving repository 'libdvdcss' metadata ...[error] 
    Repository 'libdvdcss' is invalid.
    [libdvdcss|http://opensuse-guide.org/repo/openSUSE_Leap_15-0/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository. 
    Skipping repository 'libdvdcss' because of the above error.
    Repository 'packman' is up to date.                                                                                           
    Repository 'openSUSE-Leap-15.0-Non-Oss' is up to date.                                                                        
    Repository 'openSUSE-Leap-15.0-Oss' is up to date.                                                                            
    Repository 'openSUSE-Leap-15.0-Update' is up to date.                                                                         
    Repository 'openSUSE-Leap-15.0-Update-Non-Oss' is up to date.                                                                 
    Some of the repositories have not been refreshed because of an error.
    zypper install -f libxine2-codecs...
    Code:
     linux-h38h:~ # zypper install -f libxine2-codecs ffmpeg-3 lame dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-add
    on gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 g
    streamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs vlc-codec-gstreamer ogmtools libavc
    odec58 flash-player flash-player-ppapi 
    Retrieving repository 'libdvdcss' metadata ...[error] 
    Repository 'libdvdcss' is invalid.
    [libdvdcss|http://opensuse-guide.org/repo/openSUSE_Leap_15-0/] Valid metadata not found at specified URL                     
    Please check if the URIs defined for this repository are pointing to a valid repository. 
    Warning: Skipping repository 'libdvdcss' because of the above error. 
    Some of the repositories have not been refreshed because of an error.
    Loading repository data... 
    Reading installed packages... 
    Forcing installation of 'gstreamer-plugins-bad-1.12.5-lp150.2.5.2.x86_64' from repository 'packman'. 
    Forcing installation of 'ffmpeg-3-3.4.4-lp150.9.6.x86_64' from repository 'packman'. 
    Forcing installation of 'gstreamer-plugins-ugly-1.12.5-lp150.2.4.x86_64' from repository 'packman'. 
    Forcing installation of 'dvdauthor-0.7.2-lp150.1.5.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Forcing installation of 'lame-3.100-lp150.1.5.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Forcing installation of 'gstreamer-plugins-libav-1.12.5-lp150.3.3.x86_64' from repository 'packman'. 
    Forcing installation of 'vlc-3.0.2-lp150.3.5.1.x86_64' from repository 'packman'. 
    Forcing installation of 'x265-3.0-lp150.1.1.x86_64' from repository 'packman'. 
    Forcing installation of 'libavcodec58-4.0.2-lp150.18.5.x86_64' from repository 'packman'. 
    Forcing installation of 'ogmtools-1.5-lp150.1.3.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Forcing installation of 'x264-0.155svn20190201-lp150.1.1.x86_64' from repository 'packman'. 
    Forcing installation of 'flash-player-32.0.0.142-lp150.1.1.x86_64' from repository 'packman'. 
    Forcing installation of 'libxine2-codecs-1.2.9-lp150.143.1.x86_64' from repository 'packman'. 
    Forcing installation of 'gstreamer-plugins-base-1.12.5-lp150.1.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Forcing installation of 'gstreamer-plugins-bad-orig-addon-1.12.5-lp150.2.5.2.x86_64' from repository 'packman'. 
    Forcing installation of 'gstreamer-plugins-ugly-orig-addon-1.12.5-lp150.2.4.x86_64' from repository 'packman'. 
    Forcing installation of 'vlc-codecs-3.0.2-lp150.3.5.1.x86_64' from repository 'packman'. 
    Forcing installation of 'gstreamer-plugins-good-1.12.5-lp150.1.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Forcing installation of 'flash-player-ppapi-32.0.0.142-lp150.1.1.x86_64' from repository 'packman'. 
    Forcing installation of 'vlc-codec-gstreamer-3.0.2-lp150.3.5.1.x86_64' from repository 'packman'. 
    Forcing installation of 'smplayer-18.2.2-lp150.1.4.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Forcing installation of 'gstreamer-plugins-qt5-1.2.0-lp150.1.6.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Forcing installation of 'gstreamer-plugins-good-extra-1.12.5-lp150.1.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'. 
    Resolving package dependencies... 
    3 Problems: 
    Problem: vlc-codecs-3.0.2-lp150.3.5.1.x86_64 requires libavcodec57(unrestricted), but this requirement cannot be provided 
    Problem: ffmpeg-3-3.4.4-lp150.9.6.x86_64 requires libavformat57 = 3.4.4-lp150.9.6, but this requirement cannot be provided 
    Problem: gstreamer-plugins-libav-1.12.5-lp150.3.3.x86_64 requires libavcodec57(unrestricted), but this requirement cannot be 
    provided 
    
    Problem: vlc-codecs-3.0.2-lp150.3.5.1.x86_64 requires libavcodec57(unrestricted), but this requirement cannot be provided 
     not installable providers: libavcodec57-3.4.4-lp150.9.6.x86_64[packman] 
    Solution 1: Following actions will be done: 
     install libavcodec57-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libavdevice57-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libswresample2-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libavutil55-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libpostproc54-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libswscale4-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libavresample3-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
    Solution 2: do not install vlc-codecs-3.0.2-lp150.3.5.1.x86_64 
    Solution 3: break vlc-codecs-3.0.2-lp150.3.5.1.x86_64 by ignoring some of its dependencies 
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): c
    

    zypper mr -p 20 packman

    zypper dup --from packman



    Code:
    linux-h38h:~ # zypper mr -p 20 packman 
    Repository 'packman' priority has been left unchanged (20) 
    Nothing to change for repository 'packman'. 
    linux-h38h:~ # zypper dup --from packman 
    Retrieving repository 'libdvdcss' metadata ...[error] 
    Repository 'libdvdcss' is invalid.
    [libdvdcss|http://opensuse-guide.org/repo/openSUSE_Leap_15-0/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository. 
    Warning: Skipping repository 'libdvdcss' because of the above error. 
    Some of the repositories have not been refreshed because of an error.
    Loading repository data... 
    Reading installed packages... 
    Computing distribution upgrade... 
    19 Problems: 
    Problem: problem with installed package libavformat57-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package vlc-codec-gstreamer-3.0.2-lp150.3.3.1.x86_64 
    Problem: problem with installed package libgstgl-1_0-0-1.12.5-lp150.2.3.1.x86_64 
    Problem: problem with installed package libswresample2-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package libsox3-14.4.2-lp150.3.3.x86_64 
    Problem: problem with installed package libavresample3-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package libxine2-pulse-1.2.9-lp150.2.5.x86_64 
    Problem: problem with installed package libgstphotography-1_0-0-1.12.5-lp150.2.3.1.x86_64 
    Problem: problem with installed package libswscale4-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package libavcodec57-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package ffmpeg-3-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package libquicktime0-1.2.4cvs20150223-lp150.3.7.x86_64 
    Problem: problem with installed package libavfilter6-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package libpostproc54-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package libavdevice57-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package libavutil55-3.4.4-lp150.6.1.x86_64 
    Problem: problem with installed package sox-14.4.2-lp150.3.3.x86_64 
    Problem: problem with installed package gstreamer-plugins-ugly-lang-1.12.5-lp150.1.1.noarch 
    Problem: problem with installed package gstreamer-plugins-bad-lang-1.12.5-lp150.2.3.1.noarch 
    
    Problem: problem with installed package libavformat57-3.4.4-lp150.6.1.x86_64 
    Solution 1: install libavformat57-3.4.4-lp150.9.6.x86_64 (with vendor change) 
     openSUSE  -->  http://packman.links2linux.de 
    Solution 2: keep obsolete libavformat57-3.4.4-lp150.6.1.x86_64 
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): c 
    

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,694

    Default AW: Packman Fahlermeldung

    Als erstes:
    1 x ein Repo einbinden reicht, ein lbdvdcss Repo hast du eine falsche URL, also poste einmal:
    Code:
    zypper lr -d
    Danach schauen wir mit dem Rest.

  5. #5

    Default Re: AW: Packman Fahlermeldung

    Quote Originally Posted by Sauerland View Post
    Als erstes:
    1 x ein Repo einbinden reicht, ein lbdvdcss Repo hast du eine falsche URL, also poste einmal:
    Code:
    zypper lr -d
    Danach schauen wir mit dem Rest.
    Das Ergebnis sieht dann so aus:

    Code:
    
    linux-h38h:~ # zypper lr -d 
    Repository priorities in effect:                                                             (See 'zypper lr -P' for details) 
         20 (raised priority)  :  1 repository   
         99 (default priority) :  5 repositories 
    
    #  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   
    | URI                                                                                     | Service 
    ---+---------------------------+-----------------------------------------+---------+-----------+---------+----------+--------
    +-----------------------------------------------------------------------------------------+-------- 
    1 | libdvdcss                 | libdvdcss                               | Yes     | ( p) Yes  | Yes     |   99     | NONE   
    | http://opensuse-guide.org/repo/openSUSE_Leap_15-0/                                      |         
    2 | openSUSE-Leap-15.0-1      | openSUSE-Leap-15.0-1                    | No      | ----      | ----    |   99     | rpm-md 
    | hd:///?device=/dev/disk/by-id/usb-Kingston_DT_101_G2_001CC07CEE5CBC71F91802A1-0:0-part2 |         
    3 | packman                   | packman                                 | Yes     | (r ) Yes  | Yes     |   20     | rpm-md 
    | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/                      |         
    4 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    |   99     | NONE   
    | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/                     |         
    5 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   
    | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/                 |         
    6 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    |   99     | NONE   
    | http://download.opensuse.org/debug/update/leap/15.0/oss/                                |         
    7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   
    | http://download.opensuse.org/debug/update/leap/15.0/non-oss/                            |         
    8 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md 
    | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                       |         
    9 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md 
    | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                           |         
    10 | repo-source               | openSUSE-Leap-15.0-Source               | No      | ----      | ----    |   99     | NONE   
    | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/                    |         
    11 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   
    | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/                |         
    12 | repo-update               | openSUSE-Leap-15.0-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md 
    | http://download.opensuse.org/update/leap/15.0/oss/                                      |         
    13 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md 
    | http://download.opensuse.org/update/leap/15.0/non-oss/   
    
     
     p { margin-bottom: 0.25cm; line-height: 115%; background: transparent none repeat scroll 0% 0%; }a:link { color: rgb(0, 0, 128); text-decoration: underline; }
    Danach ändert sich erstmal wenig:

    Code:
     linux-h38h:~ # zypper update 
    Retrieving repository 'libdvdcss' metadata ...[error] 
    Repository 'libdvdcss' is invalid.
    [libdvdcss|http://opensuse-guide.org/repo/openSUSE_Leap_15-0/] Valid metadata not found at specified URL                     
    Please check if the URIs defined for this repository are pointing to a valid repository. 
    Warning: Skipping repository 'libdvdcss' because of the above error. 
    Some of the repositories have not been refreshed because of an error.
    Loading repository data... 
    Reading installed packages... 
    
    The following 19 package updates will NOT be installed:
     ffmpeg-3 gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang libavcodec57 libavdevice57 libavfilter6 libavformat57 
     libavresample3 libavutil55 libgstgl-1_0-0 libgstphotography-1_0-0 libpostproc54 libquicktime0 libsox3 libswresample2 
     libswscale4 libxine2-pulse sox vlc-codec-gstreamer 
    
    Nothing to do.

  6. #6

    Default Re: Packman Fahlermeldung

    Sollte ich vielleicht einfach die entsprechenden Libraries löschen und komplett neu aufbauen? Wenn ja, wie?

    Zur Info: (See 'zypper lr -P' for details):
    Code:
    tom@linux-h38h:~> zypper lr -P
    #  | Alias                     | Name                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität
    ---+---------------------------+-----------------------------------------+-----------+-----------------+----------------+----------
     3 | packman                   | packman                                 | Ja        | (r ) Ja         | Ja             |   20     
     1 | libdvdcss                 | libdvdcss                               | Ja        | ( p) Ja         | Ja             |   99     
     2 | openSUSE-Leap-15.0-1      | openSUSE-Leap-15.0-1                    | Nein      | ----            | ----           |   99     
     4 | repo-debug                | openSUSE-Leap-15.0-Debug                | Nein      | ----            | ----           |   99     
     5 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | Nein      | ----            | ----           |   99     
     6 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | Nein      | ----            | ----           |   99     
     7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | Nein      | ----            | ----           |   99     
     8 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Ja        | (r ) Ja         | Ja             |   99     
     9 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Ja        | (r ) Ja         | Ja             |   99     
    10 | repo-source               | openSUSE-Leap-15.0-Source               | Nein      | ----            | ----           |   99     
    11 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | Nein      | ----            | ----           |   99     
    12 | repo-update               | openSUSE-Leap-15.0-Update               | Ja        | (r ) Ja         | Ja             |   99     
    13 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Ja        | (r ) Ja         | Ja             |   99 
    

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,694

    Default AW: Packman Fahlermeldung

    1 | libdvdcss | libdvdcss | Yes | ( p) Yes | Yes | 99 | NONE
    | http://opensuse-guide.org/repo/openSUSE_Leap_15-0/
    Falsche URL:
    Code:
    http://opensuse-guide.org/repo/openSUSE_Leap_15.0/
    Man beachte den Punkt am Ende statt dem Minus: 15.0........

    Löschen und neu hinzufügen
    Also als root:
    Code:
    zypper rr libdvdcss
    Code:
    zypper ar -f http://opensuse-guide.org/repo/openSUSE_Leap_15.0/ libdvdcss
    Und wenn schon ein Repo mit demselben Namen vorhanden ist, gibt es diese Fehlermeldungen (siehe Beitrag #3):
    tom@linux-h38h:~> su -
    Passwort:
    linux-h38h:~ # zypper ar -f http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman
    Adding repository 'packman' ...[error]
    Repository named 'packman' already exists. Please use another alias.
    oder
    linux-h38h:~ # zypper ar -f http://opensuse-guide.org/repo/openSUSE_Leap_15.0/ libdvdcss
    Adding repository 'libdvdcss' ...[error]
    Repository named 'libdvdcss' already exists. Please use another alias.
    Da ist es dann egal, ob die URL in dem Repo stimmt oder nicht....
    Deswegen löschen wir oben erst und fügen neu hinzu.

    Nachdem du das libdvdcss Repo neu hinzugefügt hast, den langen Befehl ausführen, die Fehlermeldung aufmerksam lesen:

    Code:
    Problem: vlc-codecs-3.0.2-lp150.3.5.1.x86_64 requires libavcodec57(unrestricted), but this requirement cannot be provided 
     not installable providers: libavcodec57-3.4.4-lp150.9.6.x86_64[packman] 
    Solution 1: Following actions will be done: 
     install libavcodec57-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libavdevice57-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libswresample2-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libavutil55-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libpostproc54-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libswscale4-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
     install libavresample3-3.4.4-lp150.9.6.x86_64 (with vendor change) 
       openSUSE  -->  http://packman.links2linux.de 
    Solution 2: do not install vlc-codecs-3.0.2-lp150.3.5.1.x86_64 
    Solution 3: break vlc-codecs-3.0.2-lp150.3.5.1.x86_64 by ignoring some of its dependencies
    Wir wollen ja alles aus Packman, daher muss ein Wechsel der Pakete von openSUSE zu Packman erfolgen (vendor change), also Lösung 1.

  8. #8

    Default Re: Packman Fahlermeldung

    Hallo Sauerland, vielen Dank für Deine Mühe!
    Ich habe folgendes eingegeben:

    Code:
    tom@linux-h38h:~> su -
    Passwort: 
    linux-h38h:~ # zypper rr libdvdcss
    Removing repository 'libdvdcss' .......................................................................................[done]
    Repository 'libdvdcss' has been removed.
    
    linux-h38h:~ # zypper rr packman
    Removing repository 'packman' .........................................................................................[done]
    Repository 'packman' has been removed.
    
    linux-h38h:~ # zypper ar -f http://opensuse-guide.org/repo/openSUSE_Leap_15.0/ libdvdcss
    Adding repository 'libdvdcss' .........................................................................................[done]
    Repository 'libdvdcss' successfully added
    
    URI         : http://opensuse-guide.org/repo/openSUSE_Leap_15.0/
    Enabled     : Yes                                               
    GPG Check   : Yes                                               
    Autorefresh : Yes                                               
    Priority    : 99 (default priority)                             
    
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    linux-h38h:~ # zypper ar -f http://opensuse-guide.org/repo/openSUSE_Leap_15.0/ packman
    Adding repository 'packman' ...........................................................................................[done]
    Repository 'packman' successfully added
    
    URI         : http://opensuse-guide.org/repo/openSUSE_Leap_15.0/
    Enabled     : Yes                                               
    GPG Check   : Yes                                               
    Autorefresh : Yes                                               
    Priority    : 99 (default priority)                             
    
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    linux-h38h:~ # zypper mr -p 20 packman
    Repository 'packman' priority has been set to 20.
    Bis hier hin sieht alles gut aus.

  9. #9

    Default Re: Packman Fahlermeldung

    Aber wenn ich den langen Befehl mit Lösung 1 eigebe, steht am Ende immer noch eine Fehlermeldung...

    Code:
    linux-h38h:~ # zypper install -f libxine2-codecs ffmpeg-3 lame dvdauthor  gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon  gstreamer-plugins-base gstreamer-plugins-good  gstreamer-plugins-good-extra gstreamer-plugins-libav  gstreamer-plugins-qt5 gstreamer-plugins-ugly  gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs  vlc-codec-gstreamer ogmtools libavcodec58 flash-player  flash-player-ppapi
    Retrieving repository 'libdvdcss' metadata ............................................................................[done]
    Building repository 'libdvdcss' cache .................................................................................[done]
    Retrieving repository 'packman' metadata ..............................................................................[done]
    Building repository 'packman' cache ...................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Package 'gstreamer-plugins-bad-orig-addon' not found.
    Package 'vlc-codecs' not found.
    Package 'flash-player-ppapi' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
    Forcing installation of 'gstreamer-plugins-base-1.12.5-lp150.1.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'gstreamer-plugins-bad-1.12.5-lp150.2.3.1.x86_64' from repository 'openSUSE-Leap-15.0-Update'.
    Forcing installation of 'gstreamer-plugins-good-1.12.5-lp150.1.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'gstreamer-plugins-ugly-1.12.5-lp150.1.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'vlc-3.0.2-lp150.3.3.1.x86_64' from repository 'openSUSE-Leap-15.0-Update'.
    Forcing installation of 'lame-3.100-lp150.1.5.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'gstreamer-plugins-libav-1.12.5-lp150.2.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'smplayer-18.2.2-lp150.1.4.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'dvdauthor-0.7.2-lp150.1.5.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'gstreamer-plugins-qt5-1.2.0-lp150.1.6.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'gstreamer-plugins-good-extra-1.12.5-lp150.1.1.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'ogmtools-1.5-lp150.1.3.x86_64' from repository 'openSUSE-Leap-15.0-Oss'.
    Forcing installation of 'vlc-codec-gstreamer-3.0.2-lp150.3.3.1.x86_64' from repository 'openSUSE-Leap-15.0-Update'.
    Package 'flash-player' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
    Package 'gstreamer-plugins-ugly-orig-addon' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
    Package 'libxine2-codecs' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
    Forcing installation of 'ffmpeg-3-3.4.4-lp150.6.1.x86_64' from repository 'openSUSE-Leap-15.0-Update'.
    Forcing installation of 'libavcodec58-4.0.2-lp150.13.1.x86_64' from repository 'openSUSE-Leap-15.0-Update'.
    Package 'x265' not found.
    Package 'x264' not found.
    Resolving package dependencies...
    
    Problem: vlc-3.0.2-lp150.3.3.1.x86_64 requires vlc-noX = 3.0.2-lp150.3.3.1, but this requirement cannot be provided
      not installable providers: vlc-noX-3.0.2-lp150.3.3.1.x86_64[repo-update]
     Solution 1: Following actions will be done:
      downgrade of vlc-noX-3.0.2-lp150.3.5.1.x86_64 to vlc-noX-3.0.2-lp150.3.3.1.x86_64
      install vlc-noX-3.0.2-lp150.3.3.1.x86_64 (with vendor change)
        http://packman.links2linux.de  -->  openSUSE
      downgrade of vlc-qt-3.0.2-lp150.3.5.1.x86_64 to vlc-qt-3.0.2-lp150.3.3.1.x86_64
      install vlc-qt-3.0.2-lp150.3.3.1.x86_64 (with vendor change)
        http://packman.links2linux.de  -->  openSUSE
      downgrade of libvlc5-3.0.2-lp150.3.5.1.x86_64 to libvlc5-3.0.2-lp150.3.3.1.x86_64
      install libvlc5-3.0.2-lp150.3.3.1.x86_64 (with vendor change)
        http://packman.links2linux.de  -->  openSUSE
      downgrade of libvlccore9-3.0.2-lp150.3.5.1.x86_64 to libvlccore9-3.0.2-lp150.3.3.1.x86_64
      install libvlccore9-3.0.2-lp150.3.3.1.x86_64 (with vendor change)
        http://packman.links2linux.de  -->  openSUSE
     Solution 2: do not install vlc-3.0.2-lp150.3.3.1.x86_64
     Solution 3: break vlc-3.0.2-lp150.3.3.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...
    
    The following 29 NEW packages are going to be installed:
      dvdauthor gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 libGraphicsMagick-Q16-3
      libGraphicsMagick3-config libavcodec58 libavutil56 libdvdcss2 libiec61883-0 liblua5_1-5 librubberband2 libswresample3
      libuchardet0 libvapoursynth-43 libvapoursynth-script0 lua51 lua51-ldbus lua51-lua-dbus lua51-lua-mpris mpv
      mpv-bash-completion mpv-plugin-mpris ogmtools python3-vapoursynth smplayer smplayer-lang vlc-lang youtube-dl
    
    The following 7 packages are going to be downgraded:
      gstreamer-plugins-bad gstreamer-plugins-ugly libvlc5 libvlccore9 vlc vlc-noX vlc-qt
    
    The following 5 packages are going to be reinstalled:
      ffmpeg-3 gstreamer-plugins-base gstreamer-plugins-good lame vlc-codec-gstreamer
    
    The following 2 recommended packages were automatically selected:
      smplayer-lang youtube-dl
    
    The following 7 packages are going to change vendor:
      gstreamer-plugins-bad   http://packman.links2linux.de -> openSUSE
      gstreamer-plugins-ugly  http://packman.links2linux.de -> openSUSE
      libvlc5                 http://packman.links2linux.de -> openSUSE
      libvlccore9             http://packman.links2linux.de -> openSUSE
      vlc                     http://packman.links2linux.de -> openSUSE
      vlc-noX                 http://packman.links2linux.de -> openSUSE
      vlc-qt                  http://packman.links2linux.de -> openSUSE
    
    7 packages to downgrade, 29 new, 5 to reinstall, 7  to change vendor.
    Overall download size: 26.9 MiB. Already cached: 0 B. After the operation, additional 62.7 MiB will be used.
    Continue? [y/n/...? shows all options] (y): y
    Retrieving package libdvdcss2-1.4.2-lp150.1.1.x86_64                                   (1/41),  66.2 KiB (175.3 KiB unpacked)
    Retrieving: (.....) 
    
    Checking for file conflicts: ..........................................................................................[done]
    ( 1/41) Installing: libdvdcss2-1.4.2-lp150.1.1.x86_64 .................................................................[done]
    ( 2/41) Installing: gstreamer-plugins-base-1.12.5-lp150.1.1.x86_64 ....................................................[done]
    ( 3/41) Installing: gstreamer-plugins-libav-1.12.5-lp150.2.1.x86_64 ...................................................[done]
    ( 4/41) Installing: gstreamer-plugins-qt5-1.2.0-lp150.1.6.x86_64 ......................................................[done]
    ( 5/41) Installing: lame-3.100-lp150.1.5.x86_64 .......................................................................[done]
    ( 6/41) Installing: libiec61883-0-1.2.0-lp150.1.10.x86_64 .............................................................[done]
    ( 7/41) Installing: liblua5_1-5-5.1.5-lp150.2.17.x86_64 ...............................................................[done]
    ( 8/41) Installing: librubberband2-1.8.1-lp150.1.9.x86_64 .............................................................[done]
    ( 9/41) Installing: libuchardet0-0.0.6-lp150.2.1.x86_64 ...............................................................[done]
    (10/41) Installing: libvapoursynth-43-43-lp150.2.1.x86_64 .............................................................[done]
    (11/41) Installing: lua51-5.1.5-lp150.2.17.x86_64 .....................................................................[done]
    Additional rpm output:
    update-alternatives: using /usr/bin/lua5.1 to provide /usr/bin/lua (lua) in auto mode                                        
    
    (12/41) Installing: ogmtools-1.5-lp150.1.3.x86_64 .....................................................................[done]
    (13/41) Installing: gstreamer-plugins-ugly-1.12.5-lp150.1.1.x86_64 ....................................................[done]
    (14/41) Installing: gstreamer-plugins-good-1.12.5-lp150.1.1.x86_64 ....................................................[done]
    (15/41) Installing: python3-vapoursynth-43-lp150.2.1.x86_64 ...........................................................[done]
    (16/41) Installing: lua51-ldbus-0.0+git20161023.e277e22-lp150.1.3.x86_64 ..............................................[done]
    (17/41) Installing: gstreamer-plugins-good-extra-1.12.5-lp150.1.1.x86_64 ..............................................[done]
    (18/41) Installing: libvapoursynth-script0-43-lp150.2.1.x86_64 ........................................................[done]
    (19/41) Installing: lua51-lua-dbus-0.0+git20170818.8fe38d0-lp150.1.3.x86_64 ...........................................[done]
    (20/41) Installing: lua51-lua-mpris-0.0+git20170918.28b1c75-lp150.3.1.x86_64 ..........................................[done]
    (21/41) Installing: ffmpeg-3-3.4.4-lp150.6.1.x86_64 ...................................................................[done]
    (22/41) Installing: gstreamer-plugins-bad-1.12.5-lp150.2.3.1.x86_64 ...................................................[done]
    (23/41) Installing: libGraphicsMagick3-config-1.3.29-lp150.3.21.1.x86_64 ..............................................[done]
    (24/41) Installing: libavutil56-4.0.2-lp150.13.1.x86_64 ...............................................................[done]
    (25/41) Installing: youtube-dl-2018.09.08-lp150.2.3.1.noarch ..........................................................[done]
    (26/41) Installing: libvlccore9-3.0.2-lp150.3.3.1.x86_64 ..............................................................[done]
    (27/41) Installing: libGraphicsMagick-Q16-3-1.3.29-lp150.3.21.1.x86_64 ................................................[done]
    (28/41) Installing: libswresample3-4.0.2-lp150.13.1.x86_64 ............................................................[done]
    (29/41) Installing: libvlc5-3.0.2-lp150.3.3.1.x86_64 ..................................................................[done]
    (30/41) Installing: libavcodec58-4.0.2-lp150.13.1.x86_64 ..............................................................[done]
    (31/41) Installing: vlc-noX-3.0.2-lp150.3.3.1.x86_64 ..................................................................[done]
    (32/41) Installing: vlc-3.0.2-lp150.3.3.1.x86_64 ......................................................................[done]
    (33/41) Installing: vlc-qt-3.0.2-lp150.3.3.1.x86_64 ...................................................................[done]
    (34/41) Installing: vlc-lang-3.0.2-lp150.3.3.1.noarch .................................................................[done]
    (35/41) Installing: vlc-codec-gstreamer-3.0.2-lp150.3.3.1.x86_64 ......................................................[done]
    (36/41) Installing: mpv-0.27.2-lp150.4.2.x86_64 .......................................................................[done]
    (37/41) Installing: dvdauthor-0.7.2-lp150.1.5.x86_64 ..................................................................[done]
    (38/41) Installing: smplayer-18.2.2-lp150.1.4.x86_64 ..................................................................[done]
    (39/41) Installing: mpv-plugin-mpris-0.0+git20170918.28b1c75-lp150.3.1.x86_64 .........................................[done]
    (40/41) Installing: mpv-bash-completion-3.3.16-lp150.4.2.noarch .......................................................[done]
    (41/41) Installing: smplayer-lang-18.2.2-lp150.1.4.noarch .............................................................[done]
    Installation has completed with error.
    
    linux-h38h:~ # zypper dup --from packman
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    Nothing to do.
    Am Ende steht "Installation has completed with error". Und Videos werden immer noch nicht reproduziert.

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,694

    Default AW: Packman Fahlermeldung

    Ich habe nicht geschrieben, das Packman Repo zu löschen und dann noch mal hinzuzufügen und dies dann auch noch mit falscher URL!.

    Deswegen funktioniert der lange Befehl auch nicht!

    Als root:
    Code:
    zypper rr packman
    Repo löschen
    Code:
    zypper ar -f -p 20 http://packman.jacobs-university.de/suse/openSUSE_Leap_15.0/ packman
    Repo mit autorefresh und Priorität hinzufügen
    Code:
    zypper install -f libxine2-codecs ffmpeg-3 lame dvdauthor  gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon  gstreamer-plugins-base gstreamer-plugins-good  gstreamer-plugins-good-extra gstreamer-plugins-libav  gstreamer-plugins-qt5 gstreamer-plugins-ugly  gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs  vlc-codec-gstreamer ogmtools libavcodec58 flash-player  flash-player-ppapi
    Pakete installieren
    Code:
    zypper dup --from packman
    Alle Pakete auf packman umstellen, die noch nicht von openSUSE nach packman umgestellt sind

    Bitte nur diese 4 Befehle ausführen (Erklärung unter der Befehlszeile)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •