Results 1 to 10 of 10

Thread: Strange issue with TeamViewer in KDE

  1. #1

    Default Strange issue with TeamViewer in KDE

    I just downloaded latest TeamViewer 14 for Linux from their website, the portable tar.xz file.
    It's supposedly latest stable indeed.

    After verifying needed packages were installed, I ran it -from command line- and seemingly worked well.
    But, if hitting TeamViewer's 'X' close window button (top right), as if wanting to close TeamViewer, it just disappears but stills alive, given command line prompt doesn't come back. I had to hit Ctrl+C.
    Using File -> Exit does work on the other hand.

    Is it that closing TeamViewer window only hides it somewhere in KDE? How to tell? There was nothing in the taskbar, system tray, or the like...

    Thanks.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: Strange issue with TeamViewer in KDE

    That is normal for team viewer it should be viable in the system tray and can be fully shut down from there with a right click and selecting quit option.

  3. #3

    Default Re: Strange issue with TeamViewer in KDE

    Thanks.

    Call me fool if you want, but I seemingly failed to locate the TeamViewer icon in systray, or even systray itself?
    Could you perhaps help a bit?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: Strange issue with TeamViewer in KDE

    Well that does depend on what desktop you use and how you configured things. In KDE Plasma the default would be bottom right on the bar at the bottom of the screen. It is a blue box with a double headed arrow

    But the system tray can live at many places depending on where you put it and which desktop is used

  5. #5

    Default Re: Strange issue with TeamViewer in KDE

    Quote Originally Posted by F_style View Post
    I just downloaded latest TeamViewer 14 for Linux from their website, the portable tar.xz file.
    It's supposedly latest stable indeed.

    After verifying needed packages were installed, I ran it -from command line- and seemingly worked well.
    But, if hitting TeamViewer's 'X' close window button (top right), as if wanting to close TeamViewer, it just disappears but stills alive, given command line prompt doesn't come back. I had to hit Ctrl+C.
    Using File -> Exit does work on the other hand.

    Is it that closing TeamViewer window only hides it somewhere in KDE? How to tell? There was nothing in the taskbar, system tray, or the like...

    Thanks.
    Teamviewer has a SUSE compatible rpm. Maybe try installing that instead. Try here.

  6. #6

    Default Re: Strange issue with TeamViewer in KDE

    Didn't like the rpm.

    Anyway, so I'm using KDE Plasma. As I already mentioned, Connection -> Exit TeamViewer properly closes TeamViewer and prompt comes back as normal in the command line.
    But if just "closing" the TeamViewer with the 'X' button at top right, this is what I get:
    https://paste.opensuse.org/21522743
    I couldn't find any "minimized" TeamViewer icon anywhere in desktop, prompt in command line never comes back, and TeamViewer process now lacks an "icon", though still consuming memory.

    Any ideas?

  7. #7

    Default Re: Strange issue with TeamViewer in KDE

    By chance ideas?

  8. #8

    Default Re: Strange issue with TeamViewer in KDE

    Click on those three horizontal bars by the clock (I don't recall if they have a proper term), then mouse-over the system stray which should bring up a pop-up with a wrench icon. Click the wrench to open the system tray settings, then click on the entries tab and make sure that visibility is not set to hidden next to the teamviewer entry. Teamviewer will need to be running when you do this, otherwise it won't show up in the entries list.

  9. #9

    Default Re: Strange issue with TeamViewer in KDE

    Thanks very much.
    The TeamViewer icon is set to "automatic", but anyways this indirectly helped me to get to the real issue: the TeamViewer icon *is present* in the system tray, but icon is *invisible*!

    In the screenshot case it's just left to the Bluetooth icon, just invisible! If I hover the mouse pointer over that area I get a pop-up saying TeamViewer.

    WTH? I'm sure I have my system fully updated -I just ran zypper up-. Is anyone else having this same issue? A bug in TeamViewer latest <stable> release?

  10. #10

    Default Re: Strange issue with TeamViewer in KDE

    I have Teamviewer installed also and am not experiencing this issue. You could try adding another system tray to your desktop to see if it shows up on the second one. Alternately you could try changing the desktop theme to see if that makes any difference. I've noticed on my system some icons do not show up properly on the suse dark theme, for example.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •