Results 1 to 4 of 4

Thread: eclipse photon 201812 hangs on connection to svn server

  1. #1

    Question eclipse photon 201812 hangs on connection to svn server

    new installation of eclipse 201812, java and c++. JDK11! With Setting Subclipse to use 1.11 javaHL provokes libsvnjavahl-1 not found!
    On using SVNKit Library and SVNKit Client Adapter make hang eclipse for ever on trying to connetc to the svn server.
    Aparently there is a netbeans-svnclientadapter available for Leap 15.0. But I don't know if this would work with eclipse and I don't know which other adaptor could be used to get a working solution. (same Eclipse version on debian 9 can connect to the svn-server!)
    Subversive has been stopped by Eclipse foundation! The same is true for subclipse from tigris! dl.bintray.com/subclipse is just a download site. Neither is helpful!
    Any hint to work around this killer is helpful.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,143
    Blog Entries
    2

    Default Re: eclipse photon 201812 hangs on connection to svn server

    According to the Subclipse Project page
    https://github.com/subclipse/subclipse/wiki

    You not only have to install the subclipse plugin,
    You also need to install the required dependencies... either a sufficiently current Subversion version and/or the JavaHL libraries (which your error says are not found)

    Requirements - current master

    • Eclipse 4.2 (Juno) or later
    • Java 6 or later
    • Subversion 1.10 or 1.11 JavaHL client libraries
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Thumbs down Re: eclipse photon 201812 hangs on connection to svn server

    Quote Originally Posted by tsu2 View Post
    According to the Subclipse Project page
    https://github.com/subclipse/subclipse/wiki

    You not only have to install the subclipse plugin,
    You also need to install the required dependencies... either a sufficiently current Subversion version and/or the JavaHL libraries (which your error says are not found)



    TSU
    please read the issue before you answer! Not helpful at all!

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,143
    Blog Entries
    2

    Default Re: eclipse photon 201812 hangs on connection to svn server

    Quote Originally Posted by hisbrj View Post
    please read the issue before you answer! Not helpful at all!
    OK, I'll bite.
    How are you satisfying the required dependency to provide JavaHL libraries?
    Or, do you not know how to do so?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •