Results 1 to 4 of 4

Thread: Kgpg and Kleopatra will no longer start on virgin Leap 15

  1. #1

    Default Kgpg and Kleopatra will no longer start on virgin Leap 15

    Hi Guys,

    Pristine install of Leap 15. No real customization has been done other than import my GPG keys into kgpg and created a system key while I was there.

    At boot the system warns me of not being able to decrypt the system key. A retry solves that problem.

    Kgpg nor Kleopatra want to start. Log snippet for Kgpg below.

    Code:
    2019-03-03T11:28:28.059890+01:00 linux-uxxd plasmashell[1971]: QXcbConnection: XCB error: 2 (BadValue), sequence: 24794, resource id: 98566149, major code: 142 (Unknown), minor code: 3
    2019-03-03T11:28:28.532322+01:00 linux-uxxd plasmashell[1971]: QXcbConnection: XCB error: 2 (BadValue), sequence: 24837, resource id: 100663301, major code: 142 (Unknown), minor code: 3
    2019-03-03T11:28:29.811814+01:00 linux-uxxd plasmashell[1971]: org.kde.plasmaquick: Applet "Application Menu" loaded after 0 msec
    2019-03-03T11:28:29.812453+01:00 linux-uxxd plasmashell[1971]: org.kde.plasmaquick: Increasing score for "Application Menu" to 100
    2019-03-03T11:28:30.598618+01:00 linux-uxxd plasmashell[1971]: trying to show an empty dialog
    2019-03-03T11:28:36.789195+01:00 linux-uxxd kgpg[2029]: QCommandLineParser: argument list cannot be empty, it should contain at least the executable name
    2019-03-03T11:28:36.824562+01:00 linux-uxxd kwin_x11[1931]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 3661, resource id: 33556794, major code: 18 (ChangeProperty), minor code: 0
    2019-03-03T11:28:37.615579+01:00 linux-uxxd kactivitymanagerd[2008]: Creating the cache for:  "applications:org.kde.kgpg.desktop"
    2019-03-03T11:28:37.616094+01:00 linux-uxxd kactivitymanagerd[2008]: Already in database?  true
    2019-03-03T11:28:37.616465+01:00 linux-uxxd kactivitymanagerd[2008]:       First update :  QDateTime(2019-03-02 18:37:41.000 CET Qt::TimeSpec(LocalTime))
    2019-03-03T11:28:37.616824+01:00 linux-uxxd kactivitymanagerd[2008]:        Last update :  QDateTime(2019-03-03 11:13:32.000 CET Qt::TimeSpec(LocalTime))
    2019-03-03T11:28:37.617163+01:00 linux-uxxd kactivitymanagerd[2008]: After the adjustment
    2019-03-03T11:28:37.617494+01:00 linux-uxxd kactivitymanagerd[2008]:      Current score :  3.96923
    2019-03-03T11:28:37.617811+01:00 linux-uxxd kactivitymanagerd[2008]:       First update :  QDateTime(2019-03-02 18:37:41.000 CET Qt::TimeSpec(LocalTime))
    2019-03-03T11:28:37.618124+01:00 linux-uxxd kactivitymanagerd[2008]:        Last update :  QDateTime(2019-03-03 11:13:32.000 CET Qt::TimeSpec(LocalTime))
    2019-03-03T11:28:37.618438+01:00 linux-uxxd kactivitymanagerd[2008]: Interval length is  0
    2019-03-03T11:28:37.618748+01:00 linux-uxxd kactivitymanagerd[2008]:          New score :  4.96923
    2019-03-03T11:28:37.639789+01:00 linux-uxxd kactivitymanagerd[2008]: ResourceScoreUpdated: "8ef604df-9516-43cb-88d0-e3d305bc00da" "org.kde.plasma.kicker" "applications:org.kde.kgpg.desktop"
    2019-03-03T11:28:37.640289+01:00 linux-uxxd plasmashell[1971]: KActivitiesStats( 0x55f989b8d920 ) ResultModelPrivate::onResultScoreUpdated  result added: "applications:org.kde.kgpg.desktop" score: 4.96923 last: 1551608916 first: 1551548261
    Please advise,
    Leo

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,185
    Blog Entries
    3

    Default Re: Kgpg and Kleopatra will no longer start on virgin Leap 15

    I'm not seeing any problems with "kgpg".

    I normally don't start it, because I'm a command line person. But it starts up just fine. First time it goes through setup. But I then logged out and logged in, and again "kgpg" starts up fine.

    I haven't tried "kleopatra" because in past experience it wants to mess with other settings (such as gpg-agent timeout settings), and that's annoying.

    I am not using "gpg" for kwallet. Perhaps that makes a difference. I suppose I could experiment with that, too.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: Kgpg and Kleopatra will no longer start on virgin Leap 15

    Ok, problem between screen and chair.

    Both do load at boot, and are hidden in the systemtray.

    Starting again from the menu therefore is futile. A decent app would've popped it open for me, but hey.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,185
    Blog Entries
    3

    Default Re: Kgpg and Kleopatra will no longer start on virgin Leap 15

    Fair enough.

    Yes, when I start "kgpg" it is very silent (except on the first run). I have to look in the tray to find it.
    openSUSE Leap 15.1; KDE Plasma 5;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •