Results 1 to 7 of 7

Thread: DNS trouble after zypper dup

  1. #1

    Default DNS trouble after zypper dup

    Ran zypper dup today to install about a month worth of updates (about 3000 packages to 20190226, previously 201901xx) on a machine that has been working fine for more than a year. Since then the NetworkManager applet shows a yellow exclamation mark next to the connection and anything requiring domain names fails (including zypper).

    IP connectivity is still there and
    Code:
    heptapus:/home/valentin # host google.com
    google.com has address 172.217.21.238
    google.com has IPv6 address 2a00:1450:4001:819::200e
    google.com mail is handled by 40 alt3.aspmx.l.google.com.
    google.com mail is handled by 10 aspmx.l.google.com.
    google.com mail is handled by 20 alt1.aspmx.l.google.com.
    google.com mail is handled by 50 alt4.aspmx.l.google.com.
    google.com mail is handled by 30 alt2.aspmx.l.google.com.
    looks okay to me as well.

    Can't see anything unusual here either, but networking is not really my expertise:
    Code:
    heptapus:/home/valentin # ip addr show wlp3s03: 
    wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 08:11:96:a7:04:d8 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.2/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp3s0
           valid_lft 862694sec preferred_lft 862694sec
        inet6 2001:4dd2:9d45:0:903:7fbe:4f96:5e1/64 scope global temporary dynamic 
           valid_lft 6931sec preferred_lft 3331sec
        inet6 2001:4dd2:9d45:0:204:835e:576b:6b04/64 scope global dynamic mngtmpaddr noprefixroute 
           valid_lft 6931sec preferred_lft 3331sec
        inet6 fe80::c93f:6be7:a6a1:d65f/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    Already tried the Troubleshooting guide, looked at /etc/resolv.conf and tried using wicked instead of NetworkManager. The problem has persisted across several reboots. Previous system snapshots fail to boot because of Name Service Cache Daemon not starting, so a rollback seem not to be an option, while the current configuration work except for that DNS problem.

    I'm running out of ideas where to look for possible causes or how to fix this short of attempting a complete reinstall.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,121
    Blog Entries
    15

    Default Re: DNS trouble after zypper dup

    Hi
    Seems it's a know issue, try;

    Code:
    netconfig update -f
    If that doesn't work you may need to manually create the softlink to it's new location...

    Code:
    ln -s /var/run/netconfig/resolv.conf /etc/resolv.conf
    Bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1124152
    Also: https://lists.opensuse.org/opensuse-.../msg00088.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: DNS trouble after zypper dup

    Hi,

    I ended up with the same problem after zypper dup. Machine been running tumbleweed since 2015 without problem. Been using linux since 2001. However, after several hours of searching for solution still came out a bust. DNS worked, according to nslookup etc, but still failed to resolve. Ended up reinstalling, which annoyed me a lot. One of the few problems I haven't been able to solve.

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,081

    Default Re: DNS trouble after zypper dup

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Seems it's a know issue, try;

    Code:
    netconfig update -f
    If that doesn't work you may need to manually create the softlink to it's new location...

    Code:
    ln -s /var/run/netconfig/resolv.conf /etc/resolv.conf
    Bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1124152
    Also: https://lists.opensuse.org/opensuse-.../msg00088.html
    Checked resolv.conf:

    Code:
    erlangen:~ # readlink -f /etc/resolv.conf 
    /run/netconfig/resolv.conf
    erlangen:~ #
    Any idea why /var got dropped from pathname? Tumbleweed 20190108 definitely had a file /etc/resolv.conf instead of a link. Name resolution failed randomly and required restarting the network e.g. after resume from suspend. The linked version never failed so far.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,121
    Blog Entries
    15

    Default Re: DNS trouble after zypper dup

    Quote Originally Posted by karlmistelberger View Post
    Checked resolv.conf:

    Code:
    erlangen:~ # readlink -f /etc/resolv.conf 
    /run/netconfig/resolv.conf
    erlangen:~ #
    Any idea why /var got dropped from pathname? Tumbleweed 20190108 definitely had a file /etc/resolv.conf instead of a link. Name resolution failed randomly and required restarting the network e.g. after resume from suspend. The linked version never failed so far.
    Hi
    If you cat the contents;

    Code:
    ### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
    ### autogenerated by netconfig!
    The /run not sure why that's created, maybe systemd related...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,397
    Blog Entries
    2

    Default Re: DNS trouble after zypper dup

    Re-read Malcom's post,
    And run the netconfig command exactly how he posted.

    You appear to have mixed up the netconfig update command with the command to create a symlink.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,081

    Default Re: DNS trouble after zypper dup

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If you cat the contents;

    Code:
    ### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
    ### autogenerated by netconfig!
    The /run not sure why that's created, maybe systemd related...
    It's a compatibility issue: "It is valid to implement /var/run as a symlink to /run." http://refspecs.linuxfoundation.org/...s/ch05s13.html

    Code:
    erlangen:~ # ll /var/run
    lrwxrwxrwx 1 root root 4 Nov  9  2016 /var/run -> /run
    erlangen:~ # 
    
    #Both pathnames are valid:
    
    erlangen:~ # ll /var/run/netconfig/resolv.conf
    -rw-r--r-- 1 root root 683 Mar  4 07:08 /var/run/netconfig/resolv.conf
    erlangen:~ # ll /run/netconfig/resolv.conf
    -rw-r--r-- 1 root root 683 Mar  4 07:08 /run/netconfig/resolv.conf
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •