Results 1 to 2 of 2

Thread: Anki 2.1.7 error: ModuleNotFoundError: No module named 'PyQt5.QtWebEngineWidgets'

  1. #1

    Default Anki 2.1.7 error: ModuleNotFoundError: No module named 'PyQt5.QtWebEngineWidgets'

    Full error message:
    "Traceback (most recent call last):
    File "/usr/bin/anki", line 6, in <module>
    import aqt
    File "/usr/share/anki/aqt/__init__.py", line 14, in <module>
    from aqt.qt import *
    File "/usr/share/anki/aqt/qt.py", line 16, in <module>
    from PyQt5.QtWebEngineWidgets import QWebEnginePage
    ModuleNotFoundError: No module named 'PyQt5.QtWebEngineWidgets' "

    I'm getting this error message on the latest available anki version in the tumbleweed repos.

    I think it's also related to this issue: https://forums.opensuse.org/showthre...WebEngine-5-12

    Searching around I found that:"Starting from PyQt 5.12, PyQtWebEngine is in a separate python{,2}-pyqtwebengine package."

    Anyone else have this issue? Is the only current fix to just wait until that new package hits the repos? Thanks.

  2. #2

    Default Re: Anki 2.1.7 error: ModuleNotFoundError: No module named 'PyQt5.QtWebEngineWidgets'

    I had that problem. fixed by installing from source from Anki's web page.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •