Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: networkmanager using 100% CPU

  1. #1

    Default networkmanager using 100% CPU

    Yesterday I upgraded Tumbleweed zu version 20190307. Soon after a reboot the fan started going faster. The top command showed that the NetworkManager uses up around 100%CPU (sometimes more sometimes less )
    Code:
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                   
     4739 root      20   0  398116  20124  15076 R 100.7 0.165   2:10.51 NetworkManager                                            
     2955 uli       20   0 1509968 232380 131672 S 0.667 1.908   0:51.03 Web Content                                               
     1641 root      20   0  369932 127504 103296 S 0.333 1.047   0:45.04 X                                                         
     1912 uli       20   0 1085504  62280  50460 S 0.333 0.511   0:02.37 kded5                                                     
     1947 uli       20   0 2875660 103404  68964 S 0.333 0.849   0:36.69 kwin_x11                                                  
     1967 uli       20   0  346632  46920  41720 S 0.333 0.385   0:00.91 kdeconnectd                                               
     2024 uli       20   0  451696  68568  58224 S 0.333 0.563   0:01.10 kgpg                                                      
     2767 uli       20   0 2133076 542760 181416 S 0.333 4.457   2:33.41 firefox
    Yesterday the command (as root)
    Code:
    systemctl restart NetworkManager
    brought the CPU usage down but today I have the same problem again and after every restart the CPU usage is up again to 100%. What could cause this? Has anyone similar problems? is it a bug? Normally the NetworkManager was often not even listed in the top command. Otherwise everything works well with this version.
    Cheers
    Uli

  2. #2

    Default Re: networkmanager using 100% CPU

    Some more information:
    I am normally connected through ethernet cable but wireless is enabled as well. I had a look at the window "Edit your network settings" and found for the wired connection in the tab "General Configuration" that under "Connect automatically with priority" the setting was to -100. The wireless settings there were all set to priority 0. I certainly have not changed this and I have set the setting to 50 since the wired connection should have a higher priority. Now after a restart of Network Manager the top command again hardly ever showed NetworkManager again and when it showed is was under 1%CPU
    Code:
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                   
     2955 uli       20   0 1509968 225868 131672 S 0.997 1.855   0:55.91 Web Content                                               
     3007 uli       20   0 1742488 313508 138424 S 0.997 2.575   0:36.74 Web Content                                               
     3028 uli       20   0 1498884 228548 133656 S 0.664 1.877   1:56.41 Web Content                                               
     3047 uli       20   0 1546416 209688 141660 S 0.664 1.722   0:34.62 Web Content                                               
     3085 uli       20   0 1650924 258536  98244 S 0.664 2.123   0:21.15 WebExtensions                                             
      181 root      20   0       0      0      0 I 0.332 0.000   0:01.51 kworker/u16:3-i915                                        
     1641 root      20   0  405628 157532 133324 S 0.332 1.294   0:56.20 X                                                         
     2767 uli       20   0 2146628 589248 181500 S 0.332 4.839   2:45.77 firefox                                                   
     4712 uli       20   0  379392  70436  58584 S 0.332 0.578   0:02.52 konsole                                                   
     6812 root      20   0  398060  18204  15200 S 0.332 0.149   0:00.39 NetworkManager                                            
     7407 uli       20   0   10816   4688   3804 R 0.332 0.038   0:00.29 top
    So that might have fixed the problem and hopefully after the next restart it will still be OK. It is only strange that after the update the priority changed!

  3. #3

    Default Re: networkmanager using 100% CPU

    Turning on the computer this morning NetworkManager again was at 100% CPU:
    Code:
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                   
     1350 root      20   0  398140  18088  15080 R 99.67 0.149   0:33.23 NetworkManager                                            
     2067 uli       20   0 2874288  97604  69000 S 2.326 0.802   0:01.17 kwin_x11                                                  
     1533 root      20   0  291936  50888  32784 S 1.329 0.418   0:01.18 X                                                         
     2792 uli       20   0  517776 102748  75900 S 0.997 0.844   0:00.81 kcmshell5
    I checked the settings and they were still as I left them yesterday with priority 50 for Ethernet and 0 for wireless. A restart of NetworkManager brought the CPU usage down again so that most of the time it is not reported by the top command. However something must be wrong that it always starts and then runs with such a high CPU load. Has anyone else seen this on Tumbleweed?

  4. #4

    Default Re: networkmanager using 100% CPU

    ...only thing I noticed after recent TW updates that in some cases the notorious IPv6 config (panel icon) switched automagically from "Ignored" to "Automatic"...
    Kind regards

    raspu

  5. #5

    Default Re: networkmanager using 100% CPU

    I always had IPv6 to automatic - there wouldn't have been a change for me.

  6. #6

    Default Re: networkmanager using 100% CPU

    Except from suse-rasputin I received no answer. This morning again I had to restart NetworkManager several times because it used 100% CPU and then after a few minutes the CPU heats up and the fan cuts in and gets louder and louder (faster) even if I only have firefox running. THis time I have added part of the NetworkManager logfile maybe someone can spot something there http://susepaste.org/view//18707926. Strangely enough it discovers "new connections" e.g. the one I use when visiting my daughter who lives 500km away - so it must take all the stored WiFi connection and tries to connect. Further I found "nisdomainname: you must be root to change the domain name" and I don't know what that is about. I don't use NIS at all and when checking NIS with yast it wants to install ybind or something like that so I cancelled out again since I never needed NIS.Is there a config file where this request comes from and where it can be changed?
    I did an zypper dup to version 20190310 again but there was no newer version of NetworkManager and the problem stayed the same. Further I disconnected the Wlan connection and watched top when only the ethernet connection was up but there was no change. I really would appreciate any help.
    Cheers
    Uli

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: networkmanager using 100% CPU

    I don't have an answer either, not experiencing the issue. Only one person reported the same on IRC. Can you check if the same issue exists for a newly created user?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: networkmanager using 100% CPU

    Thank you, Knurpht, I created a test user and there NetworkManager worked OK. Several times I restarted it and it hardly ever showed up at the top command (except when restarting with approx 6%CPU). Then log out and log in with my username and NetworkManager was up again at 100%. So it seems to be related to my profile but I still don't know what to do next. I guess there is a config file for my profile in ~/.config or ~/.kde4 but I didn't find anything looking like network.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: networkmanager using 100% CPU

    What does
    Code:
    cat ~/.config/plasma-nm
    give?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: networkmanager using 100% CPU

    There is not much
    Code:
    cat ~/.config/plasma-nm
    [General]
    ManageVirtualConnections=false
    UnlockModemOnDetection=true
    That is identical with the output for the testuser

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •