Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

  1. #1

    Default Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    So I am trying to follow the vendor change tutorial to use





    But in Yast there are pages of conflict questions to answer when I click the "switch from system to this repo" button.

    What is the proper way to do it?
    openSUSE Leap 15.0

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,180
    Blog Entries
    3

    Default Re: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    Step 1:
    Code:
    zypper lr -d
    This is to give the alias and/or number of each repo as listed.

    Step 2:
    Code:
    zypper dup --from reponame --allow-vendor-change
    For "reponame" in that line, use the alias or number of the particular repo.

    You will need to do that step twice -- once for each repo that you are switching to.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    Quote Originally Posted by nrickert View Post
    Step 1:
    Code:
    zypper lr -d
    This is to give the alias and/or number of each repo as listed.

    Step 2:
    Code:
    zypper dup --from reponame --allow-vendor-change
    For "reponame" in that line, use the alias or number of the particular repo.

    You will need to do that step twice -- once for each repo that you are switching to.
    The result is similar?
    Code:
    # zypper dup --from 5 --allow-vendor-change
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    23 Problems:
    Problem: libKF5XmlGui5-5.45.0-lp150.1.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: plasma5-integration-plugin-5.12.6-lp150.2.3.1.x86_64 requires libQt5Gui.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: xdg-desktop-portal-kde-5.12.5-lp150.1.1.x86_64 requires libQt5PrintSupport.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: akonadi-server-sqlite-17.12.3-lp150.1.2.x86_64 requires libQt5Sql.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libQt5Gui5-5.9.4-lp150.4.8.x86_64 requires libQt5DBus5 = 5.9.4, but this requirement cannot be provided
    Problem: libQt5PrintSupport5-5.9.4-lp150.4.8.x86_64 requires libQt5Widgets.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libKF5Declarative5-5.45.0-lp150.2.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: calibre-3.27.1-lp150.3.15.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: kwayland-5.45.0-lp150.2.3.1.x86_64 requires libQt5Gui5 = 5.9.4, but this requirement cannot be provided
    Problem: kwin5-5.12.6-lp150.2.3.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libKF5XmlGui5-5.45.0-lp150.1.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libKF5Declarative5-5.45.0-lp150.2.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: plasma5-integration-plugin-5.12.6-lp150.2.3.1.x86_64 requires libQt5Gui.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: kwin5-5.15.1-lp150.279.1.x86_64 requires breeze5-decoration >= 5.15, but this requirement cannot be provided
    Problem: kwin5-5.15.1-lp150.279.1.x86_64 requires libKF5WindowSystem5 >= 5.55.0, but this requirement cannot be provided
    Problem: kwin5-5.15.1-lp150.279.1.x86_64 requires plasma-framework >= 5.55.0, but this requirement cannot be provided
    Problem: kwin5-5.15.1-lp150.279.1.x86_64 requires plasma-framework >= 5.55.0, but this requirement cannot be provided
    Problem: libKF5WindowSystem5-lang-5.45.0-lp150.1.1.noarch requires libKF5WindowSystem5 = 5.45.0, but this requirement cannot be provided
    Problem: plasma5-session-5.15.1-lp150.441.1.noarch requires plasma5-workspace >= 5.15.1, but this requirement cannot be provided
    Problem: kwin5-5.15.1-lp150.279.1.x86_64 requires plasma-framework >= 5.55.0, but this requirement cannot be provided
    Problem: plasma-framework-components-5.45.0-lp150.2.1.x86_64 requires plasma-framework-private = 5.45.0, but this requirement cannot be provided
    Problem: kdeclarative-components-5.55.0-lp150.177.1.x86_64 requires kirigami2 >= 5.55, but this requirement cannot be provided
    Problem: kirigami2-lang-5.45.0-lp150.1.1.noarch requires kirigami2 = 5.45.0, but this requirement cannot be provided
    
    Problem: libKF5XmlGui5-5.45.0-lp150.1.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided
     Solution 1: install libKF5XmlGui5-5.55.0-lp150.184.1.x86_64 (with vendor change)
      openSUSE  -->  obs://build.opensuse.org/KDE
     Solution 2: keep obsolete libQt5Core5-5.9.4-lp150.4.8.x86_64
     Solution 3: break libKF5XmlGui5-5.45.0-lp150.1.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
    I mean, if this is the only way to do it I'll just answer every question.
    openSUSE Leap 15.0

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,180
    Blog Entries
    3

    Default Re: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    Here's another alternative that might work better.

    Carefully set priorities for your repos. You will want those new repos to have lower priority number than the standard. A lower number is a greater priority. And maybe packman needs to have a lower priority number than all.

    Then use:
    Code:
    zypper dup --allow-vendor-change
    The difference is that this way you will be switching to both new repos in a single step. I think you ran into a problem that when you switch to those repos separately, each has to come first. So you were getting conflict because you were only switching one at a time.

    You could maybe download the live argon iso, boot it up, and look at the repo setup there (including priorities).
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,806

    Default AW: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    And think of that:
    To revert the changes (kf5 and qt5 Repo) to the normal OSS Repo, it costs me hours......

    Also because of the dependencies.......

  6. #6

    Default Re: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    Quote Originally Posted by nrickert View Post
    Here's another alternative that might work better.

    Carefully set priorities for your repos. You will want those new repos to have lower priority number than the standard. A lower number is a greater priority. And maybe packman needs to have a lower priority number than all.

    Then use:
    Code:
    zypper dup --allow-vendor-change
    The difference is that this way you will be switching to both new repos in a single step. I think you ran into a problem that when you switch to those repos separately, each has to come first. So you were getting conflict because you were only switching one at a time.

    You could maybe download the live argon iso, boot it up, and look at the repo setup there (including priorities).
    Thank you ! Did what you suggested and upgraded smoothly so far. Priority for KDE, Qt5, OSS, Pacman were set 95, 95, 99, 100 respectively.
    The question is: should I give back their original priorities now? I noticed vlc is using OSS' packages. I guess I need to switch that to pacman manually as well right?

    Edit: BTW I did not know the argon project at all. That should have been my installation base.
    openSUSE Leap 15.0

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,180
    Blog Entries
    3

    Default Re: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    Quote Originally Posted by bonedriven View Post
    Did what you suggested and upgraded smoothly so far.
    I'm glad to hear that it went well.

    The question is: should I give back their original priorities now?
    Just leave them as they are (except maybe change packman). With normal updating, vendor-stickiness will keep you using the appropriate repos.

    I noticed vlc is using OSS' packages. I guess I need to switch that to pacman manually as well right?
    Yes, switch that. Maybe do a full packman switch for anything available in packman. It would have been better to give packman a lower priority.

    Edit: BTW I did not know the argon project at all. That should have been my installation base.
    For what you apparently want to do, yes you should have started with Argon. There isn't a DVD installer for Argon, but the live media contains a NET installer which (as far as I know) should set things up the way you wanted them.

    But doing it the way you have should give about the same result.
    openSUSE Leap 15.1; KDE Plasma 5;

  8. #8

    Default Re: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    Quote Originally Posted by nrickert View Post
    I'm glad to hear that it went well.
    Sorry for the big surprise. I just find that all my packages are still in KDE framework 4.12 instead of 4.15, and Qt in 5.9 instead of 5.12.

    I didn't check what were updated yesterday. It was just probably a normal update, but my attention was only on whether there would be tons of conflict questions when there weren't.

    So with vendor priorities set and "# zypper dup --allow-vendor-change" didn't bring the new repos' packages.
    openSUSE Leap 15.0

  9. #9

    Default Re: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    I am trying to see using the old method: Yast-switching system repo to this repo method.

    1. When I click KDE-QT repo-switch, I get tons of conflict questions. I click cancel to the dialogue. However I notice that the status for switching is not canceled.
    2. I then click KDE-framework repo- switch, I get tons of conflict questions again. I click cancel to the dialogue, and the status for the switching is not canceled.
    3. I directly click "accept" for Yast-software management window, I then get like 20 pages of conflict questions. I find that all of them in their 1st option says there would be a vendor change for the new packages from oss ->KDE, and
    deinstallation of calibre and akonadi server sqlite.

    If it's safe to do, I don't mind spending 10 mins to pick "1" for all of them. Calibre is not a priority but I'm not sure what's with "akonadi server sqlite"?
    openSUSE Leap 15.0

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,806

    Default AW: Trying to use the KDE_framework_5 and KDE_Qt5 repo but getting pages of conflict questions

    You have not posted your Repo-List as asked, so post it:
    Code:
    zypper lr -d

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •