Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: scilab 6.0.1 is not starting on Tumblweed

  1. #1

    Default scilab 6.0.1 is not starting on Tumblweed

    Hi,
    I have installed Scilab 6.0.1 directly from TW but the application is not starting up.
    During installation an error show "nothing provides java=10 for scilab6.0.1"
    can anyone help?

    Cheers

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,822
    Blog Entries
    1

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    Not sure how well scilab would work, but the following is what I did to successfully install scilab, avoiding many, many pitfalls...

    Note you cannot use the YaST installer, you must download the RPM to your machine first.
    Download the openjdk 10 runtime RPM from the link below(Link is from https://build.opensuse.org/package/s...ava-10-openjdk which itself is hard to find, not showing up consistently in a software search)
    https://download.opensuse.org/reposi....18.x86_64.rpm

    Then install
    Code:
    zypper in ~/Downloads/java-10-openjdk-10.0.2.0-2.18.x86_64.rpm
    The install will complain about a missing dependency, java-10-openjdk-headless... Select option 2 which is to ignore some dependencies.
    Because you're installing an RPM not from a configured repo, the install will also complain about a missing GPG key, choose "ignore"

    The install will proceed and automatically select the headless package for openjdk 1.8.

    Your requirement should now be med, you can now install scilab.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    I followed your solution but still have issue with scilab.
    Installed on other distros and had the same Java warning but working fine.
    Is there anything else I can do to fix this issue on TW?

    Thanks

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    817

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    Quote Originally Posted by neocurve View Post
    Hi,
    I have installed Scilab 6.0.1 directly from TW but the application is not starting up.
    During installation an error show "nothing provides java=10 for scilab6.0.1"
    can anyone help?

    Cheers
    I think so. No such problem here. Have openjdk:

    Code:
    erlangen:~ # zypper se --installed-only jdk
    Loading repository data...
    Reading installed packages...
    
    S  | Name                     | Summary                            | Type   
    ---+--------------------------+------------------------------------+--------
    i  | java-11-openjdk          | OpenJDK 11 Runtime Environment     | package
    i  | java-11-openjdk-devel    | OpenJDK 11 Development Environment | package
    i  | java-11-openjdk-headless | OpenJDK 11 Runtime Environment     | package
    i+ | java-11-openjdk-javadoc  | OpenJDK 11 API Documentation       | package
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,822
    Blog Entries
    1

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    You shouldn't just view what is installed,
    Better would be to identify what java is actually being used,

    Two commoncommands I've used are
    Code:
    which java
    Code:
    update-alternatives --config java
    It may also be that scilab currently does not support java-openjdk-11 so you'd have to install java-openjdk-10 and then use the "update-alternatives command above to set whichever java you want your system to use.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    817

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    Quote Originally Posted by tsu2 View Post
    You shouldn't just view what is installed,
    Better would be to identify what java is actually being used,

    Two commoncommands I've used are
    Code:
    which java
    Code:
    update-alternatives --config java
    It may also be that scilab currently does not support java-openjdk-11 so you'd have to install java-openjdk-10 and then use the "update-alternatives command above to set whichever java you want your system to use.

    TSU
    Code:
    erlangen:~ # which java
    /usr/bin/java
    erlangen:~ # update-alternatives --config java
    There are 2 choices for the alternative java (providing /usr/bin/java).
    
      Selection    Path                                    Priority   Status
    ------------------------------------------------------------
      0            /usr/lib64/jvm/jre-11-openjdk/bin/java   2105      auto mode
      1            /usr/lib/jalbum/jre64/bin/java           1         manual mode
    * 2            /usr/lib64/jvm/jre-11-openjdk/bin/java   2105      manual mode
    
    Press <enter> to keep the current choice[*], or type selection number: 
    erlangen:~ #
    Code:
    erlangen:~ # zypper in scilab
    Loading repository data...
    Reading installed packages...
    'scilab' is already installed.
    No update candidate for 'scilab-6.0.2-1.2.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    
    Nothing to do.
    erlangen:~ #
    Scilab does run the demos, e.g. simulations > n-pendulum ...
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  7. #7

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    Quote Originally Posted by karlmistelberger View Post
    I think so. No such problem here. Have openjdk:

    Code:
    erlangen:~ # zypper se --installed-only jdk
    Loading repository data...
    Reading installed packages...
    
    S  | Name                     | Summary                            | Type   
    ---+--------------------------+------------------------------------+--------
    i  | java-11-openjdk          | OpenJDK 11 Runtime Environment     | package
    i  | java-11-openjdk-devel    | OpenJDK 11 Development Environment | package
    i  | java-11-openjdk-headless | OpenJDK 11 Runtime Environment     | package
    i+ | java-11-openjdk-javadoc  | OpenJDK 11 API Documentation       | package
    erlangen:~ #

    here is my result:
    Code:
    shahram@EWS:~> zypper se --installed-only jdk
    Loading repository data...
    Reading installed packages...
    
    S  | Name                        | Summary                            | Type   
    ---+-----------------------------+------------------------------------+--------
    i+ | java-12-openjdk             | OpenJDK 12 Runtime Environment     | package
    i+ | java-12-openjdk-devel       | OpenJDK 12 Development Environment | package
    i+ | java-12-openjdk-headless    | OpenJDK 12 Runtime Environment     | package
    i+ | java-1_8_0-openjdk          | OpenJDK 8 Runtime Environment      | package
    i+ | java-1_8_0-openjdk-headless | OpenJDK 8 Runtime Environment      | package

  8. #8
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    817

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    Quote Originally Posted by neocurve View Post
    here is my result:
    Code:
    shahram@EWS:~> zypper se --installed-only jdk
    Loading repository data...
    Reading installed packages...
    
    S  | Name                        | Summary                            | Type   
    ---+-----------------------------+------------------------------------+--------
    i+ | java-12-openjdk             | OpenJDK 12 Runtime Environment     | package
    i+ | java-12-openjdk-devel       | OpenJDK 12 Development Environment | package
    i+ | java-12-openjdk-headless    | OpenJDK 12 Runtime Environment     | package
    i+ | java-1_8_0-openjdk          | OpenJDK 8 Runtime Environment      | package
    i+ | java-1_8_0-openjdk-headless | OpenJDK 8 Runtime Environment      | package
    That looks good. What about:

    Code:
    erlangen:~ # zypper lr -uEP
    #  | Alias                               | Name                                      | Enabled | GPG Check | Refresh | Priority | URI                                                                                       
    ---+-------------------------------------+-------------------------------------------+---------+-----------+---------+----------+-------------------------------------------------------------------------------------------
     3 | Packman                             | Packman                                   | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/                                       
     6 | download.opensuse.org-non-oss       | Haupt-Repository (NON-OSS)                | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/                                     
     7 | download.opensuse.org-oss           | Haupt-Repository (OSS)                    | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/                                         
     8 | download.opensuse.org-tumbleweed    | Hauptaktualisierungs-Repository           | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/                                           
     1 | Application_Geo                     | Application_Geo                           | Yes     | (r ) Yes  | Yes     |  100     | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_Tumbleweed/           
     2 | Google-Chrome                       | Google-Chrome                             | Yes     | (r ) Yes  | Yes     |  100     | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                       
    10 | home_malcolmlewis_TESTING           | Testing packages... (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | Yes     |  100     | http://download.opensuse.org/repositories/home:/malcolmlewis:/TESTING/openSUSE_Tumbleweed/
    11 | home_seife_testing                  | testing (openSUSE_Factory)                | Yes     | (r ) Yes  | Yes     |  100     | http://download.opensuse.org/repositories/home:/seife:/testing/openSUSE_Factory/          
    12 | http-download.opensuse.org-75c214b0 | home:Herbster0815                         | Yes     | (r ) Yes  | Yes     |  100     | http://download.opensuse.org/repositories/home:/Herbster0815/openSUSE_Tumbleweed/         
    14 | http-opensuse-guide.org-37124e10    | libdvdcss repository                      | Yes     | (r ) Yes  | Yes     |  100     | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                       
    15 | jalbum                              | jalbum                                    | Yes     | (  ) No   | Yes     |  100     | http://jalbum.net/download/software/yumrepo/                                              
    16 | myrepo                              | myrepo                                    | Yes     | ( p) Yes  | Yes     |  100     | dir:/home/karl/Downloads/myrepo                                                           
    erlangen:~ # zypper in scilab
    Loading repository data...
    Reading installed packages...
    'scilab' is already installed.
    No update candidate for 'scilab-6.0.2-1.2.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    
    Nothing to do.
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,822
    Blog Entries
    1

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    OK,
    I see that you may be seeing your error when <running> scilab whereas I only tested enough to install.

    Most times when I see that error, the Java environmental variables (eg JAVA_HOME) aren't set correctly, oftentimes you need to insert export statements in your bashrc, or the system profile.

    Update--- As I was writing this, I was also doing a little document search.
    Assuming that your java path is set incorrectly, I think the following page should allow you to inspect what path is currently set and if it needs to be modified, for you to do sol.

    https://help.scilab.org/docs/6.0.0/e...b04e39f3e.html

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #10

    Default Re: scilab 6.0.1 is not starting on Tumblweed

    java-10-openjdk installed with ignore error and installed 1-8 as well.
    java-11 installed from repos.
    Here is the result :
    EWS:/home/shahram # which java
    /usr/bin/java
    EWS:/home/shahram # update-alternatives --config java
    There are 2 choices for the alternative java (providing /usr/bin/java).

    Selection Path Priority Status
    ------------------------------------------------------------
    0 /usr/lib64/jvm/jre-11-openjdk/bin/java 2105 auto mode
    1 /usr/lib64/jvm/jre-1.8.0-openjdk/bin/java 1805 manual mode
    * 2 /usr/lib64/jvm/jre-11-openjdk/bin/java 2105 manual mode

    Press <enter> to keep the current choice[*], or type selection number:
    EWS:/home/shahram # zypper se --installed-only jdk
    Loading repository data...
    Reading installed packages...

    S | Name | Summary | Type
    ---+-------------------------------+------------------------------------+--------
    i+ | java-10-openjdk | OpenJDK 10 Runtime Environment | package
    i+ | java-11-openjdk | OpenJDK 11 Runtime Environment | package
    i+ | java-11-openjdk-accessibility | OpenJDK 11 accessibility connector | package
    i+ | java-11-openjdk-demo | OpenJDK 11 Demos | package
    i | java-11-openjdk-devel | OpenJDK 11 Development Environment | package
    i | java-11-openjdk-headless | OpenJDK 11 Runtime Environment | package
    i+ | java-11-openjdk-jmods | JMods for OpenJDK 11 | package
    i+ | java-11-openjdk-src | OpenJDK 11 Source Bundle | package
    i | java-1_8_0-openjdk-headless | OpenJDK 8 Runtime Environment | package
    EWS:/home/shahram #

    Scilab is now installed and open running. However, Xcos part are corrupted and not working.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •