Results 1 to 5 of 5

Thread: [LEAP 15][mariadb 10.2.9] What happened with 10.3.6 ?

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    380

    Default [LEAP 15][mariadb 10.2.9] What happened with 10.3.6 ?

    Greetings !!

    I just wanted to warn programmers using libmariadb-devel that the update to 3.0.9 causes issues with code source using the same way to process requests since 4 years at least.
    Downgrading to 3.0.7 resolves the issues.

    http://paste.opensuse.org/89178729

    In the upper side test with 3.0.9, it generates an error 1064... with no error message...
    In the lower side, after downgrade to 3.0.7, it worked as it always worked...

    The code is:

    Code:
        if (mysql_query(connexion, "SELECT Nom,CodePostal FROM CodesPostaux,Localités WHERE idCodePostal=Ref_CodesPostaux ORDER BY CodePostal")) 
      {
        wprintf(L"Erreur lors de l'exécution d'une requête SQL: %s !!\n",mysql_error(connexion));
        exit(1);
      }
    Any clues to help us follow the upgrades without having to go back to each source code to fix this kind of issue ?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,326
    Blog Entries
    15

    Default Re: [LEAP 15][mariadb 10.2.9] What happened with 10.3.6 ?

    Hi
    In Leap 15.0 I only see;

    Code:
    zypper if libmariadb-devel mariadb
    
    Information for package libmariadb-devel:
    -----------------------------------------
    Repository     : openSUSE-Leap-15.0-Update                        
    Name           : libmariadb-devel                                 
    Version        : 3.0.7-lp150.2.3.1                                
    
    Information for package mariadb:
    --------------------------------
    Repository     : openSUSE-Leap-15.0-Update      
    Name           : mariadb                        
    Version        : 10.2.15-lp150.2.6.1
    I would surmise you have a development project as a repository and pulling your packages from there rather than the default update repository...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    380

    Question Re: [LEAP 15][mariadb 10.2.9] What happened with 10.3.6 ?

    That is amazing, at the lab at school we had the same issue as mine yesterday.
    I did the same I did on my three computers here with LEAP 15: downgrade.

    But the versions are the same as the laptop that doesn't show the issue but the mysql client is still 10.3.6 (????)

    We rebooted the computers and the issue is the same: client is 10.3.6 and no way to execute the mysql_query() function.

    These are the repositories all the computers in the lab have they are all updated with the last kernel and mariadb3 downgraded as libmariadb-devel

    http://paste.opensuse.org/79739684

    sirius:/exemples/mysql # zypper se -v -i mariadb
    Loading repository data...
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    ---+-----------------------+---------+---------------------+--------+--------------------------
    il | libmariadb-devel | package | 3.0.3-lp150.1.2 | x86_64 | openSUSE-Leap-15.0-Oss
    name: libmariadb-devel
    i+ | libmariadb3 | package | 3.0.3-lp150.1.2 | x86_64 | openSUSE-Leap-15.0-Oss
    name: libmariadb3
    il | mariadb | package | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
    name: mariadb
    i+ | mariadb-client | package | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
    name: mariadb-client
    i+ | mariadb-errormessages | package | 10.2.15-lp150.2.6.1 | noarch | openSUSE-Leap-15.0-Update
    name: mariadb-errormessages
    These are the different packages I guess are linked with mysql/mariadb client.
    I checked with all my students on each computers ALL of them have these versions installed (some have on "il" flag, some have no "i+", ...) but only two computers (mine and one of my student) could run the
    test program with mysql client 10.2.9.

    What is wrong ?
    Notes: I had warnings with libcrypto43 and libssl45 that I removed libressl in order to wipe them out (in another post here).
    I did the same process with my students... it fixed nothing.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,326
    Blog Entries
    15

    Default Re: [LEAP 15][mariadb 10.2.9] What happened with 10.3.6 ?

    Hi
    Well your system(s) is/are out of date, maybe being directed to an out of date mirror

    Run the commands;
    Code:
    zypper -vvv ref -f
    zypper se -s mariadb
    zypper se -si mariadb
    I see;
    Code:
    zypper se -s mariadb
    Loading repository data...
    Reading installed packages...
    
    S | Name                   | Type       | Version             | Arch   | Repository               
    --+------------------------+------------+---------------------+--------+--------------------------
      | libmariadb-devel       | package    | 3.0.7-lp150.2.3.1   | x86_64 | openSUSE-Leap-15.0-Update
      | libmariadb-devel       | package    | 3.0.3-lp150.1.2     | x86_64 | openSUSE-Leap-15.0-Oss   
    i | libmariadb3            | package    | 3.0.7-lp150.2.3.1   | x86_64 | openSUSE-Leap-15.0-Update
    v | libmariadb3            | package    | 3.0.3-lp150.1.2     | x86_64 | openSUSE-Leap-15.0-Oss   
      | libmariadb3-32bit      | package    | 3.0.7-lp150.2.3.1   | x86_64 | openSUSE-Leap-15.0-Update
      | libmariadb3-32bit      | package    | 3.0.3-lp150.1.2     | x86_64 | openSUSE-Leap-15.0-Oss   
      | libmariadb_plugins     | package    | 3.0.7-lp150.2.3.1   | x86_64 | openSUSE-Leap-15.0-Update
      | libmariadb_plugins     | package    | 3.0.3-lp150.1.2     | x86_64 | openSUSE-Leap-15.0-Oss   
      | libmariadbprivate      | package    | 3.0.7-lp150.2.3.1   | x86_64 | openSUSE-Leap-15.0-Update
      | libmariadbprivate      | package    | 3.0.3-lp150.1.2     | x86_64 | openSUSE-Leap-15.0-Oss   
      | mariadb                | package    | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb                | package    | 10.2.15-lp150.2.3.2 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb                | package    | 10.2.14-lp150.1.1   | x86_64 | openSUSE-Leap-15.0-Oss   
      | mariadb                | srcpackage | 10.2.15-lp150.2.6.1 | noarch | openSUSE-Leap-15.0-Update
      | mariadb                | srcpackage | 10.2.15-lp150.2.3.2 | noarch | openSUSE-Leap-15.0-Update
      | mariadb-bench          | package    | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-bench          | package    | 10.2.15-lp150.2.3.2 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-bench          | package    | 10.2.14-lp150.1.1   | x86_64 | openSUSE-Leap-15.0-Oss   
      | mariadb-client         | package    | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-client         | package    | 10.2.15-lp150.2.3.2 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-client         | package    | 10.2.14-lp150.1.1   | x86_64 | openSUSE-Leap-15.0-Oss   
      | mariadb-connector-c    | srcpackage | 3.0.7-lp150.2.3.1   | noarch | openSUSE-Leap-15.0-Update
      | mariadb-connector-odbc | package    | 3.0.2-lp150.2.3     | x86_64 | openSUSE-Leap-15.0-Oss   
      | mariadb-errormessages  | package    | 10.2.15-lp150.2.6.1 | noarch | openSUSE-Leap-15.0-Update
      | mariadb-errormessages  | package    | 10.2.15-lp150.2.3.2 | noarch | openSUSE-Leap-15.0-Update
      | mariadb-errormessages  | package    | 10.2.14-lp150.1.1   | noarch | openSUSE-Leap-15.0-Oss   
      | mariadb-galera         | package    | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-galera         | package    | 10.2.15-lp150.2.3.2 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-galera         | package    | 10.2.14-lp150.1.1   | x86_64 | openSUSE-Leap-15.0-Oss   
      | mariadb-test           | package    | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-test           | package    | 10.2.15-lp150.2.3.2 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-test           | package    | 10.2.14-lp150.1.1   | x86_64 | openSUSE-Leap-15.0-Oss   
      | mariadb-tools          | package    | 10.2.15-lp150.2.6.1 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-tools          | package    | 10.2.15-lp150.2.3.2 | x86_64 | openSUSE-Leap-15.0-Update
      | mariadb-tools          | package    | 10.2.14-lp150.1.1   | x86_64 | openSUSE-Leap-15.0-Oss
    Last edited by malcolmlewis; 19-Feb-2019 at 11:40.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    380

    Default Re: [LEAP 15][mariadb 10.2.9] What happened with 10.3.6 ?

    Gosh !!
    I looked at the zypper's logs and realized, maybe because I went to the mariadb awful site (https://downloads.mariadb.org/connector-c) that I mismatched the versions from which I downgraded it was from 3.0.7 to 3.0.3 !!

    Code:
    2019-02-18 20:21:30|install|libmariadb3|3.0.7-lp150.2.3.1|x86_64||repo-update|b0b74b303db0c189e274229acf4310ff07aab20e722a4db14e5ecdffe1cd9800|
    2019-02-18 20:21:30|install|libmariadb-devel|3.0.7-lp150.2.3.1|x86_64|root@sirius.dezordi.world|repo-update|4a83907eb1ddaf4dbd65c3621f8627290e75f52eae8e3f4725fac28bd8bae476|
    2019-02-18 20:22:31|install|libmariadb3|3.0.3-lp150.1.2|x86_64|root@sirius.dezordi.world|repo-oss|7a8ea901543a9aced99955311c4736cf0424a2d31f6f49d2a0197a7edf028ff2|
    2019-02-18 20:22:31|install|libmariadb-devel|3.0.3-lp150.1.2|x86_64|root@sirius.dezordi.world|repo-oss|576bb7bb553e1f8a384c94c0d75d70a0bbccd4813b22e6599f1a5505927fa850|
    Sorry for the confusion... now I know what to do in my lab :{

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •