Results 1 to 2 of 2

Thread: Network printer wasn't working

  1. #1
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    157

    Default Network printer wasn't working

    I've been trying to get my Brother 7065DN printer to work under LEAP. For several days I couldn't get it to do anything. I finally did "zypper ve", which solved the dependency problems I suspected, and the printer now works. But the printer log still shows something very odd:

    E [15/Feb/2019:16:58:49 -0500] [CGI] cups-brf must be called as root
    E [15/Feb/2019:16:58:49 -0500] [cups-deviced] PID 1311 (cups-brf) stopped with status 1!
    E [15/Feb/2019:16:58:49 -0500] [cups-deviced] PID 1305 (gutenprint52+usb) stopped with status 1!
    E [15/Feb/2019:16:58:52 -0500] [CGI] cups-brf must be called as root
    E [15/Feb/2019:16:58:53 -0500] [cups-deviced] PID 1339 (cups-brf) stopped with status 1!
    E [15/Feb/2019:16:58:53 -0500] [cups-deviced] PID 1333 (gutenprint52+usb) stopped with status 1!
    W [15/Feb/2019:16:58:56 -0500] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [15/Feb/2019:16:58:56 -0500] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [15/Feb/2019:16:59:06 -0500] [CGI] cups-brf must be called as root
    E [15/Feb/2019:16:59:06 -0500] [cups-deviced] PID 1425 (cups-brf) stopped with status 1!
    E [15/Feb/2019:16:59:06 -0500] [cups-deviced] PID 1419 (gutenprint52+usb) stopped with status 1!
    E [16/Feb/2019:13:02:20 -0500] [CGI] cups-brf must be called as root
    E [16/Feb/2019:13:02:21 -0500] [cups-deviced] PID 21133 (cups-brf) stopped with status 1!
    E [16/Feb/2019:13:02:21 -0500] [cups-deviced] PID 21127 (gutenprint52+usb) stopped with status 1!
    E [16/Feb/2019:13:02:28 -0500] [cups-driverd] Bad driver information file \"/usr/share/cups/drv/generic-brf.drv\"!
    E [16/Feb/2019:13:02:28 -0500] [cups-driverd] Bad driver information file \"/usr/share/cups/drv/indexv3.drv\"!
    E [16/Feb/2019:13:02:28 -0500] [cups-driverd] Bad driver information file \"/usr/share/cups/drv/generic-ubrl.drv\"!
    E [16/Feb/2019:13:02:28 -0500] [cups-driverd] Bad driver information file \"/usr/share/cups/drv/cupsfilters.drv\"!
    E [16/Feb/2019:13:02:28 -0500] [cups-driverd] Bad driver information file \"/usr/share/cups/drv/sample.drv\"!
    E [16/Feb/2019:13:02:28 -0500] [cups-driverd] Bad driver information file \"/usr/share/cups/drv/indexv4.drv\"!
    Why am I getting these error messages? What should I do about them?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,576
    Blog Entries
    1

    Default Re: Network printer wasn't working

    Quote Originally Posted by pwabrahams View Post
    Why am I getting these error messages? What should I do about them?
    I get the same (re the cups-brf virtual backend for braille printers), and to date have just ignored them.

    There's a bug report for it here...
    https://bugzilla.redhat.com/show_bug.cgi?id=1657261#c1
    CUPS is reacting to 'Get-Devices' request, which starts cups-deviced binary, which starts every backend and returns all printers found by backends - cups-brf is needed to be run as root to work correctly (probably I can fix it in cups-filters) and gutenprint52+usb is probably called incorrectly or cannot cope up without any existing gutenprint supported printer. I'll get to it when there are not more urgent matters, I'm sorry.
    openSUSE Leap 15.1; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •