Results 1 to 3 of 3

Thread: zypper wont install local rpms

  1. #1

    Default zypper wont install local rpms

    Hi,

    Zypper suddenly stopped playing nice with local rpms showing error:

    Code:
    sudo zypper in vivaldi-snapshot-2.4.1455.4-1.x86_64.rpm 
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    '_tmpRPMcache_:srcpackage:vivaldi-snapshot=0:2.4.1455.4-1' not found in package names. Trying capabilities.
    No provider of '_tmpRPMcache_:srcpackage:vivaldi-snapshot=0:2.4.1455.4-1' found.
    It used to work, but not anymore. Happens for other rpms, too (tested with Opera). Installing packages from repos works.

    And:
    Code:
    rpm -i package.rpm
    Works, too.

    How can I fix this?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,178
    Blog Entries
    3

    Default Re: zypper wont install local rpms

    I notice a bug report
    bug 1125300 which says:
    "This bug was already fixed for zypper-1.14.25".

    In any case, just create a directory for rpm files, and put the rpm there. Then go into Yast Software Repositories, and set that directory to be a repo consisting of plain rpm files. It works well.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: zypper wont install local rpms

    Nice, thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •