Results 1 to 4 of 4

Thread: Gaupol and Curlew do not launch

  1. #1

    Default Gaupol and Curlew do not launch

    I am a user of Leap 15 and I want to try Tumbleweed.
    Almost everything works fine but there is a few minor problems with Tumbleweed.

    System Tumbleweed:20190209

    Gaupol and Curlew do not launch.
    I can replace Gaupol by Subtitleeditor and Subtitleeditor works fine.
    Has anyone have this problem with Curlew? Curlew works fine on Leap 15.

    Thermal monitor plasmoid:
    Plasmoid does not show CPU temperature immediately and I have to reload temperature sources.
    I did sensors-detect.





  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,125
    Blog Entries
    2

    Default Re: Gaupol and Curlew do not launch

    Hi,
    You seem to have left out information.

    I assume that you upgraded your LEAP to Tumbleweed or did you install Tumbleweed as a new install?

    Also, I'm going to assume by saying the apps "do not launch" that you may be clicking on menu items.
    If that is the case, try launching them from within a windowed console like xterm or Konsole. If this is successful, then you have a problem with the menu entry... Otherwise if the app still fails to start then you will likely see error information useful for troubleshooting.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Gaupol and Curlew do not launch

    Hi,
    This is my fault that I have left out information.

    I installed Tumbleweed as new install on my second drive.

    "Not launch" - I mean clicking on menu items.

    In Konsole there is an info for:

    Gaupol
    (python3:5112): Gtk-CRITICAL **: 18:59:50.212: _gtk_style_provider_private_get_settings:
    assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

    (python3:5112): Gtk-CRITICAL **: 18:59:50.212: _gtk_style_provider_private_get_settings:
    assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

    (python3:5112): Gtk-CRITICAL **: 18:59:50.212: _gtk_style_provider_private_get_settings:
    assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed



    Curlew

    (python3:4978): Gtk-WARNING **: 18:58:19.675: Theme parsing error: gtk.css:127:35: The s
    tyle property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore
    . It will be removed in a future version

    (python3:4978): Gtk-WARNING **: 18:58:19.675: Theme parsing error: gtk.css:128:35: The s
    tyle property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore
    . It will be removed in a future version
    Traceback (most recent call last):
    File "/usr/lib/python3.7/site-packages/curlew/curlew.py", line 2805, in do_activate
    win = Curlew(self, *self.args)
    File "/usr/lib/python3.7/site-packages/curlew/curlew.py", line 356, in __init__
    self.btn_convert = Gtk.Button(_('Convert'))
    TypeError: GObject.__init__() takes exactly 0 arguments (1 given)

    Curlew with root

    Traceback (most recent call last):
    File "/usr/bin/curlew", line 5, in <module>
    main(*sys.argv[1:])
    File "/usr/lib/python3.7/site-packages/curlew/curlew.py", line 2828, in main
    if dbus.SessionBus().request_name("org.curlew") != \
    File "/usr/lib/python3.7/site-packages/dbus/_dbus.py", line 211, in __new__
    mainloop=mainloop)
    File "/usr/lib/python3.7/site-packages/dbus/_dbus.py", line 100, in __new__
    bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
    File "/usr/lib/python3.7/site-packages/dbus/bus.py", line 122, in __new__
    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
    dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a rep
    ly. Possible causes include: the remote application did not send a reply, the message bu
    s security policy blocked the reply, the reply timeout expired, or the network connectio
    n was broken.


  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,125
    Blog Entries
    2

    Default Re: Gaupol and Curlew do not launch

    I installed both into an updated Tumbleweed.

    Whether I launched either from the menu entry or from a console, if the app was launched as a normal User I got only warnings and both apps can be used just fine.

    Running Gaupol as an elevated User cause the Critical errors you posted, which should not be done.

    I recommend you launch each from a command line so you can display your errors (they should all be warnings and none should be critical errors) and submit as a low priority bug to https://bugzilla.opensuse.org so that they can be addressed.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •