Results 1 to 4 of 4

Thread: Unable to run Limbo game, SDL/GLX errors

  1. #1

    Default Unable to run Limbo game, SDL/GLX errors

    I had gotten the native Linux version of Limbo, by Playdead, directly from the Humble Bundle website since a while ago (I don't have Steam installed); just now tried to run it.
    FWIW, the installer file's name is "Limbo-Linux-2014-06-08.sh".
    This is certainly a 32bit game.

    As as the title says, I'm just getting SDL errors.

    Here's console outputs, which include all repositories, what I tried -and the errors-, and what packages I have installed.
    https://paste.opensuse.org/view//59500063
    As seen, I also installed the corresponding 32bit versions of all SDL packages installed.

    And here's complete output of glxinfo, which I included since I suspect it may be necessary after my long searches around internet looking for info about my problem.
    https://paste.opensuse.org/view//94789201

    After looking for the SDL errors around internet, I saw many websites just blamed old GPUs not supporting a minimum OpenGL version. But I really don't think this is the case. I also tried the game on an older crappy laptop with Leap 42.3, Mesa 17.0.x, and Intel graphics driver i915, which doesn't even support OpenGL 3.x; and in this laptop Limbo ran perfectly out of the box.

    Oh, and I tried another SDL2 game -supertux2 in this case-, and it also ran very well.

    Could anyone help with this?
    Thanks beforehand.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,648

    Default Re: Unable to run Limbo game, SDL/GLX errors

    Sure you have the needed 32 bit libraries???

  3. #3

    Default Re: Unable to run Limbo game, SDL/GLX errors

    Well, actually no, not sure.
    As pointed in the first pastebin, I only installed 32bit libraries of the already installed 64bit SDL libraries.
    In a dumb attempt I even just did "zypper in libSDL*", but this didn't change the results.

    But there's little to no information in the official website or around internet. I don't know what changed from Leap 42.3 to 15.0 affecting this, or what additional packages in 42.3 made the game work.

    This is why I finally posted here. I hoped someone could help here with all the info in the pastebins...

    Thanks again.

  4. #4

    Default Re: Unable to run Limbo game, SDL/GLX errors

    Actually, your post served a lot.
    With that in mind I did different google searches, found different answers, found one that sounded logic, compared with old laptop with 42.3, installed the package, and finally worked!
    Missing package: Mesa-libGL1-32bit
    (I want to think this also obviously pulls glibc 32 bit as well...)

    Thanks very much for the hint, sir.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •