Results 1 to 9 of 9

Thread: Screen resolution problem with nVidia card

  1. #1

    Question Screen resolution problem with nVidia card

    So you guys have been very helpful so far with my past problems so far it has been a line of problems with my hardware compatibility. Here is the line of problems that lead up to this one.
    first one https://forums.opensuse.org/showthre...r-will-not-run
    second one https://forums.opensuse.org/showthre...41#post2894141
    This is what lead up to my current one. So I have a PC with a nVidia GPU and a ryzen 3 2200g intergrated graphics. at first it would not run with my GPU and i had to set the vega 8 graphics to forced. now it will run with both, but the resolution is really low it is
    1024 x 768 with both my GPU and APU (it was also that before i got my GPU to work.
    My monitor is a HP S2021a but it appears as a unknown monitor to my OS.
    I added iommu=soft to the boot thing to get it to work, I also have the gl503 nVidia drivers I was told they are the correct drivers for my GPU
    If you need more details ask here or check other thread post. My parts:
    CPU: Ryzen 3 2200g
    GPU: gigabyte G1 geforce gtx 1060
    Integrated Graphics: vega 8
    Ram: 16gb of HyperX 3000mhz predator RAM (2 8gb sticks)
    MB: gigabyte ga-ab350-gaming 3 Storage, M.2 crucial 500mx and a 250gb 2.5 form factor crucial ssd
    500w EVGA psu
    case: thermaltake veiw 31
    Mouse: Logictech G502
    Head set: razer man O war
    KB: a old hp one
    Internet is my Ethernet

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,469
    Blog Entries
    15

    Default Re: Screen resolution problem with nVidia card

    Hi
    OK, probably best to get some more info...

    Can you post the output from (as your user);

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    xrandr
    echo $XDG_SESSION_TYPE
    If that last command shows 'x11' can you upload your ~/.local/share/xorg/Xorg.0.log to say https://susepaste.org/ (Please set expire to never).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Screen resolution problem with nVidia card

    Quote Originally Posted by malcolmlewis View Post
    Hi
    OK, probably best to get some more info...

    Can you post the output from (as your user);

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    xrandr
    echo $XDG_SESSION_TYPE
    If that last command shows 'x11' can you upload your ~/.local/share/xorg/Xorg.0.log to say https://susepaste.org/ (Please set expire to never).
    Code:
    linux-3eog:~ # /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1)
            Subsystem: Gigabyte Technology Co., Ltd Device [1458:3739]
            Kernel modules: nouveau
    01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)
    linux-3eog:~ # xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected primary 1024x768+0+0 0mm x 0mm
       1024x768      76.00* 
    linux-3eog:~ # echo $XDG_SESSION_TYPE
    here did not have time to read it gtg rn
    Last edited by malcolmlewis; 11-Feb-2019 at 19:49. Reason: Add code tags

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,469
    Blog Entries
    15

    Default Re: Screen resolution problem with nVidia card

    Quote Originally Posted by aCyborg View Post
    Code:
    linux-3eog:~ # /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1)
            Subsystem: Gigabyte Technology Co., Ltd Device [1458:3739]
            Kernel modules: nouveau
    01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)
    linux-3eog:~ # xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected primary 1024x768+0+0 0mm x 0mm
       1024x768      76.00* 
    linux-3eog:~ # echo $XDG_SESSION_TYPE
    here did not have time to read it gtg rn
    Hi
    I would look at adding the Nvidia repository and installing the proprietary driver, or did you wish to install the 'Hard Way'?

    https://en.opensuse.org/SDB:NVIDIA_drivers

    https://en.opensuse.org/SDB:NVIDIA_the_hard_way
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Screen resolution problem with nVidia card

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I would look at adding the Nvidia repository and installing the proprietary driver, or did you wish to install the 'Hard Way'?

    https://en.opensuse.org/SDB:NVIDIA_drivers

    https://en.opensuse.org/SDB:NVIDIA_the_hard_way
    I uninstalled the nvidia drivers I had on at the time and then reboot, i was going to add then after i reboot without them and hope it will boot. It did and now the resolution is what it should be!
    I am going to add them again and see what happens will tell you when I do

  6. #6

    Cool Re: Screen resolution problem with nVidia card

    Issue found: The G05 drivers for nVidia make the screen resolution way off on a Gigabyte Geforce GTX G1 1060 This may need more testing. Fix uninstall driver

    What driver should i use if I can't use the G05 drivers?

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,469
    Blog Entries
    15

    Default Re: Screen resolution problem with nVidia card

    On Tue 12 Feb 2019 12:56:03 PM CST, aCyborg wrote:

    Issue found: The G05 drivers for nVidia make the screen resolution way
    off on a Gigabyte Geforce GTX G1 1060 This may need more testing. Fix
    uninstall driver

    What driver should i use if I can't use the G05 drivers?


    Hi
    Try the 04 ones, or install the hard way (That's what I use, it's not
    hard, just a little bit of extra work...)

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  8. #8

    Default Re: Screen resolution problem with nVidia card

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Try the 04 ones, or install the hard way (That's what I use, it's not
    hard, just a little bit of extra work...)

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    I installed the G04 drivers and that has the same problems as using the G05 drivers, so no drivers for now

  9. #9
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,028

    Default Re: Screen resolution problem with nVidia card

    Quote Originally Posted by aCyborg View Post
    I installed the G04 drivers and that has the same problems as using the G05 drivers, so no drivers for now
    Looking back through the three threads you started recently, I missed any evidence you ever attempted to use the default DDX driver. Maybe now is the time. The following is a partial copy & paste from a WIP.

    The generic default FOSS DDX driver is named "modesetting" and provided by the xorg-x11-server package. The major brand hardware-specific DDX drivers are:

    "amdgpu", provided for recent AMD by the xf86-video-amdgpu package,
    "radeon", provided for older AMD/ATI by the xf86-video-ati package,
    "intel", provided mainly for older Intel by the xf86-video-intel package, and
    "nouveau", provided for NVidia by the xf86-video-nouveau package, and not to be confused with the same name nouveau driver provided by the kernel.

    There is no Intel-specific driver provided primarily for newer Intel gfx. Intel pays its Linux driver developers to put most of their effort into the FOSS modesetting DDX driver. The xf86-video-intel DDX is in maintenance mode, having had no official release since 2015.

    Even though modesetting is the default driver, most installations include all xf86-video-* packages, thus overriding the technical default. This is mainly because there are no simple enough rules as to which DDX works best with particular hardware. Installers would be grossly bloated by any attempt to include code and database just to attempt an ideal choice. So, next step is to evaluate performance. If you are happy with it, nothing more need be done. GOTO end.

    If performance seems poor, or what should be a login screen is nothing but black except for a mouse pointer, or worse, next step is to test boot with the nomodeset boot option removed. Do this by striking the "e" key at the bootloader menu as you did when installing, but this time, remove nomodeset before proceeding. If boot proceeds normally, excellent. After you login, open YaST Bootloader, remove nomodeset, then save, and then the change will remain for successive boots.

    If you experience no improvement, or if the improvement seems to fall short of expectations, or if you just want to know how the other DDX driver performs, switch. The easiest way to switch to the modesetting driver is to remove the xf86-video- package in current use, then restart the server or reboot.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •