Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

  1. #1

    Question tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    На ядре 4.19 работало, сейчас после обновления до 4.20 не стартуют иксы с 340.107. Свободный драйвер работает нормально на 4.20

  2. #2
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,029
    Blog Entries
    1

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Как драйвер устанавливали? Больше подробностей.

    Несовместимость с ядром 4.20 есть, как минимум для 390.87.
    https://lists.opensuse.org/opensuse-.../msg00216.html

  3. #3

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Спасибо! Не знаю как, но второй раз после обновы ядра все падает и второй раз удается заставить работать gf9800gtx c 340.107. Вот так сейчас получилось.


    Установил 340.107 из этой репы https://download.nvidia.com/opensuse/leap/15.0

    Code:
    zypper in x11-video-nvidiaG03
    Не стартуют иксы,
    Удалил xorg.conf,
    Далее,

    Code:
     nvidia-xconfig
    profit

    зы правда перед всем пытался безуспешно установить этот https://www.nvidia.com/download/driv...x/135161/en-us но отнего остался /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

    А вообще на будущее, этот драйвер будет совместим с последующими ядрами Линукса?

  4. #4
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,029
    Blog Entries
    1

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Установил 340.107 из этой репы https://download.nvidia.com/opensuse/leap/15.0
    Тут Leap 15, как я вижу. Подозреваю, что не должен подходить для Tumbleweed.

    Я сам использую NVidia 340.107. Пока не обновлялся на 4.20, так как ожидал возможных проблем.
    Обычно, появляются патчи драйвера для нового ядра до выхода новой версии.

    А вообще на будущее, этот драйвер будет совместим с последующими ядрами Линукса?
    Нет, конечно.
    Но решается сначала патчами от энтузиастов, а потом выпуском новой версии драйвера.

  5. #5

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by Lazy_Kent View Post
    Тут Leap 15, как я вижу. Подозреваю, что не должен подходить для Tumbleweed.

    Я сам использую NVidia 340.107. Пока не обновлялся на 4.20, так как ожидал возможных проблем.
    Обычно, появляются патчи драйвера для нового ядра до выхода новой версии.


    Нет, конечно.
    Но решается сначала патчами от энтузиастов, а потом выпуском новой версии драйвера.
    Но как же у меня именно он работает?
    Какой тогда нужен для Tumbleweed?
    Как скоро появляются патчи и как узнать, что драйвер пропатчен под ядро?

    ЗЫ Я наверное ошибся. Как узнать из какой репы установился драйвер? Ставил через консоль командой, что выше.

  6. #6
    Join Date
    Jun 2008
    Location
    Saint-Petersburg, Russia
    Posts
    69

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Поиск по включенным репозиториям:
    Code:
    zypper se -s '*nvidia*'
    Я сам установил на Tumbleweed в первый раз так:
    Code:
    zypper ar https://download.nvidia.com/opensuse/tumbleweed nvidia
    zypper inr
    Обновляю систему только когда вижу пакеты nvidia для нового ядра (первая команда).

  7. #7

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by kkirill View Post
    Поиск по включенным репозиториям:
    Code:
    zypper se -s '*nvidia*'
    Я сам установил на Tumbleweed в первый раз так:
    Code:
    zypper ar https://download.nvidia.com/opensuse/tumbleweed nvidia
    zypper inr
    Обновляю систему только когда вижу пакеты nvidia для нового ядра (первая команда).
    Спасибо! Когда удаляю леап15 репу, система не находит дрова под мою 9800гтикс. А с леап15 репой находит 340,107, последний который поддерживает мою старушку. Судя по Вашей команде
    Code:
    zypper se -s '*nvidia*'
    В репах родных Tumbleweed репах вообще нет 340,107. Удивительно, но 340,107 из лиап15 все работает пока.

    Code:
    linux-6a8l:/home/deepforest # zypper se -s '*nvidia*'
    Loading repository data...
    Reading installed packages...
    
    S  | Name                          | Type       | Version                              | Arch   | Repository                
    ---+-------------------------------+------------+--------------------------------------+--------+---------------------------
    i  | nvidia-computeG03             | package    | 340.107-lp150.12.1                   | x86_64 | 9800                      
       | nvidia-computeG04             | package    | 390.87-10.3                          | x86_64 | NVIDIA                    
       | nvidia-computeG04             | package    | 390.87-10.3                          | x86_64 | nVidia Graphics Drivers   
       | nvidia-computeG04             | package    | 390.87-lp150.10.2                    | x86_64 | 9800                      
       | nvidia-computeG04             | package    | 390.87-10.3                          | i586   | NVIDIA                    
       | nvidia-computeG04             | package    | 390.87-10.3                          | i586   | nVidia Graphics Drivers   
       | nvidia-computeG05             | package    | 410.93-7.1                           | x86_64 | NVIDIA                    
       | nvidia-computeG05             | package    | 410.93-7.1                           | x86_64 | nVidia Graphics Drivers   
       | nvidia-computeG05             | package    | 410.93-lp150.7.1                     | x86_64 | 9800                      
    i  | nvidia-gfxG03-kmp-default     | package    | 340.107_k4.12.14_lp150.11-lp150.12.1 | x86_64 | 9800                      
       | nvidia-gfxG04-kmp-default     | package    | 390.87_k4.19.11_1-10.16              | x86_64 | NVIDIA                    
       | nvidia-gfxG04-kmp-default     | package    | 390.87_k4.19.11_1-10.16              | x86_64 | nVidia Graphics Drivers   
       | nvidia-gfxG04-kmp-default     | package    | 390.87_k4.12.14_lp150.11-lp150.10.1  | x86_64 | 9800                      
       | nvidia-gfxG04-kmp-default     | package    | 390.87_k4.19.11_1-10.16              | i586   | NVIDIA                    
       | nvidia-gfxG04-kmp-default     | package    | 390.87_k4.19.11_1-10.16              | i586   | nVidia Graphics Drivers   
       | nvidia-gfxG04-kmp-pae         | package    | 390.87_k4.19.11_1-10.16              | i586   | NVIDIA                    
       | nvidia-gfxG04-kmp-pae         | package    | 390.87_k4.19.11_1-10.16              | i586   | nVidia Graphics Drivers   
       | nvidia-gfxG05-kmp-default     | package    | 410.93_k4.19.11_1-7.1                | x86_64 | NVIDIA                    
       | nvidia-gfxG05-kmp-default     | package    | 410.93_k4.19.11_1-7.1                | x86_64 | nVidia Graphics Drivers   
       | nvidia-gfxG05-kmp-default     | package    | 410.93_k4.12.14_lp150.11-lp150.7.1   | x86_64 | 9800                      
    i  | nvidia-glG03                  | package    | 340.107-lp150.12.1                   | x86_64 | 9800                      
       | nvidia-glG04                  | package    | 390.87-10.3                          | x86_64 | NVIDIA                    
       | nvidia-glG04                  | package    | 390.87-10.3                          | x86_64 | nVidia Graphics Drivers   
       | nvidia-glG04                  | package    | 390.87-lp150.10.2                    | x86_64 | 9800                      
       | nvidia-glG04                  | package    | 390.87-10.3                          | i586   | NVIDIA                    
       | nvidia-glG04                  | package    | 390.87-10.3                          | i586   | nVidia Graphics Drivers   
       | nvidia-glG05                  | package    | 410.93-7.1                           | x86_64 | NVIDIA                    
       | nvidia-glG05                  | package    | 410.93-7.1                           | x86_64 | nVidia Graphics Drivers   
       | nvidia-glG05                  | package    | 410.93-lp150.7.1                     | x86_64 | 9800                      
       | nvidia-texture-tools          | package    | 2.0.8-3.5                            | x86_64 | openSUSE:Factory          
       | nvidia-texture-tools          | package    | 2.0.8-3.5                            | x86_64 | openSUSE-20181129-0       
       | nvidia-texture-tools          | package    | 2.0.8-3.5                            | i586   | openSUSE:Factory          
       | nvidia-texture-tools          | package    | 2.0.8-3.5                            | i586   | openSUSE-20181129-0       
       | nvidia-texture-tools          | srcpackage | 2.0.8-3.5                            | noarch | openSUSE-Tumbleweed-Source
    i  | nvidia-uvm-gfxG03-kmp-default | package    | 340.107_k4.12.14_lp150.11-lp150.12.1 | x86_64 | 9800                      
       | pcp-pmda-nvidia-gpu           | package    | 4.2.0-1.1                            | x86_64 | openSUSE:Factory          
       | pcp-pmda-nvidia-gpu           | package    | 4.2.0-1.1                            | x86_64 | openSUSE-20181129-0       
       | pcp-pmda-nvidia-gpu           | package    | 4.2.0-1.1                            | i586   | openSUSE:Factory          
       | pcp-pmda-nvidia-gpu           | package    | 4.2.0-1.1                            | i586   | openSUSE-20181129-0       
    i+ | x11-video-nvidiaG03           | package    | 340.107-lp150.12.1                   | x86_64 | 9800                      
       | x11-video-nvidiaG04           | package    | 390.87-10.3                          | x86_64 | NVIDIA                    
       | x11-video-nvidiaG04           | package    | 390.87-10.3                          | x86_64 | nVidia Graphics Drivers   
       | x11-video-nvidiaG04           | package    | 390.87-lp150.10.2                    | x86_64 | 9800                      
       | x11-video-nvidiaG04           | package    | 390.87-10.3                          | i586   | NVIDIA                    
       | x11-video-nvidiaG04           | package    | 390.87-10.3                          | i586   | nVidia Graphics Drivers   
       | x11-video-nvidiaG05           | package    | 410.93-7.1                           | x86_64 | NVIDIA                    
       | x11-video-nvidiaG05           | package    | 410.93-7.1                           | x86_64 | nVidia Graphics Drivers   
       | x11-video-nvidiaG05           | package    | 410.93-lp150.7.1                     | x86_64 | 9800                      
    linux-6a8l:/home/deepforest #

  8. #8

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Так что я прав в том, что 340.107 есть только в Леап15? А как узнать подходит ли драйвер к новому ядру?

  9. #9

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by deepforest View Post
    А как узнать подходит ли драйвер к новому ядру?
    версия с ядра с которым собран модуль указывается в имени пакета nvidia-gfxG03-kmp-340.107_kВЕРСИЯ_ЯДРА-lp150.12.1
    «Если не говорить пользователям, что линукс это сложно и страшно, то им совершенно все равно, в чем не разбираться. » — ЛОР

  10. #10
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,029
    Blog Entries
    1

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    На мой взгляд, лучше всего устанавливать драйвер NVidia в Tumbleweed установщиком ***.run с сайта производителя.
    Называется "Сложный способ".

    Как-то раз я попробовал установить драйвер для текущего ядра в Tumbleweed из репозитория. На тот момент был такой. Потом перестал обновляться.
    Как мне показалось, потянул за собой дополнительные зависимости. И установка заняла приличное количество времени.

    Насколько понял, производилась компиляция модуля на локальном компьютере. Много дольше, чем установка из "нвидевского" установщика.
    Поэтому допускаю, что пакет из Leap компилирует модуль для ядра Tumbleweed и работает.
    Last edited by Lazy_Kent; 01-Feb-2019 at 09:35. Reason: Инструкция на русском языке не внушает доверия. Дал ссылку на английский.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •