Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

  1. #1
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,472

    Default Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Just did a fresh Tumbleweed install with Plasma
    Installed smplayer, mplayer, VLC. They all come from openSUSE repos.
    Much not even offered from Packman.
    Not even video codecs as far as my search has shown.
    If I try and change provider to Packman endless unresolved libs and other files it's just a hell of requires but not provided and so forth. openSUSE files are old versions in many caces.
    What has happened? We use to be able to simply installed the package from Packman and it just worked.. Now openSUSE has decided it will ship all these players with broken codecs.
    I can't even watch a video. I get audio but no video.
    What happened to the codecs from Packman?
    How are we supposed to fix this?
    Tumbleweed

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,772
    Blog Entries
    15

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Quote Originally Posted by FlameBait View Post
    Just did a fresh Tumbleweed install with Plasma
    Installed smplayer, mplayer, VLC. They all come from openSUSE repos.
    Much not even offered from Packman.
    Not even video codecs as far as my search has shown.
    If I try and change provider to Packman endless unresolved libs and other files it's just a hell of requires but not provided and so forth. openSUSE files are old versions in many caces.
    What has happened? We use to be able to simply installed the package from Packman and it just worked.. Now openSUSE has decided it will ship all these players with broken codecs.
    I can't even watch a video. I get audio but no video.
    What happened to the codecs from Packman?
    How are we supposed to fix this?
    Hi
    The packman repository is a third party provider, you need to followup with them... I would surmise the recent update along with gstreamer (AFAIK bad) breakages mean things need fixing, submitting, review etc before they get updated.

    For example;
    http://lists.links2linux.de/pipermai...ry/015835.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,472

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    My wonder is why the packagers have decided to do everything they can to make sure multimedia doesn't just work anymore? When you try and switch to Packman you get irresolvable packages to here and back. Why did my installation of 5 hours ago just play these files and my new installation just doesn't? h264 isn't in the openSUSE VLC so no video. VLC ships with the correct codecs. If you try and switch to Packman VLC a wall of irresolvable packages. Try and play a video in smplayer. No video. Look of h264 in Yast and you won't find it. What has happened? Is the distro trying to run people who need multimedia off?
    Tumbleweed

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,772
    Blog Entries
    15

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Quote Originally Posted by FlameBait View Post
    My wonder is why the packagers have decided to do everything they can to make sure multimedia doesn't just work anymore? When you try and switch to Packman you get irresolvable packages to here and back. Why did my installation of 5 hours ago just play these files and my new installation just doesn't? h264 isn't in the openSUSE VLC so no video. VLC ships with the correct codecs. If you try and switch to Packman VLC a wall of irresolvable packages. Try and play a video in smplayer. No video. Look of h264 in Yast and you won't find it. What has happened? Is the distro trying to run people who need multimedia off?
    Hi
    Because things a being rebuilt all the time at the moment (which do filter through to packman), some things need a manual trigger to get them going again.

    Have you looked at OBS...? Head down to the bottom... it's very busy at the moment... 80,000 jobs blocked for x86_64...
    https://build.opensuse.org/monitor
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,772
    Blog Entries
    15

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Hi
    If you look at VLC, it's failing to build both on OBS and Packman...

    https://build.opensuse.org/package/s...media:libs/vlc

    https://pmbs.links2linux.de/package/show/Essentials/vlc
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,472

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Oh. That's a lot of packages. How did they manage not breaking existing installs multimedia? There's been a ongoing forcing of openSUSE packages pushing out Packman packages slowly over time. VLC was just one. You either accept or don't dup. The security implications of that are not ideal. Oh well can't be helped. You progress or you don't but it makes openSUSE less attractive in the meantime. I can't see shipping a multimedia player like VLC that can't do h264 which is now not encumbered by any patents. I mean it's willfully broken and openSUSE decided it was going to push Packman aside.
    Tumbleweed

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,772
    Blog Entries
    15

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Quote Originally Posted by FlameBait View Post
    Oh. That's a lot of packages. How did they manage not breaking existing installs multimedia? There's been a ongoing forcing of openSUSE packages pushing out Packman packages slowly over time. VLC was just one. You either accept or don't dup. The security implications of that are not ideal. Oh well can't be helped. You progress or you don't but it makes openSUSE less attractive in the meantime. I can't see shipping a multimedia player like VLC that can't do h264 which is now not encumbered by any patents. I mean it's willfully broken and openSUSE decided it was going to push Packman aside.
    Hi
    If VLC is the only thing your wanting then look at switching to VideoLan rather than packman?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,472

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    VLC is only a last resort.
    I'd much prefer MVP / Smplayer was working. with video and subtitle support.
    If it won't play then use VLC.
    Tumbleweed

  9. #9
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,472

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Well still no H264 decoding. VLC actually says it's missing the H264 codec.
    I've got gstreamer-plugins-bad from Packman installed.
    What else is missing that's blocking video playback in mvp or vlc?
    I know they some packages are still building but vlc and mvp don't complain of missing dependencies.
    I hear the audio just fine.
    Tumbleweed

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,772
    Blog Entries
    15

    Default Re: Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

    Quote Originally Posted by FlameBait View Post
    Well still no H264 decoding. VLC actually says it's missing the H264 codec.
    I've got gstreamer-plugins-bad from Packman installed.
    What else is missing that's blocking video playback in mvp or vlc?
    I know they some packages are still building but vlc and mvp don't complain of missing dependencies.
    I hear the audio just fine.
    Hi
    Still fixes for VLC in the wind... an update has just been pushed to multimedia:libs... https://build.opensuse.org/request/show/674185
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •