Results 1 to 7 of 7

Thread: Autofs not working

  1. #1

    Default Autofs not working

    I just reinstalled Tumbleweed. I saved the Autofs config files that were working from the previous build and copied them to /etc.

    Autofs has been installed and enabled.

    This is auto.master:
    Code:
    /mnt/tower /etc/auto.tower  --timeout=60
    +auto.master
    This is the auto.tower file:
    Code:
    home   -rw,soft,intr,rsize=8192,wsize=8192 tower:/home/mmontz
    raid   -rw,soft,intr,rsize=8192,wsize=8192 tower:/mnt/raid
    Directory tower has been created in /mnt

    Code:
    s showmount -e tower
    Export list for tower:
    /home/mmontz *
    /mnt/raid    *
    I can manually mount the shares without issue. I can find nothing in the logs showing a problem.

    Have I missed something?

    Thanks,
    Michael

  2. #2

    Default Re: Autofs not working

    Additional info:

    Code:
    sudo automount -f -v
    Starting automounter version 5.1.5, master map auto.master
    using kernel protocol version 5.03
    lookup(yp): read of master map auto.master failed: Request arguments bad
    mounted indirect on /mnt/tower with timeout 60, freq 15 seconds

  3. #3

    Default Re: Autofs not working

    Nevermind I resolved it though I am not sure how unfortunately.

    Although I still get this error when running:

    Code:
    sudo automount -f -v Starting automounter version 5.1.5, master map auto.master
    using kernel protocol version 5.03
    lookup(yp): read of master map auto.master failed: Request arguments bad

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    11,620
    Blog Entries
    3

    Default Re: Autofs not working

    Quote Originally Posted by mmontz View Post
    Although I still get this error when running:
    That seems to come from a yp (nis) lookup. If you are not actually using nis, and everything works, it is probably safe to ignore that. You can perhaps experiment with commenting out the "+auto.master" line, as I think that's what triggers a nis lookup.

    I looked over your post earlier, but could not see what was causing the problem. So I'm glad you have it fixed, even if you are not sure how.
    openSUSE Leap 15.0; KDE Plasma 5;
    testing Leap 15.1.

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,246

    Question Re: Autofs not working

    @mmontz:

    If I'm reading your post correctly, you're using the systemd “autofs.service” but, you're neither restarting the autofs service by means of “systemctl restart” nor, checking the status by means of “systemctl status” …

    Huh?

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,246

    Question Re: Autofs not working

    Quote Originally Posted by mmontz View Post
    This is auto.master:
    Code:
    /mnt/tower /etc/auto.tower  --timeout=60
    +auto.master
    The 2nd field should include an explicit indication of the “map-type” if unexpected behaviour of the “+auto.master” line is to be avoided: “file:/etc/auto.tower” …

    Quote Originally Posted by mmontz View Post
    This is the auto.tower file:
    Code:
    home   -rw,soft,intr,rsize=8192,wsize=8192 tower:/home/mmontz
    raid   -rw,soft,intr,rsize=8192,wsize=8192 tower:/mnt/raid
    man 5 nfs:
    intr / nointr This option is provided for backward compatibility. It is ignored after kernel 2.6.25.
    I'm no longer a fan of using the “rsize” and “wsize” options – current NFS seems to be able to look after itself: <http://nfs.sourceforge.net/nfs-howto/ar01s05.html>.
    The “rw” option is currently the default value.

    Quote Originally Posted by mmontz View Post
    I can manually mount the shares without issue. I can find nothing in the logs showing a problem.
    By “cd /mnt/home/” or “cd /mnt/raid/” or how?

  7. #7
    Join Date
    Sep 2012
    Posts
    4,848

    Default Re: Autofs not working

    Quote Originally Posted by mmontz View Post
    Although I still get this error when running
    If map name does not contain explicit type and does not look like file name, automountd tries to look it up using map sources configured in /etc/nsswitch.conf. Default nsswitch.conf contains "nis" for "automount". If you do not have any external map sources, just delete "+auto.master" line or adjust nsswitch.conf to list only map sources you actually have.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •