Results 1 to 5 of 5

Thread: packagekit check for update settings no longer honored after LEAP 42.3 -> 15.0 upgrade

  1. #1

    Default packagekit check for update settings no longer honored after LEAP 42.3 -> 15.0 upgrade

    On LEAP 42.3, I had my packagekit settings set to check for updates only once a month. When I upgraded from LEAP 42.3 to LEAP 15.0, packagekit no longer honors that setting. I have intentionally tried changing the setting and then changing it back; however, no matter what I do, packagekit always checks for updates.

    It seems that there is something wrong here and that packagekit should honor the settings.

    Personally, I manually check for updates almost every time I log in, therefore, I do not find that packagekit automatically checking for updates is convenient for me. Most of the time, the manual check for updates complains that packagekit is running and asks me if I would like to ask packagekit to quit. As such, I would like to prevent packagekit from checking for updates, yet there is no "never check for updates" setting. I have thought about, but have been reluctant to remove packagekit. Is packagekit something that can be removed or is it a critical component of application/software installation?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: packagekit check for update settings no longer honored after LEAP 42.3 -> 15.0 upgrade

    As far as I know, it is safe to uninstall packagekit. It is only used by desktop update applets.

    Or maybe you can turn it off in your desktop. For Plasma, I just turn it off. I go to "System Tray Settings" (by right clicking on the tray). And then I uncheck the box for the update applet. I think you can also turn it off in XFCE. I do not know how to turn it off for Gnome.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: packagekit check for update settings no longer honored after LEAP 42.3 -> 15.0 upgrade

    Quote Originally Posted by nrickert View Post
    As far as I know, it is safe to uninstall packagekit.
    Yes, it is. As a matter of course at installation, I have been removing all of packagekit and tabooing it for several openSUSE versions, now, with no issues.

    Or maybe you can turn it off in your desktop. For Plasma, I just turn it off. I go to "System Tray Settings" (by right clicking on the tray). And then I uncheck the box for the update applet. I think you can also turn it off in XFCE. I do not know how to turn it off for Gnome.
    I use XFCE, and I think it can be turned off there, but it has been so long now that I do know for sure. I just know I have made it one of my install kill-and-taboo routines.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  4. #4

    Default Re: packagekit check for update settings no longer honored after LEAP 42.3 -> 15.0 upgrade

    Thanks for the help everyone!

    Quote Originally Posted by nrickert View Post
    As far as I know, it is safe to uninstall packagekit. It is only used by desktop update applets.

    Or maybe you can turn it off in your desktop. For Plasma, I just turn it off. I go to "System Tray Settings" (by right clicking on the tray). And then I uncheck the box for the update applet. I think you can also turn it off in XFCE. I do not know how to turn it off for Gnome.
    I am running KDE and plasma, and it appears that I did not right-click in the right spot to find "System Tray Settings". Right-clicking appears to be very sensitive to where you right-click. I did, eventually, find it.

    However, my patience had worn thin by then. After a botched attempt at uninstalling package kit (I made the mistake of uninstalling a couple of libs that are required for a bunch of other stuff - no big deal as I have Image for Linux and a recent image backup), I uninstalled packagekit. I then rebooted and logged in and got a message that the update application could not talk to package kit. So, I searched the software manager for "update" and found a plasma update manager that I uninstalled. This removed the message, and running a manual update check took no time at all. All else seems well at this point.

    Thanks again for the help.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: packagekit check for update settings no longer honored after LEAP 42.3 -> 15.0 upgrade

    Quote Originally Posted by wiyosaya View Post
    I am running KDE and plasma, and it appears that I did not right-click in the right spot to find "System Tray Settings". Right-clicking appears to be very sensitive to where you right-click.
    Yes, it is sensitive.

    In any case, I'm glad you now have things working the way that you want.
    openSUSE Leap 15.1; KDE Plasma 5;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •