Results 1 to 9 of 9

Thread: Tumbleweed Dist Upgrade New Conflicting Problems

  1. #1

    Angry Tumbleweed Dist Upgrade New Conflicting Problems

    Hello,

    Up until now everything went smoothly with OpenSuse Tumbleweed. But recently i got some problems while trying to upgrade as usual... Python packages started to conflict. It's a bit mess for me as i use this machine for development and i don't want to make any package non working or absent from the system, so now i am just waiting to see if this will be solved in the near future. Also i want to ask what would you suggest?

    Code:
    sudo zypper dup
    [sudo] password for root:  
    Retrieving repository 'openSUSE' metadata ............................................................................................[done]
    Building repository 'openSUSE' cache .................................................................................................[done]
    Retrieving repository 'packman' metadata .............................................................................................[done]
    Building repository 'packman' cache ..................................................................................................[done]
    Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata .........................................................................[done]
    Building repository 'openSUSE-Tumbleweed-Non-Oss' cache ..............................................................................[done]
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you co
    ntinue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    11 Problems:
    Problem: python3-xarray-0.11.2-1.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
    Problem: python3-traittypes-0.2.1-1.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
    Problem: libreoffice-pyuno-6.2.0.3-1.3.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-3.7.2-2.1.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Automat-0.6.0-1.4.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Babel-2.6.0-2.2.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Bottleneck-1.2.1-1.5.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-CairoSVG-2.1.3-2.2.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Cycler-0.10.0-3.2.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Cython-0.28.5-2.4.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Genshi-0.7-8.2.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    
    Problem: python3-xarray-0.11.2-1.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
      deleted providers: python3-base-3.6.5-3.3.x86_64
     Solution 1: deinstallation of python3-xarray-0.11.2-1.1.noarch
     Solution 2: keep obsolete python3-base-3.6.5-3.3.x86_64
     Solution 3: break python3-xarray-0.11.2-1.1.noarch by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 
    
    
    Trying one of the solutions bring more other similar problems, eventually touching not only the python dev env, but also libre-office plugings and so on...

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,194
    Blog Entries
    15

    Default Re: Tumbleweed Dist Upgrade New Conflicting Problems

    Quote Originally Posted by aramgrigoryan View Post
    Hello,

    Up until now everything went smoothly with OpenSuse Tumbleweed. But recently i got some problems while trying to upgrade as usual... Python packages started to conflict. It's a bit mess for me as i use this machine for development and i don't want to make any package non working or absent from the system, so now i am just waiting to see if this will be solved in the near future. Also i want to ask what would you suggest?

    Code:
    sudo zypper dup
    [sudo] password for root:  
    Retrieving repository 'openSUSE' metadata ............................................................................................[done]
    Building repository 'openSUSE' cache .................................................................................................[done]
    Retrieving repository 'packman' metadata .............................................................................................[done]
    Building repository 'packman' cache ..................................................................................................[done]
    Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata .........................................................................[done]
    Building repository 'openSUSE-Tumbleweed-Non-Oss' cache ..............................................................................[done]
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you co
    ntinue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    11 Problems:
    Problem: python3-xarray-0.11.2-1.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
    Problem: python3-traittypes-0.2.1-1.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
    Problem: libreoffice-pyuno-6.2.0.3-1.3.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-3.7.2-2.1.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Automat-0.6.0-1.4.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Babel-2.6.0-2.2.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Bottleneck-1.2.1-1.5.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-CairoSVG-2.1.3-2.2.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Cycler-0.10.0-3.2.noarch requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Cython-0.28.5-2.4.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    Problem: python3-Genshi-0.7-8.2.x86_64 requires python(abi) = 3.7, but this requirement cannot be provided
    
    Problem: python3-xarray-0.11.2-1.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
      deleted providers: python3-base-3.6.5-3.3.x86_64
     Solution 1: deinstallation of python3-xarray-0.11.2-1.1.noarch
     Solution 2: keep obsolete python3-base-3.6.5-3.3.x86_64
     Solution 3: break python3-xarray-0.11.2-1.1.noarch by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 
    
    
    Trying one of the solutions bring more other similar problems, eventually touching not only the python dev env, but also libre-office plugings and so on...

    Thanks
    Hi
    With the recent Tumbleweed update to python 3.7, this is the expected fallout waiting for things to rebuild (perhaps fail and need fixing as well).

    It could also be an out of date mirror not fully synced, you could try forcing a refresh and try again, or look at using a specific mirror in your locale (openSUSE Download Mirrors - Overview);

    Code:
    zypper ref -f
    zypper -vvv dup
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Tumbleweed Dist Upgrade New Conflicting Problems

    I just removed some packages which became absent from repos... i guess with tumbleweed and python best is to have additional packages installed with pip rather from repos...
    Quote Originally Posted by malcolmlewis View Post
    Hi
    With the recent Tumbleweed update to python 3.7, this is the expected fallout waiting for things to rebuild (perhaps fail and need fixing as well).

    It could also be an out of date mirror not fully synced, you could try forcing a refresh and try again, or look at using a specific mirror in your locale (openSUSE Download Mirrors - Overview);

    Code:
    zypper ref -f
    zypper -vvv dup

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,194
    Blog Entries
    15

    Default Re: Tumbleweed Dist Upgrade New Conflicting Problems

    Quote Originally Posted by aramgrigoryan View Post
    I just removed some packages which became absent from repos... i guess with tumbleweed and python best is to have additional packages installed with pip rather from repos...
    Hi
    Well you can search on them and check the status in the development project, sure pip install is possible, then it's additional packages you will need to maintain/update etc...

    What ones did you remove?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Tumbleweed Dist Upgrade New Conflicting Problems

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Well you can search on them and check the status in the development project, sure pip install is possible, then it's additional packages you will need to maintain/update etc...

    What ones did you remove?
    one major package was the skikit-learn ... didn't expect to have this issue though...

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,194
    Blog Entries
    15

    Default Re: Tumbleweed Dist Upgrade New Conflicting Problems

    Quote Originally Posted by aramgrigoryan View Post
    one major package was the skikit-learn ... didn't expect to have this issue though...
    Hi
    It fails to build....
    https://build.opensuse.org/package/s...n-scikit-learn

    Looks like they turned off tests to fix the failure 7 days ago...
    https://build.opensuse.org/package/s...n-scikit-learn

    So it was an issue even before then.... now it's waiting for the rest of the python 3.7 rebuild fallout to finish...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: Tumbleweed Dist Upgrade New Conflicting Problems

    Quote Originally Posted by malcolmlewis View Post
    Hi
    It fails to build....
    https://build.opensuse.org/package/s...n-scikit-learn

    Looks like they turned off tests to fix the failure 7 days ago...
    https://build.opensuse.org/package/s...n-scikit-learn

    So it was an issue even before then.... now it's waiting for the rest of the python 3.7 rebuild fallout to finish...
    is there a way to stay on "more stable" branches of tumbleweed? so how they even could push this snapshot?

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,194
    Blog Entries
    15

    Default Re: Tumbleweed Dist Upgrade New Conflicting Problems

    Quote Originally Posted by aramgrigoryan View Post
    is there a way to stay on "more stable" branches of tumbleweed? so how they even could push this snapshot?
    Hi
    Well if something changes with the supporting packages, there will always be fallout until it's fixed/changed in the development repositories and gets back to factory, once there, through openQA and into the snapshot.

    Packages like that are considered 'leaf' ones so don't stop a snapshot release, if it's important for folks AFAIK, they can contribute tests to be added in openQA so it won't be affected in the future.

    For me, it's rock solid, but I have a look at the changes and then decide to update or not.. https://lists.opensuse.org/opensuse-factory/

    There is tumbleweed-cli that you can rollback to the previous snapshot.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Lightbulb Re: Tumbleweed Dist Upgrade New Conflicting Problems [SOLVED]

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Well if something changes with the supporting packages, there will always be fallout until it's fixed/changed in the development repositories and gets back to factory, once there, through openQA and into the snapshot.

    Packages like that are considered 'leaf' ones so don't stop a snapshot release, if it's important for folks AFAIK, they can contribute tests to be added in openQA so it won't be affected in the future.

    For me, it's rock solid, but I have a look at the changes and then decide to update or not.. https://lists.opensuse.org/opensuse-factory/

    There is tumbleweed-cli that you can rollback to the previous snapshot.
    Yes, this is also a good source http://review.tumbleweed.boombatower.com/
    I guess there is a way to upgrade to a particular snapshot,,, will choose snapshots with score more than 90 in the future...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •