Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Opensuse Will not work with my GPU

  1. #1

    Question Opensuse Will not work with my GPU

    So I got opensuse installed you can see the old problem i had here ----> https://forums.opensuse.org/showthre...r-will-not-run
    To get it installed I had to turn my vega 8 graphics to forced in my BIOS my parts are. So when my vega 8 graphics where forced it installed nicely and when I boot with it forced it and boot into opensuse the resolution is way off.
    CPU: Ryzen 3 2200g
    GPU: gigabyte G1 geforce gtx 1060
    Ram: 16gb of HyperX 3000mhz predator RAM (2 8gb sticks)
    MB: gigabyte ga-ab350-gaming 3 Storage, M.2 crucial 500mx and a 250gb 2.5 form factor crucial ssd
    500w EVGA psu
    case: thermaltake veiw 31
    Mouse: Logictech G502
    Head set: razer man O war
    KB: a old hp one
    Internet is my Ethernet
    When I am using my 1060 to boot it will go to grub and when I select Opensuse 15 it will boot and I will get a lot of "AMD-Vi: Completion-Wait loop"and in there there will be a few "AMD-Vi: Event logged [".
    Some times it will go till it shows a kernal panic error, other times it will just crash at Starting uDev. I also had it on nomodset or somthing one time and it went about the same. This is all the info I remember if you want more please ask and i will see what i can do.

  2. #2

    Exclamation Re: Opensuse Will not work with my GPU

    Quote Originally Posted by aCyborg View Post
    So I got opensuse installed you can see the old problem i had here ----> https://forums.opensuse.org/showthre...r-will-not-run
    To get it installed I had to turn my vega 8 graphics to forced in my BIOS my parts are.
    CPU: Ryzen 3 2200g
    GPU: gigabyte G1 geforce gtx 1060
    Ram: 16gb of HyperX 3000mhz predator RAM (2 8gb sticks)
    MB: gigabyte ga-ab350-gaming 3 Storage, M.2 crucial 500mx and a 250gb 2.5 form factor crucial ssd
    500w EVGA psu
    case: thermaltake veiw 31
    Mouse: Logictech G502
    Head set: razer man O war
    KB: a old hp one
    Internet is my Ethernet

    So when my vega 8 graphics where forced it installed nicely and when I boot with the vega 8 graphics forced it will boot into opensuse the resolution is way off.
    When I am using my 1060 to boot it will go to grub and when I select Opensuse 15 it will boot and I will get a lot of "AMD-Vi: Completion-Wait loop"and in there there will be a few "AMD-Vi: Event logged [".
    Some times it will go till it shows a kernal panic error, other times it will just crash at Starting uDev. I also had nomodset or somthing on one time and it went about the same. This is all the info I remember if you want more please ask and i will see what i can do.
    edited to make more sense.
    If you need more info it mite be in the old forum post.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,763
    Blog Entries
    15

    Default Re: Opensuse Will not work with my GPU

    Hi
    Have you tried adding iommu=soft to the GRUB kernel boot options (YaST -> Bootloader)?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,240

    Default Re: Opensuse Will not work with my GPU

    Reposted from <https://forums.opensuse.org/showthre...r-will-not-run>:
    Quote Originally Posted by aCyborg View Post
    So when my vega 8 graphics where forced it installed nicely and when I boot with the vega 8 graphics forced it will boot into opensuse the resolution is way off.
    It may well be that, to resolve the AMD Vega 8 issue, you'll have to move to Tumbleweed — Linux Kernel version 4.20 …
    • The Leap 15.0 Linux Kernel version 4.12 does support 1st and 2nd generation Ryzen CPUs but, the Vega support may well be insufficient …


    Quote Originally Posted by aCyborg View Post
    When I am using my 1060 to boot it will go to grub and when I select Opensuse 15 it will boot and I will get a lot of "AMD-Vi: Completion-Wait loop"and in there there will be a few "AMD-Vi: Event logged [".
    Meaning that, the GigaByte NVIDIA GeoForce card in the PCI slot hasn't been detected — with the Vega 8 GPU disabled in UEFI/BIOS, you could try booting the installation DVD (or USB stick) and then attempt to reinstall using the existing system information (reinstall only the system partition) and, this time with the NVIDIA driver.
    • You may have to invoke the Rescue System to blacklist the existing “amdgpu” driver: <https://doc.opensuse.org/documentati...recover.rescue>.

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,240

    Default Re: Opensuse Will not work with my GPU

    Quote Originally Posted by aCyborg View Post
    If you need more info it mite be in the old forum post.
    Looking at the Motherboard you've chosen, the following point has arisen:

    In addition, given the point that, you need to use a GPU other than the one integrated with the CPU, consider changing the AMD Ryzen 3 to a version which doesn't have an integrated GPU – IOW a Ryzen without “G” or “GE” attached to the 4 digit code …

  6. #6

    Arrow Re: Opensuse Will not work with my GPU

    Quote Originally Posted by dcurtisfra View Post
    Looking at the Motherboard you've chosen, the following point has arisen:

    In addition, given the point that, you need to use a GPU other than the one integrated with the CPU, consider changing the AMD Ryzen 3 to a version which doesn't have an integrated GPU – IOW a Ryzen without “G” or “GE” attached to the 4 digit code …
    You make it sound so easy to change the processor (it is) but I don't have a extra chip or someone who will give me one, I can't just buy a new CPU for i don't have the money.
    I think my Bios version is the newest from a few months ago I think i have F23 i mite have F22 tho

  7. #7

    Default Re: Opensuse Will not work with my GPU

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Have you tried adding iommu=soft to the GRUB kernel boot options (YaST -> Bootloader)?
    I have not and i do not know how to do that. i am not sure what you mean, if you would please show a screenshot of the place on the bootloader on yast that would help

    Quote Originally Posted by dcurtisfra View Post
    Reposted from <https://forums.opensuse.org/showthre...r-will-not-run>:

    It may well be that, to resolve the AMD Vega 8 issue, you'll have to move to Tumbleweed — Linux Kernel version 4.20 …
    • The Leap 15.0 Linux Kernel version 4.12 does support 1st and 2nd generation Ryzen CPUs but, the Vega support may well be insufficient …



    Meaning that, the GigaByte NVIDIA GeoForce card in the PCI slot hasn't been detected — with the Vega 8 GPU disabled in UEFI/BIOS, you could try booting the installation DVD (or USB stick) and then attempt to reinstall using the existing system information (reinstall only the system partition) and, this time with the NVIDIA driver.
    • You may have to invoke the Rescue System to blacklist the existing “amdgpu” driver: <https://doc.opensuse.org/documentati...recover.rescue>.
    Ok i will try that soon, also I have not seen any drivers for nvidia cards it mite be that it does not see my card
    I went to Yast and it does show my 1060... but idk what to do

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,763
    Blog Entries
    15

    Default Re: Opensuse Will not work with my GPU

    Quote Originally Posted by aCyborg View Post
    I have not and i do not know how to do that. i am not sure what you mean, if you would please show a screenshot of the place on the bootloader on yast that would help
    Hi
    Here you go, added at the end of the 'Optional Kernel Command Line parameter';

    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Post Re: Opensuse Will not work with my GPU

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Here you go, added at the end of the 'Optional Kernel Command Line parameter';

    Ok i will try that


    I got a pic of the error so if you mite know what it going on...
    It did have the AMD-Vi errors too and stuff like i said before.

    here is the error
    https://i.imgur.com/7Iexf68.jpg

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,763
    Blog Entries
    15

    Default Re: Opensuse Will not work with my GPU

    Quote Originally Posted by aCyborg View Post
    Ok i will try that


    I got a pic of the error so if you mite know what it going on...
    It did have the AMD-Vi errors too and stuff like i said before.

    here is the error
    https://i.imgur.com/7Iexf68.jpg
    Hi
    So you might need to look at running kernel:stable, else have you tried booting the system with a Tumbleweed Live USB to test?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •